Open main menu

Довідка:Візуальний редактор/Посібник користувача

< Help:VisualEditor
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 42% complete.

Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Bahasa Melayu • ‎Basa Sunda • ‎Bikol Central • ‎Cebuano • ‎Cmique Itom • ‎Cymraeg • ‎Deutsch • ‎English • ‎Esperanto • ‎Fiji Hindi • ‎Frysk • ‎Ilokano • ‎Interlingue • ‎Jawa • ‎Lëtzebuergesch • ‎Malagasy • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Napulitano • ‎Nederlands • ‎Oromoo • ‎Picard • ‎Scots • ‎Tagalog • ‎Tiếng Việt • ‎Tûnsî • ‎Türkçe • ‎Yorùbá • ‎Zazaki • ‎asturianu • ‎azərbaycanca • ‎bosanski • ‎català • ‎dansk • ‎eesti • ‎emiliàn e rumagnòl • ‎español • ‎euskara • ‎français • ‎furlan • ‎føroyskt • ‎galego • ‎hrvatski • ‎isiXhosa • ‎italiano • ‎latviešu • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎shqip • ‎slovenčina • ‎slovenščina • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎беларуская (тарашкевіца)‎ • ‎български • ‎македонски • ‎русский • ‎саха тыла • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎ייִדיש • ‎עברית • ‎العربية • ‎تۆرکجه • ‎سنڌي • ‎فارسی • ‎پښتو • ‎मराठी • ‎संस्कृतम् • ‎हिन्दी • ‎অসমীয়া • ‎বাংলা • ‎মেইতেই লোন্ • ‎ਪੰਜਾਬੀ • ‎ଓଡ଼ିଆ • ‎தமிழ் • ‎తెలుగు • ‎ಕನ್ನಡ • ‎മലയാളം • ‎ไทย • ‎မြန်မာဘာသာ • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎日本語 • ‎한국어
PD Зверніть увагу! Коли Ви редагуєте цю сторінку, то погоджуєтесь робити свій внесок під ліцензією CC0. Детальніше про умови ліцензії можна дізнатися на сторінці довідки.
PD
Якщо Ви хочете спробувати Візуальний редактор, не редагуючи статтю,
ось сторінка, де Ви можете вільно його тестувати.

Вам не потрібен обліковий запис, щоб використовувати Візуальний редактор на тій сторінці.

Contents


Відкриття Візуального редактора

Щоб редагувати сторінку, використовуючи Візуальний редактор, натисніть вкладку «Редагувати» у верхній частині сторінки.

Відкриття сторінки для редагування може тривати кілька секунд і довше, якщо вона дуже довга.

Натискання на вкладку «Редагувати код» відкриває класичний редактор вікітексту.

VisualEditor edit tab-uk.png

Ви також можете відкрити Візуальний редактор, натиснувши на посилання «ред.» біля заголовку кожного розділу.
VisualEditor - Section edit links-uk.png

Початок роботи: панель інструментів Візуального редактора

Вигляд панелі інструментів Візуального редактора
Панель інструментів Візуального редактора з'являється вгорі екрану, коли ви починаєте редагувати з його допомогою. На ній є декілька знайомих іконок:

VisualEditor - Toolbar - Undo-redo.png
Скасувати і Повернути зроблені Вами зміни.

VisualEditor Toolbar Headings-uk.png
Випадне меню Заголовки дозволяє змінювати форматування абзацу. Щоб змінити стиль абзацу, поставте курсор у такому абзаці та виберіть елемент із цього меню (виділяти текст непотрібно). Для заголовків розділів використовується форматування «Заголовок», а підрозділів — «Підзаголовок 1», «Підзаголовок 2» тощо. Нормальний формат для тексту — «Абзац».

VisualEditor Toolbar Formatting-uk.png

Форматування: Клацання по «А» відкриває меню.

  • Пункт «Жирний» (Ж) робить виділений текст жирним.
  • Пункт «Курсив» (К) перетворює виділений текст у курсив.
  • Пункт «Верхній індекс» (x2) робить виділений текст меншим і розташовує його трохи вище, ніж навколишній текст.
  • Пункт «Нижній індекс» (x2) робить виділений текст меншим і розташовує його трохи нижче, ніж навколишній текст.
  • Пункт «Закреслення» (S) додає суцільну лінію через виділений текст.
  • Пункт «Комп'ютерний код» (пара фігурних дужок: {}) змінює шрифт виділеного тексту на моноширинний шрифт, що виділяє його з-поміж навколишнього (пропорційного) тексту.
  • Пункт «Підкреслення» (U) додає суцільну лінію під виділеним текстом.
  • Пункт «Мова» (文A) дозволяє Вам позначати мову (наприклад, японську) і напрямок (наприклад, справа наліво) виділеного тексту.
  • Останній пункт (VisualEditor MediaWiki theme clear icon bitmap.png) під назвою «Вилучити» вилучає усе форматування символів з виділеного тексту, включно з посиланнями.

Якщо Ви не виділили жодного тексту, то коли Ви клацнете «A», щоб відкрити меню, і потім виберете бажаний елемент, це форматування буде застосоване до тексту, який Ви почнете набирати, де б не був розташований Ваш курсор.


VisualEditor - Toolbar - Linking.png
Інструмент посилань: Іконка ланцюжка — це інструмент додавання посилань. Натискання на нього (зазвичай після виділення певного тексту) відкриває діалог посилання.

VisualEditor - Cite Pulldown-uk.png
Меню «Джерело»: Меню «Джерело» використовується для додавання вбудованих цитат (або ж «приміток» чи «виносок»). Усі проекти мають доступ до базового формату приміток і можливість повторного використання цитувань з допомогою цього меню. Це меню також дає Вам швидкий доступ до локальних шаблонів цитування, якщо такі увімкнені у Вашій вікі.

(Інструкції з додавання локальних шаблонів цитування до меню «Джерело» у певній вікі доступні на сторінці Візуальний редактор/Інструмент цитування .)


VisualEditor citoid Cite button-uk.png
кнопка ⧼citoid-citefromidtool-title⧽: Якщо у Вашій вікі увімкнений сервіс Citoid, то замість меню Джерело Ви бачитимете кнопку ⧼citoid-citefromidtool-title⧽.

Сервіс Citoid створений для автоматичного заповнення шаблонів цитування.


VisualEditor Toolbar Lists and indentation-uk.png
Списки і відступи: перші два пункти дають змогу форматувати текст як «Маркований список» чи «Нумерований список». Останні два пункти дозволяють зменшувати чи збільшувати рівень відступу пунктів списку.

VisualEditor Insert Menu-uk.png
Вставити: Меню «Вставити» може відрізнятися у деяких проектах. Нижче подано список усіх опцій, які там можуть з'явитися.
  • Іконка «Мультимедіа» (малюночок гір) відкриває діалогове вікно додавання мультимедіа.
  • Іконка «Шаблон» (частинка пазла) дозволяє Вам редагувати шаблони.
  • Елемент «Таблиця» дає змогу вставити таблицю.
  • Пункт «Коментар» (хмарка мовлення) дозволяє Вам вставити коментарі, невидимі для читачів; ці коментарі можна побачити лише в режимі редагування, де вони виділені іконкою зі знаком оклику. Клацання на іконку зі знаком оклику в режимі редагування дозволить Вам відредагувати або вилучити коментар.
  • Іконка «Ієрогліфи» (символ анкх — ☥) дозволяє Вам перейти до вставлення ієрогліфів. (Див. нижче.)
  • Елемент «Блок коду» дає змогу вставити код.
  • Елемент «Нотний запис» дає змогу вставити нотний запис.
  • Іконка «Галерея» (набір фотознімків) дозволяє Вам вставити на сторінку галерею.
  • Іконка «Математична формула» (Σ) відкриває діалог вставлення формул.
  • Елемент «Графік» дає змогу вставити графік.
  • Елемент «Ваш підпис» дає змогу вставляти Ваш вікімедійний користувацький підпис. Він буде сірим (недоступним для вибору), коли Ви будете редагувати певний тип сторінок («простір назв»), такий як простір статей, де підписи вставляти не слід.
  • Іконка «Список приміток» (три книжки) відкриває діалогове вікно, у якому Ви можете визначити у якому місці примітки відображатимуться для читача. Зазвичай таку дію треба робити лише раз для окремої сторінки.

Вставка спеціальних символів: Іконка «Спеціальний символ» (Ω) розташована поруч з меню «Вставити». Після натискання вона відображає діалогове вікно із багатьма спеціальними символами. Натиснувши на певний символ, Ви вставляєте його в текст. Серед цих спеціальних символів — деякі стандартні символи, наголоси та математичні символи. (Це може налаштовуватись локально. Див. інструкції на сторінці Візуальний редактор/Спеціальні символи .)
VisualEditor Toolbar SpecialCharacters-uk.png

VisualEditor toolbar edit notices icon.png
Кнопка Сповіщення показує будь-які сповіщення, які стосуються поточної сторінки.

VisualEditor More Settings-uk.png

Меню Параметри сторінки розташоване зліва від кнопки Зберегти зміни. У цьому меню є опції налаштування параметрів сторінки, таких як те, чи ця сторінка є перенаправленням або як вона індексується; додавання, редагування чи видалення категорій; відображення з допомогою пункту «$language» списку статей на ту ж тему іншими мовами.

  • Категорії allows you to add categories to this page and to adjust how the page is sorted, when displayed within a category by setting a different index to sort with.
  • Налаштування сторінки allows you to make the page a redirect and adjust options of this redirect, to adjust settings regarding the displaying of the Table of Contents, to disable the edit links next to each heading, and to define the page as a disambiguation page.
  • Advanced settings allows you to adjust the settings regarding indexation of the page by search engines, showing a tab to add a new section, and the displayed title.
  • Моваs which shows a list of pages in other languages that are linked to that page.
  • Templates used shows a list of links to each template used on this page.

The tabs of the Options dialog are also displayed in the Параметри сторінки menu and can be opened by clicking on it. Furthermore the Параметри сторінки menu contains the button View as right-to-left and the button Find and replace which opens a dialog where you can insert characters, terms or Regular expressions you are searching for and those to replace them with, together with several buttons for options.


VisualEditor bi-directional switching square brackets icon.png
Кнопка $switch розташована поряд з кнопкою Зберегти зміни. Вона дає змогу перемкнутися на редактор вікірозмітки.

Збереження змін

Після завершення редагування, натисніть синю кнопку «Зберегти зміни» на панелі інструментів. Якщо не було внесено жодних змін, ця кнопка буде неактивною (матиме сірий колір). Щоб скасувати усі редагування, просто закрийте вікно браузера, або ж клацніть вкладку «Read» над панеллю інструментів редагування.
VisualEditor toolbar actions-uk.png

Натискання синьої кнопки «Зберегти зміни» відкриває діалогове вікно. У ньому Ви можете ввести короткий опис своїх дій, позначити редагування як незначне, та/або додати цю сторінку у свій «Список спостереження». Поле для опису еквівалентне полю «Короткий опис змін:» у редакторі вікірозмітки.

Ви також можете попередньо переглянути свої зміни за допомогою кнопки «Перевірити свої зміни», аби перед збереженням своїх змін впевнитись, що вони працюють, як належить. Ця функція подібна до тієї, яку виконує кнопка «Показати зміни» у редакторі вікітексту.

Кнопка «Продовжити редагування» повертає Вас до сторінки, яку Ви редагували. Ви можете зберегти свої зміни пізніше.

VisualEditor save dialog-uk.png

Редагування посилань

VisualEditor - Toolbar - Linking.png
Посилання можна додавати за допомогою іконки «Посилання» (ланцюжок) на панелі інструментів або використовуючи комбінацію клавіш Ctrl+K (чи Command+K на Mac).

Якщо обрати (виділити) текст, та після цього натиснути кнопку «Посилання», цей текст буде перетворено на посилання. Для посилань у формі одного окремого слова, Ви можете або виділити це слово, або розмістити курсор в його межах.


VisualEditor-link tool-search results-uk.png
Незалежно від того, чи Ви використали кнопку, чи комбінацію клавіш, відкриється діалогове вікно, у якому ви можете набрати посилання.

Інструмент додавання посилань спробує допомогти із внутрішніми посиланнями, шукаючи подібне до того, яке Ви починаєте вводити.


VisualEditor link tool 2015-uk.png
Як тільки Ви введете чи оберете посилання, можете закінчити процес його додавання, натиснувши Enter або кнопку «Готово». Ваше посилання відразу з'явиться на сторінці, але як і інші зміни на сторінці, не буде збережене доти, поки Ви не збережете усю сторінку.

VisualEditor-link tool-external link.png
Щоб вставити посилання на веб-сторінку на іншому сайті, процес той самий: виберіть вкладку «External link» та вставте посилання в поле.

VisualEditor link tool simple link.png
Зовнішні посилання без опису виглядають так: [1]. Ви можете додавати їх, розмістивши курсор на віддалі від будь-якого слова (напр., через пробіл). Натисніть відповідну іконку або комбінацію клавіш, аби відкрити інструмент додавання посилань. Введіть URL-адресу у поле, що з'явилося, та натисніть кнопку «Готово», аби вставити посилання.

VisualEditor-context menu-link tool.png
Щоб змінити або видалити існуюче посилання, клацніть на текст із цим посиланням, після чого натисніть іконку «Посилання», що з'явиться поряд. Відкриється діалогове вікно для редагування. (Ви також можете скористатись комбінацією клавіш Ctrl+K). Коли посилання виділене, воно має синю рамку. У діалозі редагування посилань Ви можете відредагувати ціль посилання. Або видалити його цілковито, натиснувши кнопку «Вилучити» у верхньому правому кутку діалогового вікна.

Ви також можете відкрити ціль посилання у новому вікні, натиснувши копію посилання в діалоговому вікні. (Так можна перевірити, чи зовнішнє посилання дійсне.)

Якщо Ви хочете вийти з діалогу визначення назви посилання (текст посилання) або продовжити писати після цього посилання, натисніть :

  • Якщо клацнути один раз, Ви покинете діалог редагування посилань і Ваш курсор опиниться в кінці елемента, до якого було додано посилання (має синю рамку, щоб редагувати цей елемент)
  • Якщо клацнути двічі, то Ваш курсор опиниться вже після цього елемента, щоб додати решту тексту.

Щоб відредагувати назву існуючого посилання, клацніть на поточній його назві, і введіть нову. Але якщо Ви хочете замінити назву посилання повністю, будь ласка, зверніть увагу:

  • Якщо Ви вибрали (виділили) всю назву посилання, це посилання буде повністю вилучене натисканням будь-якої клавіші. Ви можете створити посилання заново.
  • Щоб зберегти поточне посилання, можна клацнути в межах його назви, скористатися кнопками «backspace» і «delete», не натискаючи їх більше разів ніж потрібно, і вузька синя смужка посилання залишиться на місці. Тепер можна вписати нову назву збереженого посилання.
  • You can also link to categories, files and more.

Редагування приміток

For further information, see Довідка щодо використання шаблонів цитування або Довідка щодо використання кнопки додавання джерел сервісу Citoid

Визначення того, яка система діє

Ваша вікі може використовувати одну з трьох систем додавання приміток. Система, показана справа, є найпростішою. У ній меню «Джерело» не містить жодних шаблонів цитування. Якщо Ваша вікі використовує цю систему, то все, що Вам треба знати про додавання приміток, Ви знайдете на цій сторінці.
VisualEditor cite menu default.png

Друга система має той же тип меню «Джерело», але для швидкого доступу до нього було додано декілька найпопулярніших шаблонів цитувань. Якщо Ваша вікі використовує цю систему, то більше інформації про неї Ви знайдете на сторінці Довідка:Візуальний редактор/Посібник користувача/Шаблони цитування
VisualEditor references more.png

VisualEditor citoid Cite button-uk.png
У третій системі Вам знову доведеться починати з натискання відповідної кнопки. Далі відкриється діалогове вікно, яке містить автоматичний процес додавання примітки за допомогою сервісу Citoid. Якщо Ваша вікі використовує цю систему, то більше інформації про неї Ви зможете знайти на сторінці Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Редагування існуючої примітки

Щоб відредагувати існуючу примітку, клацніть по ній там, де вона з'являється у тексті (зазвичай виглядає як число у квадратних дужках). Ви побачите або іконку «Посилання» (закладка), або іконку (та назву) шаблону, що був використаний для створення цієї примітки. В будь-якому разі, при клацанні кнопки «Редагувати» відкриється діалогове вікно, в якому можна відредагувати цю примітку.
VisualEditor - Editing references 1-uk.png

Що стосується іконки «Посилання», то клацання кнопки «Редагувати» відкриє діалогове вікно редагування примітки. Щоб почати змінювати інформацію примітки, клацніть на ній.

Чимало вікі використовують шаблони для автоматичного форматування приміток. Якщо шаблон використано у Вашій примітці, тоді весь текст у шаблоні буде підсвіченим при клацанні по інформації примітки.

Якщо було використано шаблон і Ви клацнули на інформації у цьому шаблоні, тоді з'явиться іконка «Шаблон» (частинка пазла). Натисніть на неї, щоб редагувати вміст шаблону у діалоговому вікні міні-редактора шаблонів.

VisualEditor - Editing references 6-uk.png

Якщо ж замість іконки «$reference» (закладка), після натискання на примітку з'явиться іконка стандартного шаблона для цитувань, натискання на цю іконку прямо приведе Вас у діалог міні-редактора шаблонів.
VisualEditor - Editing References - Cite Web-uk.png

У міні-редакторі шаблонів Ви можете додавати або вилучати певну інформацію або змінювати поточний вміст шаблону. Початково відображатимуться лише ті поля (параметри шаблону), що заповнені. Додавати поля можна кнопкою «Додати більше інформації» унизу міні-редактора.
VisualEditor - Editing references 5-uk.png

Натисніть «Застосувати зміни», коли завершите.
VisualEditor Apply Changes-uk.png

Повторне використання існуючої примітки

Якщо сторінка уже містить примітки, що стосуються тексту, до якого Ви хочете вказати джерело, Ви можете повторно використати наявне цитування.

Щоб повторно використати існуючу примітку, помістіть курсор туди, де ви хочете додати нове посилання (виноску) на це джерело. Після цього натисніть на іконку «$re-using-reference» в меню «Джерело».

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Джерело" menu.)

VisualEditor Cite menu re-use.png

У діалоговому вікні «Примітка» відшукайте примітку, яку ви бажаєте використати повторно, та виберіть її. Якщо наявна велика кількість приміток, можна використати поле пошуку (із запитанням «Пошук у поточних примітках»), щоб відобразились лише примітки, що містять певний текст.
VisualEditor - Editing references 18.png

Додавання нової примітки

Щоб додати нову примітку з використанням меню «Джерело», помістіть курсор туди, де Ви хочете її додати в тексті. Тоді виберіть відповідний пункт у меню «Джерело».
VisualEditor references more.png

Використання «Базової» примітки

Shown here is what you will see if you select the basic references item. На знімку екрана зліва зображене вікно, яке Ви побачите при виборі іконки «$basic». У редакторі приміток Ви можете додати, відредагувати та відформатувати своє цитування.

Ви можете віднести примітку до певної групи, хоча зазвичай це поле залишають порожнім. (Ця опція використовується для відображення груп приміток з допомогою інструменту «Список приміток».)

VisualEditor - Editing references 20.png

Якщо Ви додаєте нову примітку і хочете включити в неї шаблон, оберіть пункт «Шаблон» (частинка пазла) в меню «Вставити» на панелі інструментів редактора приміток.
VisualEditor Template Insert Menu-uk.png

Далі, знайдіть шаблон, який хочете використати, додайте його і відредагуйте так, як і будь-який інший шаблон. (Див. розділ Редагування шаблонів нижче за додатковою інформацією про шаблони.)

Після того, як ви завершите редагування нового шаблону, натисніть «Застосувати зміни», щоб повернутись до редактора приміток, і ще раз «Застосувати зміни», щоб повернутись до сторінки, яку редагуєте.

VisualEditor - Editing references 9-uk.png

Якщо списку приміток на сторінці іще немає (наприклад, якщо Ви додаєте на сторінку першу примітку), Вам треба вказати, у якому місці на сторінці він має відображатися для читачів.

Помістіть курсор туди, де Ви хочете, щоб відображались примітки (зазвичай унизу сторінки), відкрийте меню «Вставити» та натисніть іконку «Список приміток» (три книжки), щоб додати його.

VisualEditor References List Insert Menu-uk.png

Якщо Ви створили декілька груп приміток, Ви можете вказати групу у цьому діалозі. Будуть відображені лише ті примітки, що належать до вказаної групи.

Щоб завершити додавання списку приміток, натисніть «Вставити» у діалозі.

VisualEditor references list-uk.png

Використання стандартних шаблонів цитувань

У Вашій локальній вікі можуть бути додані у це меню іще інші шаблони цитувань. Це забезпечує швидкий доступ до найчастіше використовуваних шаблонів цитувань. (Інструкції з додавання інших шаблонів цитування у Вашій локальній вікі доступні на сторінці VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Натискання на іконці шаблону, наприклад «Cite book», приведе Вас у міні-редактор для цього шаблону. Поля важливої інформації можуть бути відмічені астеріском (зірочкою). Відображатимуться переважно частовживані поля, хоч і не всі з них обов'язкові.
VisualEditor - Editing references - Cite book required fields.png

Щоб додати більше параметрів, прокрутіть вниз у міні-редакторі шаблонів і виберіть опцію «Додати більше інформації».

Натисніть «Вставити», коли завершите.

VisualEditor - Editing references - Add parameter.png

Редагування зображень та інших файлів мультимедіа

Редагування зображень

Щоб додати нове зображення (або інший медіафайл) на сторінку, натисніть іконку «Мультимедіа» (зображення гір) в меню «Вставити» на панелі інструментів. Зображення буде вставлено туди, де в цю мить перебуває курсор.
VisualEditor Media Insert Menu-uk.png

Натискання на іконку «Мультимедіа» відкриває діалогове вікно, що автоматично шукає у Вікісховищі та локальній вікі медіафайли, пов'язані з назвою сторінки, яку Ви редагуєте.

Ви можете змінити критерії пошуку, змінивши текст у пошуковому рядку діалогу.

Клацніть на мініатюрку, щоб обрати файл.

Ця дія поміщає зображення на сторінку, з якою Ви працюєте.

VisualEditor - Media editing 2-uk.png

Коли Ви натиснули на мініатюру, вставивши зображення на сторінку, відкриється діалог медіа. Діалог мультимедіа дозволяє додавати і редагувати опис. Опис може містити форматування та посилання.
VisualEditor - Media editing 6-uk.png

Діалог мультимедіа також дозволяє додавати альтернативні текстові підписи, щоб допомогти користувачам, що використовують читачі екрана або вимкнули показ зображень.
VisualEditor - Media editing 7.png

Ви також можете налаштувати різні параметри зображення у вікні «Додаткові налаштування». Сюди входять вирівнювання, тип і розміри.
VisualEditor - Media editing 8-uk.png

Коли закінчите, натисніть «Застосувати зміни», щоб закрити діалогове вікно та повернутись до редактора сторінки.
VisualEditor Apply Changes-uk.png

До існуючого зображення Ви можете додати чи відредагувати підпис або інші налаштування, клацнувши по зображенню та натиснувши іконку «Мультимедіа», що з'являється під зображенням.

Ви можете змінити розмір існуючого зображення, натиснувши на нього та перемістивши іконку зміни зображення (двостороння стрілка унизу зліва).

Ви також можете перетягти зображення вище або нижче на сторінці.

VisualEditor - Media editing 3-uk.png

Завантаження зображень

Ви можете завантажувати зображення з вкладки у діалозі мультимедіа.
VisualEditor - Media upload 1.png

Натисніть вкладку «Завантажити» й оберіть зображення зі свого комп'ютера. Ви можете ввести назву файлу або перетягти зображення на вікно. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.png

Ви можете описати зображення і додати категорії до нього, щоб інші люди могли його знайти.
VisualEditor - Media upload 2.png

Зображення буде вставлене на сторінку, коли Ви завершите.
VisualEditor-logo.svg

Редагування галерей мультимедіа

Щоб додати нову галерею, натисніть іконку «Галерея» (набір фотознімків) у меню «Вставити». (Якщо Ви не бачите цієї іконки у тому меню, то Ваша локальна вікі вирішила відкласти впровадження цього функціоналу у Візуальному редакторі.)
VisualEditor - Gallery1.png

Щоб відредагувати існуючу галерею у Візуальному редакторі, клацніть будь-де в межах тієї галереї. Далі, ближче до низу галереї, натисніть на іконку галереї (набір фото). Цим Ви відкриєте вікно редагування галереї із повним списком зображень, які в неї включені.
VisualEditor - Gallery2-uk.png
Діалог редагування галереї зараз виглядає як простий прямокутник, що дозволяє Вам редагувати наявні галереї з використанням вікірозмітки. Щоб додати нове зображення до наявної галереї, введіть назву файлу і вертикальну риску після нього (|), а далі — опис зображення. Кожне зображення в галереї треба вписувати з нового рядка. Ви також можете редагувати цей список, щоб вилучити зображення або переставити місцями чи змінити підписи.

Натиснувши кнопку «Готово», ви вийдете з редактора галерей. Далі Ви маєте побачити результат внесених Вами змін — вона виглядатиме такою, якою її бачитимуть читачі.

Пам'ятайте, що вихід з діалогу редагування галереї не зберігає Ваших змін. Як і з іншими змінами, зробленими з допомогою Візуального редактора, Ви маєте зберегти усю сторінку, щоб зберегти свою роботу.

VisualEditor - Gallery3-uk.png

Editing templates

Starting

Щоб додати новий шаблон на сторінку, помістіть курсор туди, де Ви хочете його вставити, і клікніть іконку «Шаблон» (частинка пазла) у меню «Вставити».
VisualEditor Template Insert Menu-uk.png

Вводьте назву шаблону, який хочете вставити. Клацніть на нього, коли побачите його у списку. Далі натисніть «Додати шаблон».
VisualEditor - Template editing 4.png

Ви також можете редагувати шаблони, які уже містяться на сторінці, виділяючи їх (вони підсвічуються блакитним) і натискаючи на іконку «Шаблон» (частинка пазла), що з'являється.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the "Включення" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

Для існуючого шаблону Ви можете відредагувати вже наявні параметри, а також додати інші, натиснувши кнопку «Додати більше інформації», розташовану в самому низу діалогу.
VisualEditor - Template editing 3.png

Коли шаблон включає інші шаблони, ці підшаблони відображаються як параметри. Їх можна редагувати чи видалити натисканням на назву підшаблону.

Нові підшаблони додаються тими ж кроками, що й додавання параметра. Вам варто переглянути документацію шаблону, аби переконатись, що підшаблон підтримується.

VisualEditor - Template editing 5.png

Finishing

Коли закінчите, натисніть кнопку «Застосувати зміни», щоб закрити діалогове вікно та повернутись до редактора сторінки.
VisualEditor Apply Changes-uk.png

Підставляння шаблонів

Коли шаблон треба підставляти, введіть subst: (з двокрапкою) перед назвою шаблону.

Автодоповнення не працює з subst:; якщо вам потрібне автодоповнення, додайте subst: тільки після того, як знайдете шаблон, який шукаєте.

Далі, натисніть зелену кнопку «Додати шаблон».

Додайте параметри, як звичайно, і натисніть «Вставити».

VisualEditor - Template editing 7.png

На цій початковій фазі ви не побачите шаблон розгорнутим на сторінці.
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-uk.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just press on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then press on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Редагування таблиць

VisualEditor insert table-uk.png
Ви можете використовувати візуальний редактор для додавання та редагування таблиць.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you press on "Table", in the "Вставити" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, press it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double press in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just press elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Ви можете додавати та вилучати колонки та рядки.

You can merge cells: Select them, then from the Table menu, press on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Редагування категорій

VisualEditor category item-uk.png
Для редагування категорій, клацніть кнопку «Категорії» в меню «Параметри сторінки».

VisualEditor category editing-uk.png

Кнопка «Категорії» відкриває діалогове вікно, у якому перераховані існуючі категорії і можна додати нові.

У Вас є можливість встановлення або зміни загального (типового) ключа сортування, що використовується для визначення того, де сторінка перебуватиме при відображенні її у списку всіх сторінок, що належать до однакової категорії.

Приміром, для статті «Джордж Вашингтон» ключ сортування за замовчуванням «Вашингтон, Джордж», тому в категорії «Президенти Сполучених Штатів» ця стаття розміщена під літерою «В», а не під «Д».


VisualEditor - Category editing 3-uk.png
Щоб додати категорію до сторінки, введіть її назву у поле «Додати категорію». Під час вводу тексту, Візуальний редактор автоматично підшукуватиме наявні категорії з найбільш відповідними назвами. Ви можете або вибрати вже існуючу категорію, або додати категорію, яка ще не має окремої сторінки. (Доки така сторінка категорії не буде створена, додана Вами категорія виглядатиме як червоне посилання після збереження внесених Вами змін.)

VisualEditor - Category editing 2-uk.png

Щоб видалити існуючу категорію, клацніть на ній і натисніть іконку «Вилучити» (смітник) у діалоговому вікні, що відкриється.

Клацання на категорії також дозволить Вам вказати ключ сортування для цієї конкретної категорії. Таким чином можна знехтувати стандартним ключем сортування.


VisualEditor Apply Changes-uk.png
Натисніть «Застосувати зміни», коли завершите редагування категорій, щоб повернутись до редактора сторінки.

Редагування параметрів сторінки

VisualEditor page settings item-uk.png
Щоб редагувати параметри сторінки, відкрийте меню «Параметри сторінки» на панелі інструментів і натисніть кнопку «Налаштування сторінки».

VisualEditor Page Settings-uk.png
Кнопка «Налаштування сторінки» відкриває діалогове вікно, що пропонує декілька опцій.

VisualEditor Page Settings Redirects-uk.png
Ви можете зробити сторінку перенаправленням на іншу сторінку, поставивши галочку «Перенаправити цю сторінку на», а потім ввівши назву сторінки, на яку Ви хочете відправляти читача, коли він намагатиметься зайти на сторінку, яку Ви саме редагуєте.

Унизу є опція, яка запобігає оновленню цього перенаправлення при перейменуванні сторінки, що використовується дуже рідко.


VisualEditor Page Settings TOC-uk.png
Ви можете вказати, чи має ця сторінка відображати зміст, вибравши одну з цих троьх кнопок. Опцією за замовчуванням є «У разі потреби», за якою зміст відображається, коли є три і більше розділів.

VisualEditor Page Settings Edit Links-uk.png
Ви можете зробити так, щоб на сторінці не відображалися посилання на редагування поруч із заголовком кожного розділу, поставивши цю галочку.

VisualEditor Apply Changes-uk.png
Натисніть «Застосувати зміни», коли завершите редагувати Параметри сторінки, щоб повернутися до редактора сторінки.

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Редагування математичних формул

Щоб додати нову математичну формулу на сторінку, помістіть курсор туди, де вона має бути, і натисніть на іконку «Математична формула» («Σ») у меню «Вставити» на панелі інструментів.
VisualEditor Formula Insert Menu-uk.png

Відкриється віконце, у якому Вам треба ввести формулу, використовуючи синтаксис LaTeX. Візуальний редактор буде оновлювати формулу по ходу друку, тож Ви зможете бачити, як вона виглядатиме в процесі набору. Як тільки Ви будете задоволені результатом, натисніть кнопку «Готово».
VisualEditor formula-uk.png

Щоб відредагувати існуючу на сторінці математичну формулу, клацніть на ній, а потім натисніть іконку «Σ» у меню, що випливе. Це відкриє віконце і дасть Вам змогу внести зміни.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, press the "Musical notation" option.

To edit an existing musical notation on the page, double press on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, press the "Done" button to close the dialog and publish your changes.
Musical.png

Редагування віршів та інших незвичних елементів

Деякі елементи, як-то списки асоціацій, вірші та нотні записи, ще не підтримуються візуальним редактором повною мірою.

VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, press the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll press on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, press the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you press the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you press "Keep changes", you'll go to the visual editor. If you press "Discard changes", you'll be asked to confirm that is what you want to do (press on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Комбінації клавіш

Чимало редакторів використовують для прямого вводу вікітексту, особливо жирного, курсиву і вікіпосилань. Комбінації клавіш дають змогу швидко вставити подібне форматування без необхідності натискати кнопки панелі інструментів. Загальні комбінації клавіш, які використовуються й іншими редакторами, працюють у візуальному редакторі:

Комбінація для ПК Дія Комбінація для Mac

Ctrl+B Жирний Cmd+B

Ctrl+I Курсив Cmd+I

Ctrl+K Вставити посилання Cmd+K

Ctrl+X Вирізати Cmd+X

Ctrl+C Копіювати Cmd+C

Ctrl+V Вставити Cmd+V

Ctrl+Z Скасувати Cmd+Z