Pomoc:VisualEditor/Instrukcja

This page is a translated version of the page Help:VisualEditor/User guide and the translation is 73% complete.
Outdated translations are marked like this.
PD Uwaga: Jeżeli edytujesz tę stronę, to umieszczając na niej treści wyrażasz nieodwołalną zgodę na udostępnianie Twojego materiału na podstawie wolnej licencji CC0. Aby uzyskać więcej informacji, przeczytaj Strony Pomocy w Domenie Publicznej.
PD
Edytor wizualny można wypróbować, nie zmieniając artykułu - tu można swobodnie go testować. Nie jest konieczne posiadanie konta, aby zmienić tę stronę za pomocą edytora wizualnego.


Uruchamianie edytora wizualnego

Aby zmienić stronę za pomocą edytora wizualnego, należy kliknąć w zakładkę „Edytuj” u góry strony.

Może potrwać kilka sekund, zanim otworzy się strona edycji lub dłużej, jeżeli strona jest bardzo długa.

Kliknięcie w zakładkę „Edytuj kod źródłowy” otworzy klasyczny edytor kodu źródłowego.

VisualEditor edit tab-pl.png

Edytor wizualny można także uruchomić, klikając link „edytuj”, znajdujący się przy nagłówku każdej sekcji.
VisualEditor - Section edit links-en.png

Na początek: pasek narzędzi edytora wizualnego

Zrzut ekranu: pasek narzędzi edytora wizualnego
Po uruchomieniu edytora wizualnego na górze ekranu pojawi się pasek narzędzi. Zawiera on znajome ikony:

VisualEditor - Toolbar - Undo-redo.png
Cofnij lub Ponów wykonane zmiany.

VisualEditor Toolbar Headings-pl.png
Nagłówki (menu rozwijane): pozwala zmienić formatowanie tekstu. Aby zmienić styl akapitu należy umieścić kursor w tekście (nie ma potrzeby zaznaczania czegokolwiek). Tytuły sekcji są formatowane jako „Podstawowy nagłówek rozdziału”, a podsekcji jako „Nagłówek podrozdziału 1 stopnia”, „Nagłówek podrozdziału 2 stopnia” itd. Zwykłe formatowanie tekstu to „Akapit”.

VisualEditor Toolbar Formatting-pl.png

Formatowanie: Kliknięcie na „A” otwiera menu.

  • „Pogrubienie” (B) wytłuszcza zaznaczony tekst.
  • „Kursywa” (I) pochyla zaznaczony tekst.
  • „Indeks górny” (x2) umieszcza zaznaczony tekst we frakcji górnej.
  • „Indeks dolny” (x2) umieszcza zaznaczony tekst w indeksie dolnym, tj. będzie mniejszy i niżej niż reszta tekstu.
  • "Przekreślenie" (S) dodaje przekreślenie do zaznaczonego tekstu.
  • Element „Kod programu” (para nawiasów klamrowych: {}) ustawia czcionkę zaznaczonego tekstu na czcionkę o stałej szerokości; nie wpływa to na pozostały tekst w akapicie.
  • Element „Podkreślenie” (A) dodaje linię ciągłą pod zaznaczonym tekstem.
  • „Język” (文A) pozwala ustawić język zaznaczonego tekstu (np. na japoński) i kierunek pisania (np. od prawej do lewej).
  • Ostatni element („VisualEditor MediaWiki theme clear icon bitmap.png”), zwany „Usuń”, usuwa formatowanie zaznaczonego tekstu, w tym linkowanie.

Jeżeli nie zaznaczono żadnego tekstu, po kliknięciu "A" i otwarciu menu, z którego zostanie wybrana pozycja, wybrane formatowanie zostanie zastosowane do następnie wpisywanego tekstu, w miejscu, gdzie zlokalizowany jest kursor.


VisualEditor - Toolbar - Linking.png
Linkowanie: ikona łańcucha symbolizuje narzędzie wstawiania odnośników (linków). Kliknięcie w nią (zazwyczaj po zaznaczeniu tekstu) otwiera okno linku.

VisualEditor - Cite Pulldown.png
Menu „Przypis” używamy do dodania przypisów. Jest możliwość dodania zwykłych przypisów i wykorzystania istniejących, wcześniej już zdefiniowanych. W tym menu dostępne jest także wstawianie szablonów cytowania dostępnych lokalnie na edytowanej wiki.

(Instrukcje dodawania lokalnych szablonów cytowania do menu „Przypis” są opisane na VisualEditor/Citation tool )


VisualEditor citoid Cite button-pl.png
Przycisk Przypis: Jeżeli na polskiej wiki jest włączony Citoid, to dostępny będzie przycisk „Przypis” zamiast menu „Przypis”.

Citoid spróbuje samodzielnie wypełnić szablon cytowania.


VisualEditor Toolbar Lists and indentation-pl.png
Listy i wcięcia: pierwsze dwa elementy pozwalają formatować tekst jako „Lista wypunktowana” albo „Lista numerowana”. Kolejne dwa służą do powiększania lub zmniejszania wcięcia listy elementów.

VisualEditor Insert Menu-pl.png
Wstaw: menu „Wstaw” może się różnić na różnych wiki. Poniżej zamieszczono listę wszystkich możliwych opcji.
  • Ikona „Grafika i multimedia” (obrazek przedstawiający góry) otwiera okno multimediów.
  • Ikona „Szablon” (puzel) otwiera okno zmieniania szablonów.
  • Element „Tabela” pozwala na wstawienie tabeli.
  • „Komentarz” (dymek) otwiera okno dodawania komentarzy, które są niewidoczne dla czytelników; są widoczne tylko w trybie edycji jako ikonka wykrzyknika w kółku, której kliknięcie pozwala na edycje lub usunięcie komentarza.
  • Ikona „Hieroglify” (symbol anch - ☥) otwiera okno wstawiania hieroglifów (patrz niżej).
  • Element "Blok kodu" pozwala na wstawienie kodu.
  • Element „Notacja muzyczna” pozwala na wstawianie zapisu nut.
  • Ikona „Galeria” (zbiór zdjęć) otwiera okno wstawiania galerii.
  • Ikona „Wzory matematyczne” (Σ) otwiera okno wstawiania wzorów matematycznych.
  • Element „Wykres” pozwala na wstawianie wykresów.
  • Element „Twój podpis” pozwala na wstawienie podpisu, którego używasz w danym projekcie. Element będzie wyświetlony w kolorze szarym (czyli nie można go wybrać), jeżeli będziesz edytować stronę takiego typu (w przestrzeni nazw), w którym nie powinno się wstawiać podpisów.
  • Ikona „Lista przypisów” (trzy książki) otwiera okno dialogowe, w którym możesz określić, gdzie przypisy zostaną wyświetlone czytelnikowi. Zazwyczaj na stronie potrzeba użyć tego tylko raz.

Wstawianie znaków specjalnych: naciśnięcie na ikonę „Znak specjalny” (Ω) obok menu „Wstaw” otwiera okno z wieloma znakami specjalnymi. Naciśnięcie na znak umieszcza go w tekście. Zbiór znaków specjalnych zawiera niektóre standardowe symbole, litery diakrytyczne i symbole matematyczne. (Tę listę można lokalnie dostosowywać, zobacz instrukcję: VisualEditor/Znaki specjalne )
VisualEditor Toolbar SpecialCharacters-pl.png

VisualEditor toolbar edit notices icon.png
Okno komunikatów wyświetla komunikaty kierowane do użytkownika dotyczące edytowanej strony.

VisualEditor More Settings-pl.png
The Opcje strony menu is to the left of the Opublikuj zmiany button and the Switch editor menu. On this menu there is a button to open an Options dialog with the following (left side) tabs:
  • Kategorie allows you to add categories to this page and to adjust how the page is sorted, when displayed within a category by setting a different index to sort with.
  • Ustawienia strony allows you to make the page a redirect and adjust options of this redirect, to adjust settings regarding the displaying of the Table of Contents, to disable the edit links next to each heading, and to define the page as a disambiguation page.
  • Advanced settings allows you to adjust the settings regarding indexation of the page by search engines, showing a tab to add a new section, and the displayed title.
  • Języki which shows a list of pages in other languages that are linked to that page.
  • Templates used shows a list of links to each template used on this page.

The tabs of the Options dialog are also displayed in the Opcje strony menu and can be opened by clicking on it.

Furthermore the Opcje strony menu contains the button View as right-to-left and the button Find and replace which opens a dialog where you can insert characters, terms or Regular expressions you are searching for and those to replace them with, together with several buttons for options.

VisualEditor bi-directional switching square brackets icon.png
Przycisk Edytowanie kodu źródłowego znajduje się obok przycisku Opublikuj zmiany. Umożliwia przełączanie do edytora kodu źródłowego.

Publikowanie zmian

Po zakończeniu edycji należy kliknąć na niebieski przycisk „Opublikuj zmiany” na pasku narzędzi. Nie jest to możliwe, jeśli nie dokonano żadnych zmian (przycisk jest szary). Aby anulować wszystkie zmiany edycyjne, wystarczy zamknąć okno przeglądarki albo kliknąć zakładkę „Czytaj” nad paskiem narzędzi edycji.
VisualEditor toolbar actions-pl.png

Naciśnięcie niebiekiego przycisku „Opublikuj zmiany” otwiera okno, w którym można wprowadzić krótkie podsumowanie swoich działań, oznaczyć edycję jako drobną czy zdecydować się na obserwowanie przyszłych zmian na stronie. To okno odpowiada polu opisu zmian w edytorze kodu źródłowego.

Można też przejrzeć swoje zmiany, używając przycisku „Skontroluj swoje zmiany”. W ten sposób można upewnić się jeszcze przed zapisaniem edycji, że zmiany są zgodne z ich intencjami. Ta opcja odpowiada przyciskowi „Podgląd zmian” w edytorze kodu źródłowego.

Klikając na przycisk „Kontynuuj edycję”, wracasz do edytowanej strony. Później możesz zapisać wszystkie swoje zmiany.

VisualEditor save dialog-pl.png

Edycja linków

VisualEditor - Toolbar - Linking.png
Można dodać link za pomocą ikony „Link” w pasku narzędzi lub używając skrótu klawiszowego Ctrl+K (lub ⌘ Command+K na Mac-u).

Po zaznaczeniu (podświetleniu) tekstu naciśnięcie na „Link” spowoduje użycie tego tekstu do tworzenia linku. W przypadku linku obejmującego jeden wyraz można albo zaznaczyć wyraz, albo umieścić kursor w środku tego wyrazu.


VisualEditor-link tool-search results-pl.png
Niezależnie od tego, czy użyto ikonki czy skrótu, to otworzy się okno dialogowe, w którym można wpisać adres linku.

Edytor linków będzie wyszukał proponowane linki wewnętrzne pasujące do tego, co wpiszesz. Po wpisaniu lub wybraniu linku, można wcisnąć ↵ Enter albo kliknąć „Gotowe”. Link pojawi się na zmienianej stronie, ale, jak pozostałe zmiany, nie będzie opublikowany, dopóki cała strona nie zostanie opublikowana.


VisualEditor-link tool-external link.png
Aby dodać link do innej strony, proces jest podobny: należy wybrać zakładkę „Strona zewnętrzna” i wpisać adres URL.

VisualEditor link tool simple link.png
Linki zewnętrzne bez etykiet wyglądają tak: [1]. Można je dodać, klikając gdziekolwiek indziej (np. po spacji). Należy otwórzyć narzędzie do edycji linków, klikając na przycisk lub używając skrótu klawiszowego. Należy wpisać URL i kliknąć przycisk „Gotowe”, by wstawić link.

VisualEditor-context menu-link tool.png
Aby zmienić lub usunąć istniejący link, kliknij na niego, a następnie na ikonę „Link” widoczną obok. Pojawi się okno do zmieniania linku. (Możesz też kliknąć na taką samą ikonę na pasku narzędzi lub użyć skrótu klawiszowego Ctrl+K). Jeżeli link zostanie zaznaczony, to wyświetli się na niebieskim tle.

W oknie zmieniania linku można zmienić stronę do której ma prowadzić link, albo usunąć link, klikając na ikonę „Usuń”, znajdującą się w prawym górnym rogu okna. Można także otworzyć link w osobnym oknie, wybierając taką opcję w menu kontekstowym. (Można sprawdzić, czy link zewnętrzny jest poprawny).

Aby wyjść z okna edycji linku (tekstu wyświetlonego jako link) lub kontynuować pisanie po tym linku, można nacisnąć :

  • Pojedyncze naciśnięcie spowoduje wyjście z okna edycji linku i umieści kursor na końcu linkowanego elementu (który będzie wyróżniony w niebieskiej ramce podczas edycji)
  • Dwukrotne naciśnięcie umieści kursor za linkiem, w miejscu, gdzie można kontynuować pisanie.

Aby zmienić etykietę linku (wyświetlany tekst), kliknij na etykietę i wpisz nową. Jeżeli chcesz całkowicie zmienić etykietę, uważaj na:

  • Jeżeli zaznaczyłeś (podświetliłeś) całą etykietę linku, link do zostanie usunięty po wciśnięciu jakiegokolwiek klawisza. Będzie trzeba dodać od nowa ten link.
  • Aby sam link był zachowany podczas zmiany, używaj klawiszy backspace i delete i nie wciskaj ich więcej razy niż to konieczne, pozostanie wtedy wąski niebieski obszar linka. Teraz możesz wpisać nowy tekst pozostawionego linka.
  • Możesz także utworzyć łącza do kategorii, plików i innych elementów.

Edycja przypisów

Po więcej informacji zobacz Pomoc w używaniu szablonów cytowania i pomoc w używaniu Citoida

Ustalanie który system obowiązuje

Wiki, na której edytujesz może używać jednego z trzech sposobów wstawiania przypisów. Po prawej wyświetlany jest najprostszy sposób, w którym menu „Przypis” nie zawiera zdefiniowanych dla wiki szablonów cytowania. Jeżeli twoja wiki używa tego systemu, to wszystko co należy wiedzieć o wstawianiu przypisów, jest na tej stronie.
VisualEditor cite menu default.png

Drugi system ma takie samo menu „Przypis”, ale zawierające kilka szablonów cytowania do szybkiego wstawiania. Jeżeli twoja wiki używa tego systemu, to szczegóły można znaleźć na Help:VisualEditor/User guide/Citations-Templates .
VisualEditor references more.png

VisualEditor citoid Cite button-pl.png
W trzecim systemie również zaczynasz przez kliknięcie przycisku Przypis. Pojawi się okienko, które oferuje automatyczny proces wstawiania przypisu przy użyciu usługi Citoid. Jeżeli wiki, na której działasz korzysta z tego systemu to więcej informacji zdobędziesz na stronie Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-pl.png

Edycja istniejącego przypisu

Aby zmienić istniejący przypis, należy kliknąć na niego w tekście, w którym się on znajduje (zazwyczaj to liczba w nawiasie). Pojawi się ikona „Przypis” (obrazek zakładki w książce) albo ikona i nazwa szablonu, którego użyto do utworzenia przypisu. W obu przypadkach, kliknięcie na "Edytuj" otworzy okno, w którym można zmienić ten przypis.
VisualEditor - Editing references 1.png

Kliknięcie na „Edytuj” obok ikony „Przypis” otwiera okno dialogowe. Aby zmienić tekst przypisu należy kliknąć na niego.

Wiele serwisów wiki używa szablonów formatujących przypisy do właściwego standardu. Jeżeli w przypisie użyto szablonu, przesunięcie kursora na tekście spowoduje podświetlenie się tekstu.

Jeżeli użyto szablonu, to kliknięcie na tekst formatowany za pomocą szablonu spowoduje pojawienie się ikony „Szablon”. Należy kliknąć przycisk „Edytuj”, by edytować zawartość szablonu.

VisualEditor - Editing references 6.png

Jeżeli pojawia się wtedy standardowa ikona przypisu (przykład po prawej), kliknięcie „Edytuj” otworzy okno edytowania szablonu.
VisualEditor - Editing References - Cite Web.png

Kliknięcie na ikonę Dołączony szablon pozwala dodać i usuwać rodzaje informacji oraz zmieniać wpisane informacje. Na początku pojawią się tylko te pola (parametry), które zawierają treść. By dodać pola, należy kliknąć na „Dodaj więcej informacji” na dole okna dialogowego.
VisualEditor - Editing references 5.png

Po zakończeniu należy kliknąć „Zastosuj”.
VisualEditor Apply Changes-pl.png

Używanie istniejącego przypisu

Jeżeli strona zawiera już przypisy, to można wybrać jeden z nich, o ile dotyczy on informacji do której należy go dodać.

Aby użyć istniejącego przypisu, należy umieścić kursor w miejscu, w którym ma być on dodany i kliknąć na ikonę „Użyj istniejącego” (obrazek zakładki w książce) z menu „$cite”.

(Uwaga: Jeżeli twoja wiki ma trzeci system wstawiania przypisów opisany powyżej, to będzie dostępna zakładka „Użyj istniejącego” w oknie dialogowym, zamiast ikonki „Użyj istniejącego” widniejącej w menu „Przypis”).

VisualEditor Cite menu re-use.png

W oknie „$reference-title” dostępna będzie lista istniejących przypisów, które można wybrać i wstawić ponownie. Jeżeli jest ich wiele, to można użyć wyszukiwarki (podpowiadającej „$input”) i otrzymać listę tylko tych przypisów, które zawierają tekst wpisany do wyszukiwarki.
VisualEditor - Editing references 18.png

Tworzenie nowego przypisu

Aby utworzyć nowy przypis używając menu „$cite”, należy umieścić kursor w miejscu, w którym ma być wstawiony, a następnie wybrać odpowiedni typ przypisu z menu.
VisualEditor references more.png

Użycie „zwykłego wyglądu”

Obok pokazano, co wyświetli się po wybraniu opcji „zwykły przypis”. W tym oknie dialogowym można dodać, edytować i formatować swój przypis.

Można określić przynależność przypisu do danej grupy (zwykle do żadnej nie należy). Ta opcja jest używana do wyświetlania grup przypisów za pomocą narzędzia „Lista przypisów”.

VisualEditor - Editing references 20.png

Jeżeli dodawany jest nowy przypis i ma być w nim zawarty szablon przypisu albo jakiś inny, to należy kliknąć na ikonę „Szablon” (obrazek puzzla) w menu „Wstaw” w pasku narzędziowym okna tworzenia nowego przypisu.
VisualEditor Template Insert Menu-pl.png

Należy wybrać szablon, który ma być użyty, dodać i zmienić tak samo, jak zmienia się istniejący. (Zobacz sekcję Edycja szablonów dla uzyskania dodatkowych informacji o szablonach).

Po zakończeniu edytowania nowego szablonu należy kliknąć na „Zastosuj”, by wrócić do edytora przypisów i powtórnie „Zastosuj”, by wrócić do edytowanej strony.

VisualEditor - Editing references 9.png

Jeżeli strona nie zawiera jeszcze listy przypisów (np. tworzony jest właśnie pierwszy przypis), to tę listę dodać, aby treść przypisów wyświetlała się na stronie.

Należy umieścić kursor w miejscu, w którym ma wyświetlać się lista przypisów (zwykle na dole strony) i otworzyć menu „Wstaw”, po czym kliknąć na ikonę „Lista przypisów” (obrazek trzech książek).

VisualEditor References List Insert Menu-pl.png

Gdy używa się kilku grup przypisów, co jest rzadkie, to można wybrać jedną z nich w tym oknie. Tylko te przypisy, które należą do niej, wyświetlą się w miejscu, w którym umieszcza się daną grupę.

Ostatnim krokiem w oknie edycji grup przypisów jest kliknięcie na „Wstaw”.

VisualEditor references list-pl.png

Użycie standardowych szablonów cytowań

Na lokalnej wiki mogą być podane inne szablony w menu „Przypis”. Jeżeli tak jest, to jest szybki dostęp do najczęściej używanych szablonów przypisów na waszej wiki. (Instrukcje takiego dodawania szablonów przypisów do menu są opisane na VisualEditor/Citation tool ).
VisualEditor - Editing References - Cite Pulldown.png

Kliknięcie na ikonę szablonu taką jak „Cytuj książkę” zaprowadzi do edytora tego szablonu. Ważne pola informacji mogą być oznaczone gwiazdką. Domyślnie wyświetlają się najczęściej używane pola, ale być może nie będzie potrzeby wypełniania wszystkich.
VisualEditor - Editing references - Cite book required fields.png

By dodać więcej parametrów należy przewinąć okno edycji szablonu i kliknąć na „Dodaj więcej informacji”.

Po zakończeniu należy kliknąć na „Wstaw”.

VisualEditor - Editing references - Add parameter.png

Edycja obrazków i innych plików multimedialnych

Edycja obrazków

Aby dodać nowe zdjęcie (lub inny plik multimedialny) do strony, należy kliknąć ikonę „Grafika i multimedia” (obrazek gór) w rozwijanym menu „Wstaw”. Zdjęcie zostanie wstawione w miejscu, gdzie znajduje się kursor.
VisualEditor Media Insert Menu-pl.png

Kliknięcie na ikonę „Grafika i multimedia” otwiera okno dialogowe, które automatycznie wyszukuje w Wikimedia Commons i w polskiej wiki pliki multimedialne związane z tytułem edytowanej strony.

Można szukać innych plików multimedialnych, zmieniając tekst w oknie dialogowym w polu wyszukiwania.

Należy kliknąć na miniaturę, aby wybrać plik.

To umieszcza plik na stronie, która jest edytowana.

VisualEditor - Media editing 2.png

Kiedy wybierany jest i wstawiany plik na stronę, to pojawi się nowe okno dialogowe, w którym można dodać (lub zmienić) opis, który może zawierać sformatowany tekst i linki.
VisualEditor - Media editing 6.png

Okno edycji multimediów pozwala na dodawanie alternatywnych opisów używanych przez osoby, które używają czytników ekranowych oraz przez tych, którzy wyłączyli wyświetlanie plików.
VisualEditor - Media editing 7.png

Można także skorzystać z różnych ustawień plików w oknie „Zaawansowane”. Znajdują się tam opcje wyrównania, rodzaju wyświetlania i rozmiaru pliku.
VisualEditor - Media editing 8.png

Po zakończeniu należy kliknąć Zastosuj by zamknąć okno i wrócić do edycji strony.
VisualEditor Apply Changes-pl.png

Można zmieniać opis lub ustawienia istniejącej grafiki poprzez kliknięcie tej grafiki, a następnie kliknięcia ikony „Grafika i multimedia” umieszczonej poniżej grafiki.

Można zmienić rozmiar istniejącego pliku, klikając na niego i przesuwając ikony zmieniania rozmiaru (dwukierunkowe strzałki na jednym albo dwóch dolnych rogach pliku).

Można także przeciągać i upuszczać plik, by umieścić go wyżej albo niżej.

VisualEditor - Media editing 3.png

Przesyłanie plików

Można ładować nowe pliki, używając zakładki w menu edycji plików, przeciągając i upuszczając plik w edytorze lub wklejając obraz ze schowka.
VisualEditor - Media upload 1.png

Należy kliknąć przycisk „Załaduj” i wybrać plik grafiki na komputerze lokalnym – można wpisać nazwę lub zaczepić i przeciągnąć do okna. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.5.png

Należy opisać grafikę i zdefiniować jej kategorię, co pozwoli innym ją odnaleźć.
VisualEditor - Media upload 2.png

Po zakończeniu grafika zostanie wstawiona na stronę.
VisualEditor-logo.svg

Edycja i wstawianie galerii zdjęć

Aby dodać nową galerię, należ kliknąć ikonę „Galeria” (zbiór zdjęć) w menu „Wstaw”. (Jeżeli nie widzisz tej ikony w tym menu to oznacza, że na lokalnej wiki zdecydowano, że zostanie odłożone zaimplementowanie tej funkcji w edytorze wizualnym.)
VisualEditor - Gallery1.png

Aby edytować w edytorze wizualnym istniejącą galerię należy ją kliknąć. Następnie na dole galerii należy kliknąć ikonę galerii (zestaw grafik). Spowoduje to wywołanie edytora galerii z pełnym wykazem grafik w galerii.
VisualEditor - Gallery2.png
Edytor galerii obecnie to zwykłe okno w którym można edytować istniejące galerie w wikikodzie. Aby do galerii dodać nową grafikę, to należy wpisać nazwę pliku, następnie kreskę (|) i opis tej grafiki, przy czym każda grafiki musi być wpisana w oddzielnym wierszu. Można również edytować daną listę – usuwając lub przemieszczając grafiki lub zmieniając ich opisy.

Kliknięcie przycisku "$dialogdone" powoduje wyjście z edytora galerii i zostaną pokazane wprowadzane zmiany tak jak są one widoczne dla czytelników.

Należ pamiętać, że wyjście z okna edycji galerii nie zapisze zmian. Tak jak w przypadku innych zmian dokonanych za pomocą edytora wizualnego, trzeba zapisać całą stronę, aby zmiany zostały zachowane.

VisualEditor - Gallery3.png

Edycja szablonów

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Aby dodać nowy szablon, należ umieścić kursor w miejscu, w którym należygo dodać, i kliknąć na ikonę „$template” (obrazek puzzla) umieszczoną w menu „$insert”. Then open the Wstaw menu and select "OOjs UI icon puzzle-ltr.svg Szablon". Alternatively, type two curly brackets {{ to open the same dialog.
VisualEditor Template Insert Menu-pl.png
Należy wpisać nazwę szablonu, który należy dodać. Kiedy pojawi się na liście, to należy kliknąć jego nazwę, a następnie kliknąć „Dodaj szablon”.
Screenshot of the template search field in the Visual Editor

Można także edytować szablony, które znajdują się na stronie, poprzez kliknięcie na nie (zaznaczą się na niebiesko) i kliknięcie na ikonę „$template”. Następnie należy kliknąć „$edit”. When you select the template you want to edit, it turns blue, and a box appears displaying "OOjs UI icon puzzle-ltr.svg Szablon". Then select the "Edytuj" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Niektóre szablony są niewidoczne dla czytelników. W edytorze wizualnym takim ukrytym szablonom towarzyszy ikona puzzla. Obok tej ikony zostanie wyświetlona nazwa szablonu.
Screenshot of hidden templates in the Visual Editor interface

Parametry szablonu

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

Można edytować parametry wyświetlające się w oknie edycji szablonu. Można także dodawać parametry, klikając na „Dodaj więcej informacji” na samym dole okna.
Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without have names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add next to the values you want to provide as you normally would.

Example: * first unnamed parameter: “1” * first unnamed parameter’s value: “en_US” * second unnamed parameter: “2” * second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.
Autogenerated parameters in the VisualEditor.png

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

Po zakończeniu należy kliknąć „Zastosuj” by zamknąć okno i wrócić do edycji strony. Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.

VisualEditor Apply Changes-pl.png

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Wklejanie szablonów

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. (Autocomplete doesn’t work in this case.) Then press the blue “Add template” button.

When you’re finished, press “Insert”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Edytowanie list

VisualEditor Toolbar Lists and indentation-pl.png
W edytorze wizualnym można tworzyć listy lub zmieniać format istniejących list. Są dwa typy list: nienumerowana (wypunktowana) i uporządkowana (numerowana).

Aby dodać nową listę, kliknij na jedną z dwóch pozycji z menu pokazanego obok. Jeżeli już masz wpisany tekst listy, zaznacz go i kliknij jeden z wspomnianych wcześniej przycisków, aby sformatować wiersze jako listę.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Oto przykłady dwóch typów list: nienumerowana (wypunktowana) i uporządkowana (numerowana).

VisualEditor lists 3 select to indent.png
Jeżeli chcesz zmienić poziom wcięcia części istniejącej listy, zaznacz ją.

VisualEditor lists 4 indentation menu.png
Następnie skorzystaj z odpowiedniej opcji w menu lub wciśnij przycisk Tab. Przycisk Tab zwiększa wcięcie, a kombinacja Shift+Tab zmniejsza je.

VisualEditor lists after indenting.png
Oto przykład dodania wcięcia w liście.

VisualEditor lists mixed.png
Jest możliwość mieszania rodzajów list jeżeli są one na innych poziomach wcięć.

Edycja tabel

VisualEditor insert table-pl.png
Edytor wizualny może być używany do wstawiania i edytowania tabel.

Można również używać go do stosowania metody przeciągnij i upuść wartości w formacie .csv z komputera lokalnego.


Po kliknięciu przycisku "Tabela" w menu "Wstaw" edytor wizualny wstawi pustą tabelę 4x4.

Dostępne będzie menu "Tabela", z którego można dodać tytuł tabeli.

VisualEditor empty table.png

Aby wybrać komórkę, należy ją raz kliknąć.
VisualEditor tables select one cell.png

Aby edytować zawartość komórki (na przykład dodać zawartość lub poprawić błąd), kliknij dwukrotnie tę komórkę. Można też wybrać komórkę i wcisnąć Enter.

Aby zakończyć wprowadzanie zmian do komórki, kliknij w dowolne miejsce poza nią.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Można dodawać i usuwać kolumny i wiersze.

Komórki można scalić: Wybierz je, a następnie z menu Tabela wybierz "Scal komórki".
VisualEditor tables merge cells.png

Podczas łączenia komórek zachowywany jest tekst tylko z jednej z nich; tekst z pozostałych łączonych komórek jest usuwany. Jeżeli potrzebujesz zawartości komórek, która zostanie usunięta, Cofnij operację, skopiuj lub przenieś potrzebny tekst, a następnie ponownie dokonaj łączenia komórek.
VisualEditor tables post-merge cell.png

Można także rozdzielać komórki wcześniej połączone. Cała zawartość takiej komórki znajdzie się w pierwszej z poowstałych w wyniku podziału.
VisualEditor tables split cells.png

Edycja kategorii

VisualEditor category item-pl.png
Edytowanie kategorii wykonuje się po kliknięciu pozycji "Kategorie" w menu "Opcje strony".

VisualEditor category editing-pl.png
Przycisk "Kategorie" otwiera okno, w którym wymienione są kategorie oraz pozwala dodać nowe.

Istnieje możliwość skonfigurowania klucza sortowania używanego do wstawiania danej strony na stronach kategorii.

Na przykład domyślnym kluczem sortowania hasło "Gabriel Narutowicz" jest ono samo i w kategorii "Prezydenci Polski" byłoby wykazane pod literą "G", a nie "N" (faktycznie ten artykuł ma jawnie ustawiony klucz sortowania "Narutowicz, Gabriel" i jest wykazany pod literą "N").


VisualEditor - Category editing 3.png
Aby dodać nową kategorię, należy wpisać jej nazwę w pole „Dodaj kategorię”. Po wpisaniu nazwy kategorii edytor wizualny odszuka możliwe dopasowania istniejących kategorii. Można zarówno wybrać istniejącą kategorię, albo dodać nową. (Dopóki strona kategorii nie zostanie utworzona, nowa kategoria będzie pokazana jako czerwony link po zachowaniu zmian).

VisualEditor - Category editing 2.png
Aby usunąć dołączoną kategorię, należy kliknąć na nią, a następnie na ikonę „Usuń” (obrazek kosza) w oknie, które się pojawi.

Można także określić klucz sortowania dla poszczególnych kategorii. Zastępuje on w danym przypadku ogólny klucz sortowania.


VisualEditor Apply Changes-pl.png
Po zakończeniu nalezy klikniąć Zastosuj by zamknąć okno i wrócić do edycji strony.

Edycja ustawień strony

VisualEditor page settings item-pl.png
Aby wejść do edycji ustawień strony, należy kliknąć przycisk "Opcje strony" na belce narzędziowej i wybrać pozycję "Ustawienia strony".

VisualEditor Page Settings-pl.png
Kliknięcie przycisku "Ustawienia strony" otwiera okno dialogowe pokazujące kilka opcji.

VisualEditor Page Settings Redirects-pl.png
Można zdefiniować przekierowanie do innej strony za pomocą zaznaczenia pola wyboru "Przekieruj tę stronę do", a następnie wpisania nazwy strony do której ma być przeniesiony czytelnik, który wejdzie na stronę która jest edytowana.

Na dole jest opcja chroniąca przed aktualizacją danego przekierowania w przypadku przeniesienia strony będącej aktualnie celem przekierowania (standardowo takie przeniesienie powoduje powstanie na tej stronie kolejnego przekierowania). Używane jest bardzo rzadko.


VisualEditor Page Settings TOC-pl.png
Poprzez kliknięcie jednego z tych trzech przycisków można wskazać czy na stronie jest wstawiany spis treści. Domyślnym wyborem jest "W razie potrzeby", czyli wstawianie spisu treści w przypadku gdy hasło ma trzy sekcje lub więcej.

VisualEditor Page Settings Edit Links-pl.png
Zaznaczenie tego pola wyboru powoduje, że obok tytułu sekcji nie będzie pokazywany przycisk "Edytuj".

VisualEditor Apply Changes-pl.png
Po zakończeniu edytowania menu "Opcje strony" należy kliknąć przycisk "Zastosuj" aby powrócić do edycji strony..

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Edycja wzorów matematycznych

Aby dodać nowy wzór matematyczny należy ustawić wskaźnik kursora w miejscu zamierzonego wstawienia i kliknąć ikonę „Wzory matematyczne” („Σ”) w przycisk „Wstaw” paska narzędziowego.
VisualEditor Formula Insert Menu-pl.png

Zostanie otwarte okno do wpisania wzoru z użyciem składni LaTeX-u. Edytor wizualny uaktualni wzór i pokaże wygląd wzoru po zakończeniu zmian. Gdy jesteśmy uszczęśliwieni zmianami, to należy je zatwierdzić klikając przycisk „Wstaw”.
VisualEditor formula-pl.png

Aby edytować wzory matematyczne na stronie należy kliknąć występującą tu ikonę „Σ”. Spowoduje to otwarcie okna wzorów, w którym można wprowadzić zmiany.
VisualEditor - editing existing mathematical formula.png

Wzory matematyczne można umieszczać w linii lub wyśrodkowane blokowo.
VisualEditor mathematic formula inline.png

Edytowanie zapisu nut

Aby wstawić notację muzyczną na stronie, umieść kursor, gdzie ma się pojawić. Następnie z menu "Wstaw" wybierz "Notacja muzyczna".

Aby edytować wcześniej wstawiony na stronie zapis nut, kliknij w niego dwukrotnie.

VisualEditor-Insert-Musical-Notation.png

Zostanie otwarte okno dialogowe "Notacja muzyczna". Tutaj notacja może być edytowana według skali, w formacie ABC lub w LilyPond. Można również powiązać notację z plikiem audio lub MIDI. Kiedy skończysz, kliknij przycisk "Gotowe", aby zamknąć okienko i zachować zmiany.
Musical.png

Edycja fragmentów liryki i innych specjalnych elementów

Niektóre elementy, jak np. listy powiązań i poematy nie są jeszcze w pełni obsługiwane przez edytor wizualny. Aby je dodać lub edytować, należy edytować kod źródłowy.
VisualEditor editing poem 1.png

W większości przypadków istniejące elementy mogą być wstawiane, ale wstawienie niektórych nowych elementów może nie być obsługiwane przez edytor wizualny.

Dopóki nie będzie to w pełni obsługiwane, można to skopiować z innej strony albo przejść do edycji kodu źródłowego.

VisualEditor editing poem 2.png

Przełączanie między edytorem wizualnym i wikitekstu

Aby przełączyć się z edytora wizualnego na edytor wikitekstu, kliknij przycisk [[ ]] znajdujący na pasku narzędzi po prawej stronie.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Przewiń w dół, aby zobaczyć pole edycji wikitekstu.

VisualEditor bi-directional switching diff before wikitext-pl.png

Możesz także przełączyć się z edytora kodu źródłowego do edytora wizualnego. Aby to zrobić, należy kliknąć ikonę ołówka po prawej stronie paska narzędziowego.

VisualEditor bi-directional switching pencil icon in wikitext.png

Skróty klawiszowe

Wielu użytkowników jest przyzwyczajonych do wpisywania wikikodu wprost, w szczególności wytłuszczenia, pochylenia i linków. Skróty klawiszowe pozwalają szybko zastosować podobne formatowanie bez konieczności klikania w pasek narzędzi. VisualEditor zna popularne ogólne skróty oraz skróty stosowane przez niektórych użytkowników.

Skrót PC Akcja Skrót Maca

Ctrl+B Pogrubienie ⌘ Cmd+B

Ctrl+I Kursywa ⌘ Cmd+I

Ctrl+K Wstaw link ⌘ Cmd+K

Ctrl+X Wytnij ⌘ Cmd+X

Ctrl+C Kopiuj ⌘ Cmd+C

Ctrl+V Wklej ⌘ Cmd+V

Ctrl+Z Cofnij ⌘ Cmd+Z