مساعدة:المحرر المرئي/دليل المستخدم

This page is a translated version of the page Help:VisualEditor/User guide and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Bahasa Melayu • ‎Bikol Central • ‎Cebuano • ‎Cymraeg • ‎Deutsch • ‎English • ‎Esperanto • ‎Fiji Hindi • ‎Frysk • ‎Ilokano • ‎Interlingue • ‎Jawa • ‎Ligure • ‎Lëtzebuergesch • ‎Malagasy • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Napulitano • ‎Nederlands • ‎Oromoo • ‎Picard • ‎Scots • ‎Sunda • ‎Tagalog • ‎Tiếng Việt • ‎Tûnsî • ‎Türkçe • ‎Yorùbá • ‎Zazaki • ‎asturianu • ‎azərbaycanca • ‎bosanski • ‎català • ‎dansk • ‎eesti • ‎emiliàn e rumagnòl • ‎español • ‎euskara • ‎français • ‎furlan • ‎føroyskt • ‎galego • ‎hrvatski • ‎isiXhosa • ‎italiano • ‎latviešu • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎shqip • ‎slovenčina • ‎slovenščina • ‎srpskohrvatski / српскохрватски • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎беларуская (тарашкевіца) • ‎български • ‎македонски • ‎русский • ‎саха тыла • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎ייִדיש • ‎עברית • ‎العربية • ‎تۆرکجه • ‎سنڌي • ‎فارسی • ‎پښتو • ‎मराठी • ‎संस्कृतम् • ‎हिन्दी • ‎অসমীয়া • ‎বাংলা • ‎ਪੰਜਾਬੀ • ‎ଓଡ଼ିଆ • ‎தமிழ் • ‎తెలుగు • ‎ಕನ್ನಡ • ‎മലയാളം • ‎ไทย • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎日本語 • ‎ꯃꯤꯇꯩ ꯂꯣꯟ • ‎한국어
PD ملاحظة: بتعديلك هذه الصفحة فإنك توافق على وضع مساهمتك في الملكية العامة وفق CC0. راجع صفحات مساعدة الملكية العامة للمزيد من المعلومات.
PD
اذا رغبت بتجربة استخدام المحرر المرئي بدون تعديل مقالة، يمكنك تجريبه بهذه الصفحة لست بحاجة لانشاء حساب لاستخدام المحرر المرئي في تلك الصفحة.


فتح المحرر المرئي

لتحرير صفحة باستخدام المحرر المرئي إضغط على علامة التبويب "عدل" الموجودة في أعلى الصفحة.

فتح الصفحة للتحرير قد يأخد بضع ثواني، وقد يطول الوقت إذا كانت الصفحة طويلة جدا.

الضغط على علامة التبويب "عدل المصدر" سيفتح محرر مصدر الويكي الكلاسيكي (تعديل المصدر).

VisualEditor edit tab-ar.png

يمكنك أيضا فتح المحرر المرئي بالنقر على رابط "عدل" في كل قسم.
VisualEditor - Section edit links-en.png

البدء: شريط أدوات المحرر المرئي

لقطة شاشة من شريط أدوات المحرر المرئي
عندما تبدأ عملية التحرير بإستخدام المحرر المرئي سيظهر شريط الأدوات الخاص به أعلى الشاشة. وسيحتوي على العديد من الأيقونات المألوفة:

VisualEditor - Toolbar - Undo-redo.png
بالنقر على تراجع و أعد يمكنك التراجع أو أعادة التغييرات التي قمت بها.

VisualEditor Toolbar Headings-ar.png
قائمة الترويسات المنسدلة بعنوان فقرة: تتيح لك إختيار مستوى العنوان. لتغيير نمط الفقرة، ضع علامة الكتابة في الفقرة، ثم اختر عنصر من القائمة (لا يلزم تظليل النص). عناوين الأقسام تكون عناوين "عنوان"، وعناوين الأقسام الفرعية "عنوان فرعي 1" و"عنوان فرعي 2" وهكذا دواليك. التنسيق الافتراضي للنص هو "فقرة".

VisualEditor Toolbar Formatting-ar.png

"التنسيق:" الضغط على "A" يفتح قائمة. لاي عنصر لعمل تأثير عليه، في البداية يجب أن تختار (تُعَلِّمْ) بعض النصوص.

  • العنصر "غليظ" (B) يجعل النص المحدد بالخط العريض.
  • العنصر "مائل" (I) يجعل النص المحدد بالخط المائل.
  • العنصر "نص علوي" (x2) يسبب بجعل النص المحدد يبدو أصغر من باقي النص الغير محدد وكما يجعله يبدو اعلى منه كذلك.
  • العنصر "نص سفلي" (x2) يسبب بجعل النص المحدد يبدو أصغر من باقي النص الغير محدد وكما يجعله يبدو أسفل منه كذلك.
  • عنصر "سطر وسطي" (S) يضيف خطاً يقطع النص المحدد.
  • العنصر "كود برمجي" (مجموعة من الأقواس المعقوفة {}) يغيّر خط النص المظلل إلى خط أحادي المسافة، ما يميّزه عن النص الآخر الذي تكون كلماته متباعدة نسبياً.
  • العنصر "سطر تحتي" (U) يضيف خطاً تحت النص المظلل.
  • عنصر لغة (文A) يتيح لك اختيار اللغة (اليابانية على سبيل المثال) واتجاه الكتابة (مثلاً، من اليمين إلى اليسار) للنص المحدد.
  • العنصر الأخير (VisualEditor MediaWiki theme clear icon bitmap.png) ويسمى "أزل"، يحذف تنسيق الأحرف من النص المحدد بما في ذلك الوصلات.

إذا لم تحدد أي نص وقمت بالنقر على "A" واخترت أحد الخيارات، فسيتم التنسيق وفقاً لذلك الخيار من المكان الذي كان به المؤشر.


VisualEditor - Toolbar - Linking.png
أداة الربط: linking tool يتم بالنقر على هذه الأداة بعد اختيار نص معين فتح link dialog لإضافة وصلات داخلية أو خارجية.

VisualEditor - Cite Pulldown.png
قائمة مرجع' تستخدم لإضافة استشهادات ضمنية (وتعرف أيضاً بالحواشي أو المرجعيات). جميع المشاريع لها وصولية لتنسيق مرجعية أساسية والقدرة على إعادة استخدام الاستشهادات باستخدام القائمة. كما تتيح لك هذه القائمة وصولية أسرع لقوالب الاستشهاد المحلية إذا كانت مفعلة في الويكي.

(يمكن مطالعة تعليمات حول إضافة قوالب الاستشهاد المحلية إلى قائمة مرجع في ويكي معينة هنا VisualEditor/Citation tool ).


VisualEditor citoid Cite button-ar.png
زر استشهاد: عندما تكون خاصية الاستشهاد على ويكي مفعلة بلغتك، فسوف ترى أيقونة «استشهد» التي تذهب بك إلى الخيارات المتاحة عند النقر عليها.

خدمة الاستشهاد (citoid service) تقوم بتعبئة قوالب الاستشهاد بشكل آلي.


VisualEditor Toolbar Lists and indentation-ar.png
القوائم والهامش: أول أيقونتان تتيحان تكوين قائمة نقطية أو مرقمة. آخر أيقونتان تتيحان زيادة أو تقليل الهامش الخاص بالمحتوى.

VisualEditor Insert Menu-ar.png
شريط الأدوات إدراج: ربما تختلف قائمة «إدراج» على بعض المشاريع. القائمة التالية تسرد كافة الخيارات التي قد تظهر.
  • أيقونة "الصور والوسائط" (صورة الجبال) تفتح نافذة الوسائط.
  • أيقونة "قالب" (قطعة أحجية) تتيح استخدام وتحرير القوالب،
  • عنصر «جدول» يُتيح إدراج جدول وتحديد خصائصه وعدد الأعمدة والصفوف.
  • «تعليق مخفي» تُتيح إضافة تعليق غير مرئي للقراء إلا في حالة التعديل، حيث ينتهي التعليق بعلامة تعجب. بالنقر على علامة التعجب يمكنك تعديل أو حذف التعليق.
  • «هيرغليفية» تمكنك من إدراج رموز هيرغليفية مثل (ankh - ☥)
  • من رمز الكود يمكنك إضافة كود إلى مكان وجود المؤشر.
  • «علامة موسيقية» تُتيح إدراج نوتات موسيقية بلغتين (نظامين) هما: ABC و ليلي بوند.
  • أيقونة "معرض" (مجموعة صور) تتيح إدراج معرض صور في الصفحة.
  • تفتح أيقونة «صيغة رياضية» (Σ) مربع حوار إدراج صيغة رياضية.
  • رمز المخطط أو الرسم (Graph) يسمح لك بإضافته.
  • «توقيعك» تُتيح إضافة توقيعك للمشروع الذي تعمل عليه. يتم إظهاره بلون رمادي ويكون معطلاً عند العمل على نطاق الصفحات، فمثلاً لا ينبغي إدراج التوقيع في المقالات الويكيبيدية.
  • * أيقونة (ثلاثة كتب) تفتح صندوق لعرض مكان إدراج المراجع في مقالتك. عادةً تحتاج لذلك مرة واحدة في مقالتك فقط.

إدخال الرموز الخاصةيتم بالنقر على أيقونة(Ω)، حيث تتيح إدخال رموز مختلفة، مثلاً من اليونانية والعربية والعبرية وغيرها. يمكن تعديل هذه القائمة محلياً. شاهد قائمة VisualEditor/Special characters للتعليمات.
VisualEditor Toolbar SpecialCharacters-ar.png

VisualEditor toolbar edit notices icon.png
رمز «تبصرات التعديل» يعطي ملاحظات حول الصفحة.

VisualEditor More Settings-ar.png
خيارات الصفحة تقع على يمين أيقونة نشر التغييرات وبجانب أيقونة ضبط المحرر (التبديل بين المحرر المرئي وتعديل المصدر). تضم القائمة كل من:
  • التصنيفات لإضافة التصانيف
  • إعدادات الصفحة تتيح التحويل إلى صفحة أخرى أو إظهار وإخفاء فهرس المحتويات أو جعل الصفحة صفحة توضيحية وإعدادات متقدمة أخرى
  • إعدادات متقدمة تتيح بعض الاختيارات لفهرسة الصفحة بواسطة محركات البحث وإظهار أو إخفاء إشارة تبويب على هذه الصفحة لإضافة قسم جديد، وعرض العنوان لها.
  • اللغات والتي تعرض قائمة الصفحات بلغات أخرى مرتبطة بتلك الصفحة.
  • النقر على «القوالب المستخدمة» يقوم بعرض جميع القوالب المستخدمة في الصفحة.
  • تتيح خيارات الصفحة أيضا تسليط الضوء على التركيب بالنقر على الأيقونة الخاصة بذلك. خيارات الصفحة تتيح أيضا كل من:
  • تحديد تسنيق عرض المحتوى (يسار إلى يمين أو العكس)
  • إجراء عمليات بحث واستبدال

VisualEditor bi-directional switching square brackets icon.png
خيار تبديل المحرر يقع بجانب أيقونة نشر التغييرات ويتيح لك الذهاب إلى طريقة تعديل المصدر (wikitext editor)

نشر التغييرات

عند الانتهاء من التحرير، إضغط زر "نشر التغييرات" الأزرق الموجود في شريط الأدوات. لا يمكن النقر على الزر إن لم يكن هناك تغييرات. كي تلغي كافة تغييراتك، أغلق نافذة متصفحك أو اضغط على لسان «اقرأ» الموجود فوق شريط أدوات التعديل.
VisualEditor toolbar actions-ar.png

عند الضغط على زر "نشر التغييرات" سيتم توجيهك إلى صندوق حوار صغير يمكنك من خلاله إدخال ملخص عن تعديلك وتحديد المساهمة على أنها طفيفة واختيار مراقبة أي تعديلات تجرى على الصفحة لاحقاً.

يمكنك أيضا مراجعة تعديلاتك مستخدمًا زر «راجع تعديلاتك» للتأكد من أنها تعمل كما ينبغي قبل حفظها. هذا الأمر مشابه لزر «عرض التغييرات» الموجود في محرر نصوص الويكي.

لتأجيل نشر التعديلات يمكن النقر على خيار «تابع التعديل» والنشر لاحقاً.

VisualEditor save dialog-ar.png

تحرير الروابط

VisualEditor - Toolbar - Linking.png
يمكن إضافة الوصلات من خلال أيقونة "وصلة" (وصلات في سلسلة) الموجودة في شريط الأدوات أو من خلال إستخدام المختصر Ctrl+K (أو Command+K على ماك). لتحديد الكلمة أو الجملة التي تريد ربطها قم بتظليلها أولا.

إذا قمت بإختيار نص أو وضع المؤشر فوق كلمة ومن ثم قمت بالضغط على زر "وصلة"، سيتم إضافة وصلة للكلمة المختارة. أما لو أردت إدراج وصلة واحدة لجملة (أكثر من كلمة) فعليك تحديد النص المختار أولا ثم إدراج الوصلة.


VisualEditor-link tool-search results-ar.png
سواء كنت تستخدم الزر أو مختصر لوحة المفاتيح، سيتم عرض حوار يمكنك من كتابة الوصلة (سواء داخلية أو خارجية). سيحاول المحرر المرئي مساعدتك في التعامل مع الوصلات الداخلية من خلال البحث عن الإحتمالات المحتملة بمجرد أن تبدأ بطباعة نص الوصلة.

يقوم المشغل بالمساعدة عند البحث عن أي توافق لما يتم البحث عنه. ما إن تكتب أو تختار الوصلة، أو تنقر على «نفذ» أو انقر خارج مربع الحوار، ستظهر وصلتك على صفحة المحرر المرئي ولكن لن يتم حفظها حتى تحفظ الصفحة.


VisualEditor-link tool-external link.png
لإضافة وصلة لصفحة وب خارج ويكيبيديا، العملية هي نفسها؛ فقط أدخل الوصلة في الحقل وستضاف بصفة «موقع خارجي». وينبغي تظليل ما ستختار الوصلة الخارجية له أولاً!

VisualEditor link tool simple link.png
تظهر الروابط الخارجية بدون الاسم كالآتي على سبيل المثال: [١] يمكن إضافة الوصلات الخارجية كزر وصلات بدون أي نص عبر نقل المؤشر بعيدا عن النص (على سبيل المثال: بعد فراغ) ثم إضافة الوصلة. يمكن فتح أداة الرابط عبر النقر على الزر أو مفتاح الاختصار. قم بنسخ الرابط في النافذة المحددة للوصلة الخارجية وانقر على "نفذ" لإضافته.

VisualEditor-context menu-link tool.png
لتغيير أو إزالة وصلة موجودة، أنقر على النص المرتبط بوصلة ومن ثم إضغط على أيقونة «وصلة» أو «أزل وصلة» التي ستتواجد بالقرب من الإختيار. يمكنك أيضا النقر على نفس الأيقونة في شريط الأدوات أو إستخدام مخنصر لوحة المفاتيح Ctrl+K بينما يكون المؤشر على الوصلة. عند اختيار رابط ما، فيظهر ملوناً باللون الأزرق.

يمكنك حينئذا تحرير رابط الوصلة أو إزالتها كليا بالضغط على زر 'أزل الوصلة' (علامة الدائرة الحمراء) الموجود في أعلى الركن الأيسر من مربع الحوار. ربما ترغب بفتح الرابط الخارجي في نافذة جديدة عبر النقر على الرابط (يُحبذ للتأكد من أنه يعمل).

إذا رغبت بالخروج من الوصلة لمتابعة الكتابة يمكنك استخدام إشارة السهم على لوحة المفاتيح:

  • الضغط على الزر مرة واحدة سوف يغلق حوار تعديل الوصلة الشبكية وسيضع مؤشر فأرتك على نهاية العنصر الموصول (في إطار أزرق، والغرض هو تعديل هذا العنصر)
  • الضغط على الزر مرتين سوف يضع مؤشر الفأرة بعد العنصر الموصول، مستعدًا لكتابة باقي نصك.

لتغيير اسم وصلة موجودة، يمكن النقر عليه ثم كتابة اسم آخر. لكن لو رغبت بتغيير كلي لاسم الوصلة، الرجاء ملاحظة التالي:

  • إن كُنت ظللت (حددت) الاسم المربوط كاملاً، فسيم حذف الوصلة عند النقر على أي زر. ربما ترغب بالعودة لعمل الوصلة من جديد بعد ذلك.
  • للاحتفاظ بوصلة، يمكنكم النقر على الاسم المشار إليه بالصولة، واستعمال أزرار الفراغ والحذف مع التأكد من بقاء الوصلة المربوطة والتي تكون باللون الأزرق. الآن يمكنك اختيار اسم جديد مع الاحتفاظ بالوصلة.
  • يمكنك أيضا إضافة روابط لتصانيف وملفات وخلاف ذلك.

تحرير المراجع

للمزيد من المعلومات، طالع معلومات إضافية تجدها في ساحة المساعدة حول قوالب الاستشهاد..

تحديد نظام المراجع المستخدم أولا

الويكي الخاصة بلغتك قد تستعمل واحداً من ثلاث أنظمة للهوامش والحواشي. الأول والظاهر على اليسار هو قائمة «استشهد» والتي لا تحتوي على قوالب للاستشهاد. إذا كان نظام الويكي يستخدم هذا النظام، فكل ما تحتاجه حول الحواشي والهوامش على الصفحة التالية.
VisualEditor cite menu default.png

النظام الثاني للاستشهاد بالمصادر يتبع نفس قائمة «استشهد» السابقة، مع إضافات لبعض قوالب الاستشهاد المهمة والتي تُتيح استخداماً وإدراجاً أسرع لها. إذا كان الويكي يستعمل هذا النظام، فستجد تفاصيل أكثر في ساحة Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button-ar.png
النظام الثالث تبدأ به أيضا بالنقر على «استشهد» ثم تفتح نافذة الاستشهاد والتي تسمح بعملية الاستشهاد بشكل آلي باستعمل خدمة البحث الآلية. إذا كان الويكي يستعمل هذا النظام، فستجد تفاصيل أكثر في ساحة Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-ar.png

تحرير مرجع قائم

كي تعدل مرجع قائم، اضغط عليه حيث يظهر في النص (عادة في صيغة رقم بين قوسين مربعين). سوى ترى إما أيقونة «مرجع» (علامة مرجعية) أو أيقونة (واسم) للقالب الذي استخدم في إنشاء هذا المرجع. في أي من الحالتين، سوف ينتج عن الضغط على الزر «تعديل» مربع حواري حيث يمكنك تعديل المرجع.
VisualEditor - Editing references 1-ar.png

في حالة أيقونة «مرجع»، سينتج عن الضغط على «تعديل» فتح مربع الحوار المخصص للمراجع. كي تشرع في تغيير بيانات لمرجع، اضغط عليه.

تستخدم الكثير من مواقع الويكي القوالب كي تضبط صيغة المراجع. لو استخدم أحد القوالب في إضافة مرجعك، حينما تنقل مؤشرك إلى بيانات المرجع، سوف تُظَلل كافة البيانات الموجودة في تلك الخانة.

لو استخدم قالب وضغطت أنت على بيانات المرجع، سوف تظهر أيقونة قالب (قطعة من أحجية) مع بعض المعلومات. اضغط على زر «تعديل» كي تعدل محتوى القالب من مربع حوار محرر القالب المصغّر.

VisualEditor - Editing references 6-ar.png

لو كان ما ظهر حينما ضغطت على مرجع هو أيقونة للقالب القياسي المستخدم في الاستشهادات (يوجد مثال على ذلك على اليسار)، سوف ينتج عن الضغط على زر «تعديل» فتح مربع حوار محرر القوالب المصغّر.
VisualEditor - Editing References - Cite Web.png

يمكنك من داخل المحرر المصغّر للقوالب إضافة أنواع البيانات أو إزالتها أو تغيير المحتوى القائم. سوف تظهر الخانات (متغيرات القالب) التي أضيف إليها محتوى لا غير، في البداية. إن أردت إضافة خانات، اضغط على «إضافة معلومات أخرى» في الجزء الأسفل من المحرر المصغّر.
VisualEditor - Editing references 5-ar.png

اضغط على زر «طبق التعديلات» حينما تنتهي.
VisualEditor Apply Changes-ar.png

إعادة استخدام مرجع قائم

إذا كان هناك مرجع قائم ومستخدم من قبل في الصفحة، يمكنك إعادة استخدامه لنص أخر بحاجة إلى ذلك المصدر.

لإعادة استخدام مرجع قائم، ضع مؤشرك في المكان الذي تود إضافته، وانقر على أيقونة «مرجع» في شريط الأدوات ثم على «أعد الاستخدام». هناك طريقة أخرى سهلة وهي النقر على رقم المرجع ثم نسخه ولصقه في المكان المناسب في النص.

ملاحظة: إذا كان نظام الويكي لديك هو النظام الثالث فسيظهر خيار أعادة الاستخدام في شريط الأدوات بدلاً من قائمة المراجع.

VisualEditor Cite menu re-use.png

في مربع الحوار مرجع، انظر إلى القائمة بحثًا عن المرجع الذي ترغب في إعادة استخدامه، واختره. لو كانت ثمة عدة مراجع، يمكنك استخدام مربع البحث (مكتوب عليه «البحث ضمن الاستشهادات الحالية») كي ترى تلك المراجع التي تتضمن نص معين.
VisualEditor - Editing references 18.png

إضافة مصدر جديد

لإضافة مرجع جديد، ضع مؤشرك في المكان الذي تود إضافته، وإنقر على أيقونة مرجع في شريط الأدوات، ثم اختر قالب الاستشهاد المناسب.
VisualEditor references more.png

استعمال الصيغة الأساسية للاستشهاد

هذا ما تراه عند اختيار الصيغة الأساسية للاستشهاد. في محرر المرجع، يمكنك إضافة وتعديل وتنسيق مصدرك.

يمكنك أن تضيف المرجع إلى مجموعة قائمة، إلا أن هذا في المعتاد يترك فارغًا. (يستخدم هذا الخيار في عرض مجموعات من المراجع مستخدمًا أداة «قائمة مراجع».)

VisualEditor - Editing references 20.png

إذا قمت بإضافة مرجع جديد وتود أن تستخدم قالبا به، قم بالنقر على أيقونة الإضمان (صورة قطعة أحجية) في شريط الأدوات الخاص بمحرر المرجع. الخطوات: النقر على المرجع المُرَقَّمْ، ثم النقر عل «إدراج» ثم على «قالب»، وأخيراً البحث عن القالب المناسب واختياره.
VisualEditor Template Insert Menu-ar.png

ابحث بعد ذلك عن القالب الذي ترغي في استخدامه وأضفه وعدّله كما تفعل مع أي قالب آخر. (طالع قسم تحرير القوالب تاليًا لو كنت تبحث عن مزيد من المعلومات عن القوالب.)

بعد الانتهاء من تعديل قالبك الجديد، اضغط على «طبق التعديلات» كي تعود إلى محرر المراجع واضغط «طبق التعديلات» مرة أخرى كي تعود إلى الصفحة التي تعدلها.

VisualEditor - Editing references 9.png

لو لم توجد بالفعل قائمة مراجع على الصفحة (ربما كنت تضيف على سبيل المثال أول مرجع إلى صفحة) ستحتاج لتحديد محل قائمة المراجع ونصها التي سوف تظهر للقارئ.

ضع المؤشر حيث تريد عرض قائمة المراجع (يكون هذا المكان غالبا في أسفل الصفحة) وأنقر على أيقونة قائمة مراجع (ثلاثة كتب) لإضافته من قائمة إدراج في شريط الأدوات.

VisualEditor References List Insert Menu-ar.png

إذا قمت بإنشاء مجموعات من قوائم المراجع وهو أمرٌ نادر الحدوث، يمكنك تحديد مجموعة معينة في مربع الحوار، تظهر فقط المراجع المختصة بهذه المجموعة فقط في مكان المجموعة.

لإضافة قائمة مراجع، كل ما عليك فعله هو الضغط على "إدراج" لإدراجها.

VisualEditor references list-ar.png

استخدام قوالب الاستشهاد المعيارية

قد يحتوي نظام الويكي للغتك قوالب استشهاد إضافية في القائمة. في هذه الحالة، سيُتاح لك الوصول السريع لأكثر القوالب استخداما في ويكي الخاصة بلغتك. (تجد تعليمات حول كيفية إضافة قوالب استشهاد لويكي الخاصة بلغتك في قائمة المساعدة VisualEditor/Citation tool .)
VisualEditor - Editing References - Cite Pulldown.png

بالنقر على الاستشهاد بمرجع كتاب، تُفتح نافذة الاستشهاد (Cite book). المعلومات المهمة تظهر مُعلَّمة بإشارة نجمة. تظهر أغلب البيانات التي يمكن ملؤها، سواء الاختيارية أم الإلزامية.
VisualEditor - Editing references - Cite book required fields.png

لإضاقة بيانات أخرى للاستشهاد، يمكنك النقر على إضافة معلومات أخرى والاختيار من المقترحات.

قم بالنقر أخيراً على زر "إدراج".

VisualEditor - Editing references - Add parameter.png

تحرير الصور وملفات الوسائط المتعددة الأخرى

تحرير صور

لإضافة صورة جديدة (أو ملف وسائط أخر) للصفحة، إضغط على أيقونة "الصور والوسائط" في "إدراج" وسيتم إضافة الصورة عند مكان المؤشر.
VisualEditor Media Insert Menu-ar.png

سينتج عن الضغط على أيقونة «الصور والوسائط» مربع حوار يبحث آليًا في ويكيميديا كومنز وموقعك الويكي المحلي عن ملفات وسائط معنية بعنوان الصفحة التي تعدلها.

يمكنك أيضا البحث عن ملفات وسائط أخرى بتغيير النص الموجود في مربع البحث.

اضغط على إحدى الصور أو الملفات لاختيارها.

هذا يدرج الصورة في الصفحة التي تقوم بتعديلها في مكان وجود المؤشر.

VisualEditor - Media editing 2.png

بعد اختيار صورة بالنقر على استخدم هذه الصورة تظهر نافذة حوار تتيح إضافة وتعديل تعليق للصورة (يظهر تحتها عند النشر). كما يمكن أن يحتوي التعليق على وصلاة وتنسيقات مختلفة.
VisualEditor - Media editing 6-ar.png

نافذة إعدادات الوسائط المفتوحة تُتيح أيضا استخدام نص بديل للتعليق لمن يستخدمون قارئ الشاشات أو يعطلون عرض الصور على أجهزتهم.
VisualEditor - Media editing 7.png

يمنك أيضا تحديد عوامل إضافية للصورة كموضعها في الصفحة ونوع وحجم الصورة. يتم ذلك بالنقر على خيار إعدادات متقدمة أو متقدم.
VisualEditor - Media editing 8.png

حينما تنتهي من عملك، اضغط على «طبق التعديلات» كي تغلق مربع الحوار والعودة إلى تعديل الصفحة.
VisualEditor Apply Changes-ar.png

كما يمكن تعديل تعليق صورة مُدرجة مسبقا بالنقر عليها والذهاب إلى نافذة التعديل بالنقر على تعديل الذي يظهر أسفل الصورة.

يمكنك تغيير حجم صورة مُدرجة بسحبها في الزاوية اليسرى من الأسفل (قد يتغير لجهة اليمين مستقبلاً) حيث تظهر إشارات الأسهم المتعاكسة.

يمكنك أيضا سحب ثم إفلات الصورة إلى مكان أعلى أو أدنى في الصفحة.

VisualEditor - Media editing 3-ar.png

رفع الصور

يمكنك رفع الصور من لسان موجود في مربع حوار الوسائط أو عن طريق سحب ملف وإفلاته داخل المحرر، أو عن طريق لصق صورة من حافظة الكمبيوتر لديك.
VisualEditor - Media upload 1.png

اضغط على لسان «رفع» واختر الصورة من كمبيوترك. يمكنك كتابة اسم الملف أو سحب الصورة داخل المربع وإفلاتها. إذا قمت بسحب الصورة للنافذة مباشرة أو لصقتها من الحافظة، سيتم فتح نافذة الحوار المجاورة.
VisualEditor - Media upload 1.5.png

تحتاج لوصف الصورة وإضافة تصانيف لها، ليتمكن الآخرون من إيجادها.
VisualEditor - Media upload 2.png

سيتم إدراج الصورة بعد الانتهاء من الرفع واختيار استخدامها.
VisualEditor-logo.svg

تحرير معارض الوسائط المتعددة

لإضافة معرض (مجموعة من الصور) تنقر على إدراج وتختارها. سيظهر خيار المعرض إن كان متاحاً في تطبيق الويكي الخاص بلغتك.
VisualEditor - Gallery1.png

لتعديل معرض صور مُدرج مسبقا انقر عليه، ثم انقر على تعديل، فتتنقل إلى نافذة التعديل وتظهر قائمة الصور المستخدمة في المعرض.
VisualEditor - Gallery2.png
يُتيح لك محرر المعرض تعديل محتواه بإدراج صور جديدة وتعديل بياناتها وخصائصها. يمكنك أيضا تعديل هذه القائمة بحذف أو إعادة تعيين الصور أو تعديل العناوين.

عند الانتهاء انقر على نفذ لإغلاق محرر المعرض وإظهار التعديلات على الحالة التي ستظهر للقُرَّاء أيضا.

لا تنسى! إغلاق محرر المعرض لا يعني نشر تعديلاتك. حتى تصبح تعديلاتك متاحة ومنتشرة أونلاين، عليك النقر على نشر التغييرات.

VisualEditor - Gallery3.png

تحرير القوالب

البدء

لإضافة قالب جديد، ضع مؤشرك في المكان الذي تود إضافته، وإنقر على أيقونة "قالب" (صورة قطعة أحجية) في قائمة "إدراج".
VisualEditor Template Insert Menu-ar.png

ابدأ بكتابة اسم القالب الذي تود إدراجه. عندما يظهر لك، انقر على اسمه ثم على "أضف القالب" لإضافته.
VisualEditor - Template editing 4.png

يمكنك أيضًا تعديل قالب موجود على الصفحة. حينما تضغط على القالب كي تختاره، سوف يتحول إلى اللون الأزرق، وسيظهر مربع يحتوي على أيقونة «قالب» (قطعة أحجية). اضغط بعد ذلك على وصلة «عدل».
VisualEditor - Template editing 1.png

بعض القوالب ليست مرئية (في وضع مخفي) لمن يقرأ الصفحة. يكون شكل هكذا قوالب مخفية في المحرر المرئي على صورة قطع أحجية. يظهر اسم القالب بجانب قطعة الأحجية الخاصة بالقالب.
VisualEditor template not visible.png

عند النقر على الأيقونة، تُفتح نافذة تسمح لك بتعديل القالب.
VisualEditor template not visible context menu.png

عناصر القوالب

حينما تضيف قالب جديد أو تفتح قالب قائم، سيظهر المربع الحواري «⧼visualeditor-dialog-transclusion-title⧽». يعتمد محتواه على ما إذا كان القالب قد جرى توثيقه باستخدام نظام TemplateData أم لا.

القالب المعروض جانباً لا يحوي معلومات قالب مُعدة له. تظهر نافذة الحوار رابط للتوثيق حول القالب. تسطيع بزيارتك لصفحة القالب التعرف على بارامترات (محددات) هذا القالب ورؤية ما يحتويه كل حقل. استعمل الأرقام كاسم لكل حقل بلا اسم. يتم ترقيم البارامترات الفارغة (بلا اسم) بشكل تصاعدي فالأول يأخذ اسم 2 والثاني 1 وهكذا.
VisualEditor template with no TemplateData.png

لو كان أحد القوالب قد جرى تعديله كي يحتوي على بيانات TemplateData، سوف يعرض المربع الحواري قائمة بالمتغيرات المنفردة (كلٌ باسمه).
VisualEditor template with TemplateData.png

يمكنك إضافة معاملات لقالب موجود بالنقر على "إضافة معلومات أخرى" أو تعديل الموجود حاليا.
VisualEditor - Template editing 3.png

عندما يتم تضمين قالب في قوالب أخرى (القوالب المضمنة ستكون فرعية)، ستظهر القوالب الفرعية على أنها معاملات. يمكن تعديل أو إزالة القالب الفرعي داخل الحقل الخاص.

إضافة القوالب الفرعية تتم كما تتم عملية إضافة معامل إلى قالب. قد تحتاج إلى قراءة توثيق القالب لضمان أن القالب الفرعي المراد إستخدامه مدعوم.

القوالب المتاخلة قابلة للتعديل حالياً فقط عبر تعديل المصدر وغير متاحة للمحرر المرئي بعد (see phab:T52182).
VisualEditor - Template editing 5.png

الانتهاء

عند إنتهائك، قم بالنقر على "طبق التعديلات" لغلق مربع الحوار والرجوع إلى محرر الصفحة.
VisualEditor Apply Changes-ar.png

استبدال القوالب

عند الرغبة بإدراج قالب مضمن في آخر (substituted)، إطبع subst: (النقطتان الرأسيتان محسوبة) قبل اسم القالب.

خاصية الإكمال التلقائي لا تعمل مع التضمين (subst:). إذا أردت هذه الخاصية قم بإستخدام subst: وليكن هذا بعد العثور على القالب المراد إستخدامه.

ومن ثم، اضغط على زر "أضف القالب".

أضف أي معاملات كما هو معتاد وإضغط على "إدراج".

VisualEditor - Template editing 7.png

سوف ترى القالب يتمدد على الصفحة بعد الضغط على "طبق التعديلات".
VisualEditor - Template editing 8.png

تحرير القوائم

VisualEditor Toolbar Lists and indentation-ar.png
يمكن استعمال المحرر المرئي لإدراج أو تعديل القوائم. هناك صيغتا للقوائم: قائمة منقطة وقائمة مرقمة.

لتبدء بقائمة جديدة، انقر على شارة القائمة من أدوات التحرير، واختر نوع القائمة، والتي سيتم إدراجها في مكان المؤشر. يمكنك أيضا أن تقوم باختيار قائمة أعددتها (عنصر في كل سطر) ومن ثم تنقر على أيقونة القائمة التي ترغب بإدراجها.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
في المثال ترى أمثلة لنوعي القوائم: المنقطة (غير المرقمة) والقائمة المرقمة.

VisualEditor lists 3 select to indent.png
إن كنت ترغب بتغيير مستوى إظهار أحد أو بعض عناصر القائمة، قم باختياره/ا.

VisualEditor lists 4 indentation menu.png
ثم استعمل القائمة مرة أخرى واختر منها أحد خياري الإزاحة، بالإنقاص أوالزيادة.

VisualEditor lists after indenting.png
هنا ترى النتيجة عند اختيار زيادة الإزاحة لعنصرين مختارين.

VisualEditor lists mixed.png
كما يُمكن أيضا التشكيل في صنع القائمة بحيث تكون بعض العناصر منقطة وأخرى مُرقَّمة.

تعديل الجداول

VisualEditor insert table-ar.png
يمكن استخدام المحرر المرئي لإدراج وتعديل الجداول.

يمكنك حتى أن تضيف جدول من ملف بقيم مفصولة بفاصلة (comma-separated values) بإدراجه من حاسوبك مباشرة في نافذة التعديل.


عند نقرك على إدراج ثم جدول من إدراج، فيتم إدراج جدول فارغ ذو أبعاء 4 في 4.

تظهر قائمة الجدول والتي يمكنك من خلالها إضافة عنوان للجدول.

VisualEditor empty table.png

لاختيار خانة في الجدول قُم بالنقر عليها.
VisualEditor tables select one cell.png

لتعديل محتوى خانة معينة في الجدول، قم بالنقر المزدوج عليها. أو تنقر على الخانة ثم تضغط على زر Return.

لإنهاء التعديل لخانة ما، قم بنقل المؤشر ببساطة لمكان آخر.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
يمكنك أضافة عمود أو صف أو نقله أو حذفه.

يمكنك أيضا دمج الخلايا (الخانات) باختيارها ثم النقر على "دمج الخلايا".
VisualEditor tables merge cells.png

عند دمج الخلايا، يبقى محتوى خلية واحدة فقط ويُحذف محتوى باقي الخلايا. إن كنت ترغب باسترجاع بعض أو كل النص المحذوف أنقر على ألغ الدمج.
VisualEditor tables post-merge cell.png

يمكنك أيضا فصل خلايا مُدمجة سابقاً. عند القيام بذلك يبقى النص في الخلية الأولى. ربما ترغب بقصه ولصقه لخلية أو خلايا أخرى إن رغبت.
VisualEditor tables split cells.png

تحرير التصنيفات

VisualEditor category item-ar.png
لتعديل التصنيفات، انقر على التصنيفات ضمن قائمة خيارات الصفحة.

VisualEditor category editing-ar.png
يفتح مربع حوار بالتصنيفات يعرض التصنيفات القائمة للصفحة ويسمح لك بإضافة تصنيفات جديدة أو حذف المستخدمة.

لديك أيضًا خيار ضبط أو تغيير مفتاح الفرز العمومي (الافتراضي)، الذي يحدد مكان ظهور الصفحة حينما تسرد في قائمة مع صفحات أخرى في ذات التصنيف.

إن مفتاح الفرز الافتراضي على سبيل المثال لمقالة «George Washington» هو «Washington, George». سوف تسرد المقالة في تصنيف «رؤساء الولايات المتحدة الأميركية» تحت الحرف «W»، لا الحرف «G».


VisualEditor - Category editing 3.png
كي تضيف تصنيف إلى صفحة، اكتب اسم التصنيف في الخانة «أضف التصنيف». أثناء الكتابة، سوف يبحث المحرر المرئي عن أسماء مشابهة محتملة وكذا تصنيفات قائمة. يمكنك إما أم تختار تصنيف قائم أو يمكنك إضافة تصنيف لا يوجد له صفحة تصنيف قائمة. (سوف يظهر تصنيفك الجديد في صيغة وصلة حمراء بعد أن تنشر كافة تعديلاتك إلى أن تنشئ صفحة التصنيف هذه.)

VisualEditor - Category editing 2.png
لإزالة تصنيف قائم، إضغط عليه ومن ثم إنقر على أيقونة أزل (صورة سلة المهملات) في مربع الحوار الذي سوف يظهر.

يمكنك أيضا تحديد مفتاح الترتيب لتصنيف معين في مربع الحوار المفتوح. سيقوم هذا بإبطال المفتاح العام للتصنيف المعدل.


VisualEditor Apply Changes-ar.png
اضغط على «طبق التعديلات» حينما تنتهي من تعديل التصنيفات كي تعود إلى محرر الصفحة.

تعديل إعدادات الصفحة

VisualEditor page settings item-ar.png
لتعديل إعدادات صفحة ما، افتح قائمة خيارات الصفحة في شريط الأدوات ثم انقر على زر إعدادات الصفحة.

VisualEditor Page Settings-ar.png
بالنقر على زر إعدادات الصفحة يظهر مربع حوار ويتضمن عدة خيارات.

VisualEditor Page Settings Redirects-ar.png
يمكنك أن تجعل صفحة ما صفحة إعادة توجيه إلى صفحة أخرى عن طريق وضع علامة في المربع «حول الصفحة إلى»، ومن ثم كتابة اسم الصفحة التي ترغب في أن يذهب القارئ الذي يحاول الذهاب إلى الصفحة التي تعدلها إليها.

أسفل الخانة التي تضع اسم التحويلة فيها يأتي خيار يتيح لك منع تغيير التحويلة عندما يقوم محرر بتغيير اسماء صفحات. هذه الخاصية تستخدم بشكل نادر جداً.


VisualEditor Page Settings TOC-ar.png
يمكنك تغيير ما إذا كانت الصفحة تحتوي على جدول محتويات أم لا عن طريق تحديد واحد من هذه الأزرار الثلاثة. الخيار الافتراضي هو «أظهر إن لزم الأمر» وهو الذي يعرض جدول محتويات لو كانت الصفحة تحتوي على عدد ثلاثة عناوين رئيسية أو أكثر.

VisualEditor Page Settings Edit Links-ar.png
يمكنك أن تجعل الصفحة لا تظهر وصلات التعديل بجانب عنوان كل قسم بالنقر على مربع الاختيار هذا.

VisualEditor Apply Changes-ar.png
اضغط على «طبق التعديلات» حينما تنتهي من تعديل خيارات الصفحة كي تعود إلى محرر الصفحة.

تحرير الخرائط

Visual editor showing editing an existing map.jpg
يمكنك إضافة وتعديل الخرائط.. طالع Help:VisualEditor/Maps للمزيد.

تعديل الصيغ الرياضية

لإضافة صيغة رياضية للصفحة، ضع المؤشر في المكان الذي تود إراجها إليه، وانقر على صيغة رياضية ("Σ") في قائمة إدراج.
VisualEditor Formula Insert Menu-ar.png

يتم فتح نافذة يمكنك كتابة الصيغة الرياضية فيها باستخدام كود لاتخ (LaTex). بما أن تبدء بالكتابة، يقوم المحرر المرئي بتحديث النتيجة لما تكتبه بحث تراه بينما تضيف. عندما تكون راضياً عن النتيجة انقر على زر "إدراج" لإدراج ما كتبته في الصفحة.
VisualEditor formula-ar.png

كي تعدل صيغة رياضية قائمة على الصفحة، اضغط عليها ومن ثم اضغط على أيقونة «Σ» التي ستظهر. سوف يفتح هذا نافذة الصيغ الرياضية، حيث يمكنك عمل التغييرات.
VisualEditor - editing existing mathematical formula.png

يمكن وضع الصيغ الرياضية داخل السطر أو كقالب لوحده في وسط الصفحة.
VisualEditor mathematic formula inline.png

تعديل العلامات الموسيقية

لإضافة نوتة موسيقية إلى الصفحة، ضع المؤشر في المكان الذي ترغب بإضافته فيه. من شريط الأدوات انقر على إدراج ثم على علامة موسيقية.

لتعديل نوتة موسيقية مُدرجة مُسبقاً، انقر عليها مرتين (نقر مزدوج).

VisualEditor-Insert-Musical-Notation.png

سيتم فتح نافذة حوار للعلامة الموسيقية. حيث يمكنك اختيار لغة النوتة (خيار ABC و ليلي بوند). يمكنك أيضا ربط النوتة الموسيقية بملف صوتي موجود أو ملف MIDI. عند انتهائك انقر على نفذ لإغلاق نافذة الحوار وإنهاء التعديل.
Musical.png

تحرير الأشعار وبعض العناصر الخاصة

بعض العناصر الخاصة ما زالت حتى الآن غير مدعومة من المحرر المرئي.
VisualEditor editing poem 1.png

في أغلب الأحيان يمكن تعديل العناصر الموجودة، ولكن لا يمكن إضافة أخرى جديدة عبر المحرر المرئي.

إلى حين إتاحة الاستخدام كلياً عبر المحرر المرئي، يمكن نسخ عناصر من صفحات أخرى أو إجراء التعديلات عبر تعديل المصدر.

VisualEditor editing poem 2.png

تغيير المحرر (التحويل بين المحرر المرئي وتعديل المصدر)

للتحويل إلى تعديل المصدر انقر على زر [[ ]] في أقصى يسار شريط الأدوات العلوي.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

سوف ترى الفرق. (أما إن نقرت على ألغاء التحويل فستعود للمحرر المرئي ولا ترى أي فرق.)

عند تحولك لتعديل المصدر اذهب للأسفل وألقِ نظرة على نافذة التحرير.

VisualEditor bi-directional switching diff before wikitext.png

يمكنك بالتأكيد العودة مرة أخرى للمحرر المرئي بالنقر على أيقونة القلم في يسار الصفحة العلوي ثم اختيار أيقونة العين للتحرير المرئي.

VisualEditor bi-directional switching pencil icon in wikitext.png

اختصارات لوحة المفاتيح

تعتمد الكثير من أدوات وبرامج التحرير على إدخال نص الويكي مباشرة، خصوصا عمليات تغليظ وإمالة النص وإضافة الوصلات. تسمح Keyboard shortcuts بسرعة إدراج تنسيقات مماثلة من غير الإضطرار إلى الضغط على أزرار شريط الأدوات. هنا ترى قائمة بأشهر اختصارات لوحة المفاتيح في المحرر المرئي.

وصلة كمبيوتر فعل وصلة كمبيوتر ماكنتوش

Ctrl+B غليظ Cmd+B

Ctrl+I مائل Cmd+I

Ctrl+K أدرج وصلة Cmd+K

Ctrl+X قص Cmd+X

Ctrl+C نسخ Cmd+C

Ctrl+V لصق Cmd+V

Ctrl+Z تراجع Cmd+Z