সাহায্য:দৃশ্যমান সম্পাদনা/ব্যবহারকারী নির্দেশিকা

< Help:VisualEditor
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 23% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD টীকা: যখন আপনি এই পাতা সম্পাদনা করছেন, তখন আপনি আপনার অবদান সিসি০'র অধীনে দিতে সম্মত হচ্ছেন। আরও তথ্যের জন্য পাবলিক ডোমেইন সাহায্য পাতা দেখুন।
PD
যদি আপনি একটি নিবন্ধ সম্পাদনা করা ছাড়া দৃশ্যমান সম্পাদনা ব্যবহার করতে চান তাহলে, এখানে সেই পাতাটি পাবেন যেখানে আপনি অবাধে তা পরীক্ষা করতে পারবেন। সেই পাতায় দৃশ্যমান সম্পাদনা ব্যবহার করার জন্য আপনার একটি অ্যাকাউন্টের প্রয়োজন হবে না।

দৃশ্যমান সম্পাদনা খোলা

দৃশ্যমান সম্পাদনা ব্যবহার করে একটি পাতা সম্পাদনা করার জন্য, পাতার উপরে "সম্পাদনা" ট্যাবে ক্লিক করুন।

সম্পাদনার জন্য পাতা খুলতে কয়েক সেকেন্ডের সময় নিতে পারে, এবং দীর্ঘতর হতে পারে যদি পাতাটি খুবই দীর্ঘ হয়।

"উৎস সম্পাদনা" ট্যাবের উপর ক্লিক করা হলে ক্লাসিক উইকিটেক্সট উৎস সম্পাদনা খুলবে।

VisualEditor edit tab-bn.png

এছাড়াও আপনি প্রতিটি অনুচ্ছেদের "সম্পাদনা" লিঙ্কে ক্লিক করে দৃশ্যমান সম্পাদনা খুলতে পারেন।
VisualEditor - Section edit links-en.png

শুরু করার জন্য: দৃশ্যমান সম্পাদনা সরঞ্জামদণ্ড

দৃশ্যমান সম্পাদনার সরঞ্জামদণ্ডের স্ক্রীনশট
ভিজ্যুয়ালএডিটর টুলবার পর্দার উপরের অংশে প্রদর্শিত হবে যখন আপনি ভিজুয়ালএডিটরের মাধ্যমে সম্পাদনা আরম্ভ করবেন। এটি কিছু পরিচিত আইকনসহ:

VisualEditor - Toolbar - Undo-redo.png
আপনি যে পরিবর্তন করেছেন তা পূর্বাবস্থা এবং কাজটি পুনরায় করো করুন।

VisualEditor Toolbar Headings-bn.png
শিরোনামা টেনে-নেওয়া-নিম্নমুখী মেনু: আপনাকে পাঠ্যের শীর্ষচরণের স্তর পরিবর্তনের অনুমতি দিবে। পরিচ্ছেদের আদর্শ শিরোনামাটি হচ্ছে "শিরোনামা"। লেখার জন্য সাধারন বিন্যাসটি হচ্ছে "অনুচ্ছেদ"।

VisualEditor Toolbar Formatting-bn.png

বিন্যাসন: "A" ক্লিক করার দ্বারা মেনু খুলবে।

  • "গাঢ়" আইটেম (B) নির্বাচিত লেখা গাঢ় করে।
  • "বাঁকা" আইটেম (I) নির্বাচিত লেখা বাঁকা করে।
  • The "ঊর্ধ্বলিপি" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • The "নিম্নলিপি" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly lower than the surrounding text.
  • "অবচ্ছেদন" আইটেম (S) নির্বাচিত লেখার মাঝে গাঢ় দণ্ড যোগ করে।
  • The "কম্পিউটার কোড" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "নিম্নরেখ" item (U) adds a solid line beneath the selected text.
  • The "ভাষা" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "শৈলী পরিষ্কার", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

VisualEditor - Cite Pulldown.png
উদ্ধৃতি menu: The "উদ্ধৃতি" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to basic reference formatting and the ability to re-use citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the উদ্ধৃতি menu at a specific wiki are available at VisualEditor/Citation toolVisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
উদ্ধৃতি বোতাম: If the citoid service is enabled on your wiki, then you will see a উদ্ধৃতি button instead of a উদ্ধৃতি menu.

চাইটইয়েড পরিষেবা তথ্যসূত্র টেমপ্লেট স্বয়ংক্রিয়ভাবে পূরণ করার চেষ্টা করে।


VisualEditor Toolbar Lists and indentation-bn.png
তালিকা এবং ইন্ডেন্টেশন প্রথম দুটি আইকন আপনাকে যথাক্রমে, সংখ্যায়িত অথবা বুলেটকৃত তালিকা তৈরী করতে অনুমতি দেয়। শেষ দুটি আপনাকে বিষয়বস্তুর ইন্ডেন্টেশনের মাত্রা বৃদ্ধি বা হ্রাস করার অনুমতি দেয়।

VisualEditor Insert Menu-bn.png
মিডিয়া, তথ্যসূত্র এবং অন্তর্ভুক্তি: প্রতিটি আইকন একটি নিয়োজিত ডায়ালগ খোলে:
  • "মিডিয়া" আইকন (পর্বতমালার একটি ছবি) মিডিয়া ডায়ালগ খোলে।
  • The "টেমপ্লেট" icon (a puzzle piece) allows you to edit templates.
  • The "Table" item allows you to insert a table.
  • The "মন্তব্য" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.
  • The "হায়ারোগ্লিফ" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • "গ্যালারি" আইকন (ছবির একটি সেট) আপনাকে পাতায় একটি গ্যালারি সন্নিবেশ করার অনুমতি দেয়।
  • The "সূত্র" icon (Σ) opens the formula inserter dialog.
  • The "Graph" item allows you to insert a graph.
  • The "আপনার স্বাক্ষর" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • * "⧼visualeditor-dialogbutton-referencelist-tooltip⧽" আইকন (তিনটি বই) তথ্যসূত্র প্রদর্শনের একটি ডায়ালগ খোলে।

Special character insertion: The "বিশেষ বর্ণ" (Ω) icon is next to the "যোগ করো" menu. When clicked, it displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (This list may be customized locally. See VisualEditor/Special charactersVisualEditor/Special characters for instructions.)
VisualEditor Toolbar SpecialCharacters-bn.png

VisualEditor toolbar edit notices icon.png
সম্পাদনা বিজ্ঞপ্তি বোতাম পাতার জন্য যেকোন বিজ্ঞতি প্রদর্শন করে।

VisualEditor More Settings-bn.png
আপনার পরিবর্তনগুলি বাতিল বা সংরক্ষণ করুন।

VisualEditor bi-directional switching square brackets icon.png
The উৎস সম্পাদনায় যান button is next to the পাতা সংরক্ষণ button. It allows you to switch to the wikitext editor.

পরিবর্তনগুলি সংরক্ষণ করা

আপনার সম্পাদনা সম্পন্ন হলে, সরঞ্জামদণ্ডের সবুজ "পাতা সংরক্ষণ" বোতামে ক্লিক করুন। আপনি যদি কোন পরিবর্তন না করেন, তাহলে বোতামটি নিষ্ক্রিয় থাকবে (ধূসর রঙে)। আপনার সম্পাদনায় করা সব পরিবর্তন বাতিল করতে, শুধু আপনার ব্রাউজারের উইন্ডোটি বন্ধ করুন।
VisualEditor toolbar actions-bn.png

সবুজ "Save page" বাটন টিপলে একটি ছোট ডায়ালগ খোলে যেখানে আপনি আপনার কর্মের একটি সংক্ষিপ্তসার লিখতে পারেন, অনুল্লেখ্য হিসাবে আপনার সম্পাদনা চিহ্নিত করুন, এবং ভবিষ্যতে পাতার সম্পাদনায় নজর রাখুন নির্বাচন করুন

সংখ্যাগুলি নির্দেশ করে আপনার সম্পাদনা সারাংশে কতটুকু খালি জায়গা বাকি। এছাড়াও আপনি আপনার পরিবর্তনগুলি সংরক্ষণের আগে তাদের উদ্দীষ্ট কাজ নিশ্চিত হতে আপনার পরিবর্তনগুলি পর্যালোচনা করতে পারেন।

The "সম্পাদনা পুনরায় আরম্ভ করুন" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-bn.png

লিঙ্ক সম্পাদনা করা

VisualEditor - Toolbar - Linking.png
সরঞ্জামদণ্ডের "লিঙ্ক" আইকনের (একটা চেন সংযোগগুলি) মাধ্যমে লিঙ্ক যোগ করা যেতে পারে, অথবা শর্টকাট Ctrl+K (বা ম্যাকে Command+K) ব্যবহার করে।

আপনি যদি লেখা অথবা আপনার কার্সার দ্বারা কোন শব্দ নির্বাচন করেন, "লিঙ্ক" বাটন টিপে সেখানে একটি "Link" সন্নিবেশ করতে পারবেন।


VisualEditor-link tool-search results.png
আপনি বাটন অথবা শর্টকাট যাই ব্যবহার করেন, একটি ডায়ালগ খুলবে যেখানে আপনি লিঙ্ক টাইপ করতে পারেন। ভিজ্যুয়ালএডিটর আপনার টাইপে সম্ভবত মিল আছে এমন অভ্যন্তরীণ সংযোগগুলি (উইকিপিডিয়ার অন্যান্য পাতাগুলির লিঙ্ক) খোঁজার দ্বারা সাহায্য করার চেষ্টা করবে।

The link tool will try to help with internal links by searching for likely matches.


VisualEditor link tool 2015.png
লিঙ্ক প্রবেশ বা নির্বাচন করার পর, আপনি Enter টিপতে পারেন, বক্সের বাইরে ক্লিক করুন, অথবা বন্ধ (<) আইকন টিপুন। আপনার লিঙ্ক ভিজ্যুয়ালএডিটর পাতায় প্রদর্শিত হবে, কিন্তু আপনি পাতা সংরক্ষণ করা না পর্যন্ত এটি সংরক্ষিত হবে না।

VisualEditor-link tool-external link.png
To link to a web page on another website, the process is similar: Choose the "বহিঃসংযোগ" tab, and enter a URL in the box.

VisualEditor link tool simple link.png
লেবেল ছাড়া বহিঃসংযোগ দেখতে এই রকম হবে: [১]। You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by clicking on the button or pressing the shortcut keys. Type the URL in the box, and click the "সম্পন্ন" button to insert the link.

VisualEditor-context menu-link tool.png
একটি বিদ্যমান লিঙ্ক পরিবর্তন অথবা মুছে ফেলার জন্য, লেখার উপর লিঙ্কে ক্লিক করুন, তারপর এটির কাছাকাছি প্রদর্শিত "লিঙ্ক" আইকনে টিপুন। আপনি টুলবারে একই আইকন ক্লিক করে এটি করতে পারেন অথবা কীবোর্ড শর্টকাট Ctrl+K ব্যবহার করে এটি করুন। When a link is selected, it appears as blue framed.

তারপর আপনি লিঙ্ক -এর লক্ষ্য সম্পাদনা করতে পারেন, অথবা ডায়লগটির উপরের ডান দিকের কোণায় অবস্থিত 'অপসারণ' আইকনে (ট্র্যাশ ক্যান) টিপে সব একসাথে মুছে ফেলতে পারেন। You can also open the link's target in another window by clicking on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

তথ্যসূত্র সম্পাদনা করা

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "উদ্ধৃতি" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "উদ্ধৃতি" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

একটি বিদ্যমান তথ্যসূত্র সম্পাদনা করা

একটি বিদ্যমান তথ্যসূত্র সম্পাদন করার জন্য, লেখার উপর এটিতে ক্লিক করুন, এবং এটির কাছাকাছি প্রদর্শিত "তথ্যসূত্র" আইকনের (বুকমার্ক) উপর ক্লিক করুন।
VisualEditor - Editing references 1.png

তথ্যসূত্র আইকনের উপর ক্লিক করলে একটি ডায়ালগ খোলে যেটিতে একটি ক্ষুদ্র-সম্পাদনা বক্স রয়েছে, যেখানে আপনি তথ্যসূত্রের লেখা সম্পাদনা করতে পারেন।

অনেক উইকি একটি নির্দিষ্ট মান অনুযায়ী বিন্যাস তথ্যসূত্র টেমপ্লেট ব্যবহার। আপনি যদি একটি বিদ্যমান তথ্যসূত্র সম্পাদন করেন তখন আপনি এটি লক্ষ্য করবেন যার বিষয়বস্তু নীল দেখাবে যখন আপনি এটি নির্বাচন করেন।

If a template was used and you click on the reference information, then the টেমপ্লেট icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

অন্তর্ভুক্তি আইকন (ধাঁধার টুকরা) বাটনে ক্লিক করলে আপনি টেমপ্লেটের স্বতন্ত্র প্যারামিটার সম্পাদন করতে পারবেন।
VisualEditor - Editing references 5.png

কাজ সমাপ্ত হয়ে গেলে "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন, এবং এতে আপনি তথ্যসূত্র সম্পাদনায় ফিরে যাবেন।
VisualEditor Apply Changes-bn.png

একটি বিদ্যমান তথ্যসূত্র পুনঃব্যবহার করা

যদি পাতায় ইতিমধ্যে তথ্যসূত্র উল্লেখ থাকে, আপনি বিদ্যমান উদ্ধৃতি পুনরায় ব্যবহার করার জন্য চয়ন করতে পারেন, এটি প্রয়োগ করা যাবে যদি আপনি লেখা ক্ষেত্রে উৎস চান।

একটি বিদ্যমান তথ্যসূত্র পুনরায় ব্যবহার করার জন্য, আপনি যে লেখায় এটি যোগ করতে চান সেখানে আপনার কার্সার স্থাপন করুন, এবং টুলবারের "তথ্যসূত্র" আইকনের (বুকমার্ক) উপর ক্লিক করুন।

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "উদ্ধৃতি" menu.)

VisualEditor Cite menu re-use.png

যদি সেখানে অনেক তথ্যসূত্র থাকে, আপনি একটি প্রদত্ত লেখা সাথে মেলার জন্য তথ্যসূত্র প্রদর্শন অনুসন্ধান বার ("আপনি কোন তথ্যসূত্র চান?" লেবেল দেওয়া) ব্যবহার করতে পারেন।

তালিকার মধ্যে পুনঃব্যবহারের জন্য তথ্যসূত্রগুলি দেখুন, এবং তা নির্বাচন করুন।

VisualEditor - Editing references 18.png

একটি নতুন তথ্যসূত্র যোগ করা

একটি নতুন তথ্যসূত্র যোগ করার জন্য, আপনি যে লেখায় এটি যোগ করতে চান সেখানে আপনার কার্সার স্থাপন করুন, এবং টুলবারের "তথ্যসূত্র" আইকনের (বুকমার্ক) উপর ক্লিক করুন।
VisualEditor references more.png

Using the "Basic" citation

Shown here is what you will see if you select the basic references item. তথ্যসূত্র সম্পাদনায়, আপনি আপনার উদ্ধৃতি যোগ, সম্পাদনা এবং বিন্যাস করতে পারেন।

আপনি তথ্যসূত্র একটি প্রদত্ত দলের অংশভুক্ত করতে পারেন; এটি "তথ্যসূত্রের তালিকা" টুলসহ তথ্যসূত্র দল প্রদর্শন করতে ব্যবহৃত হয়।

VisualEditor - Editing references 20.png

যদি আপনি একটি নতুন তথ্যসূত্র যোগ এবং এটা একটি টেমপ্লেটের অন্তর্ভুক্ত করতে চাইলে, তথ্যসূত্র সম্পাদনার টুলবারের অন্তর্ভুক্তি আইকনে (ধাঁধার টুকরা) ক্লিক করুন।
VisualEditor Template Insert Menu-bn.png

তারপর, আপনি ব্যবহার করতে চান সেই রকম টেমপ্লেটের জন্য দেখুন, এটি যোগ করুন এবং একটি বিদ্যমান যেভাবে সম্পাদনা করে সেভাবে করুন।

তথ্যসূত্র সম্পাদনায় ফিরতে "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন এবং মূল সম্পাদনায় ফিরতে আবারও "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন।

VisualEditor - Editing references 9.png

পাতা তে তথ্যসূত্র একটি তালিকা ইতিমধ্যেই উপস্থিত না থাকলে (উদাহরণস্বরূপ, যদি আপনি পাতায় প্রথম তথ্যসূত্র যোগ করেন), প্রদর্শন করতে আপনার তথ্যসূত্র লেখার জন্য অনুক্রমে আপনার এটি যোগ করা প্রয়োজন।

আপনি যেখানে তথ্যসূত্র প্রদর্শন করতে চান সেখানে কার্সার রাখুন (সাধারণত পাতার নীচের অংশে), এবং এটি যোগ করতে "তথ্যসূত্রের তালিকা" আইকনে (তিনটি বই) ক্লিক করুন।

VisualEditor References List Insert Menu-bn.png

আপনি যদি তথ্যসূত্রের দল তৈরি করেন, আপনি বেছে বেছে এটির অন্তর্গত তথ্যসূত্র প্রদর্শনে, এই ডায়লগ বক্সের মধ্যে একটি দল নির্দিষ্ট করতে পারেন।

সহজে একটি তথ্যসূত্রের তালিকায় যোগ করার জন্য, ডায়লগের উপর "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন।

VisualEditor references list-bn.png

প্রমিত উদ্ধৃতি টেমপ্লেট ব্যবহার করা

Your local wiki may have added extra citation templates to the "উদ্ধৃতি" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "আরও প্যারামিটার যোগ করুন" option.

Click on "যোগ করো" when you're done.

VisualEditor - Editing references - Add parameter.png

ছবি এবং অন্যান্য মিডিয়া ফাইল সম্পাদনা করা

ছবি সম্পাদনা করা

পাতায় একটি নতুন চিত্র (অথবা অন্য মিডিয়া ফাইল) যোগ করার জন্য, টুলবারের "মিডিয়া" আইকনে (পর্বতমালার একটি ছবি) ক্লিক করুন।
VisualEditor Media Insert Menu-bn.png

"মিডিয়া" আইকনে ক্লিকে স্বয়ংক্রিয়ভাবে উইকিমিডিয়া কমন্সে আপনি যে পাতাটি সম্পাদনা করছেন সেই সংক্রান্ত মিডিয়া ফাইল অনুসন্ধান করার একটি ডায়ালগ খোলে।

আপনি ডায়লগটি এর অনুসন্ধান বক্সে লেখা পরিবর্তন করে অন্যান্য মিডিয়া ফাইলের জন্য সন্ধান করতে পারেন।

একটি ফাইল নির্বাচন করার জন্য থাম্বনেইল-এ ক্লিক করুন।

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

মিডিয়া ডায়লগটিতে আপনি একটি পরিচয়লিপি যোগ (এবং সম্পাদনা) করতে পারবেন, যেটিতে বিন্যাস এবং লিঙ্ক উপস্থিত থাকতে পারে।
VisualEditor - Media editing 6.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
Media editing 7.png

You can also set various parameters for the image in the "উন্নত সেটিং" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

সমাপ্ত হয়ে গেলে, ডায়লগ পাতা বন্ধ করতে এবং মূল সম্পাদনায় ফিরতে "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন।
VisualEditor Apply Changes-bn.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "মিডিয়া" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

ছবি আপলোড করা

মিডিয়া ডায়ালগের একটি ট্যাব থেকে আপনি ছবি আপলোড করতে পারেন।
VisualEditor - Media upload 1.PNG

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

মিডিয়া গ্যালারি সম্পাদনা করা

To add a new gallery, click the "গ্যালারি" icon (a set of photos) on the "যোগ করো" menu. (If you don't see this icon on that menu, then your local wiki has decided to delay implementing this functionality in the visual editor.)
VisualEditor - Gallery1.png

To edit an existing gallery in the visual editor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "সম্পন্ন" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

টেমপ্লেট সম্পাদনা করা

আরম্ভ

পাতায় একটি নতুন টেমপ্লেট যোগ করার জন্য, আপনি যেখানে টেমপ্লেটটি সন্নিবেশিত করতে চান যেখানে আপনার কার্সার স্থাপন করুন, এবং টুলবারের "সন্নিবেশ" আইকনের (ধাঁধার টুকরা) উপর ক্লিক করুন।
VisualEditor Template Insert Menu-bn.png

আপনি যে টেমপ্লেট সন্নিবেশ করতে চান তার নাম লিখুন, এবং "টেমপ্লেট যোগ"-এ ক্লিক করুন।
VisualEditor - Template editing 4.png

পাতায় আছে এমন টেমপ্লেট নির্বাচন করে (নীল রঙে দেখাবে), এবং সেখানে প্রদর্শিত "অন্তর্ভুক্তি" আইকনে (ধাঁধার টুকরা), অথবা টুলবারেরটির উপর ক্লিক করে আপনি সম্পাদনা করতে পারেন।
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

টেমপ্লেট প্যারামিটার

When you add a new template or open an existing one, the "অন্তর্ভুক্তকরণ" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

আপনি প্যারামিটার যোগ অথবা ইতিমধ্যে তালিকাভুক্তগুলি সম্পাদনা করতে পারেন।
VisualEditor - Template editing 3.png

একটি টেমপ্লেট অন্য টেমপ্লেট এম্বেড করার সময়, এই উপ-টেমপ্লেট প্যারামিটার হিসেবে প্রদর্শিত হবে। এই উপ-টেমপ্লেটের নামের উপর ক্লিক করে সম্পাদনা করা বা সরিয়ে ফেলা যাবে।

নতুন উপ-টেমপ্লেট একটি প্যারামিটার যোগ করার পদক্ষেপগুলি অনুসরণ করে যোগ করা যাবে। আপনাক উপ-টেমপ্লেট সমর্থিত কিনা তা নিশ্চিত হতে ঐ টেমপ্লেটের নথিপত্র পরীক্ষা করার দরকার হতে পারে।

VisualEditor - Template editing 5.png

সমাপ্ত করা

কাজ সমাপ্ত হয়ে গেলে, ডায়লগ পাতা বন্ধ করতে এবং মূল সম্পাদনায় ফিরতে "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন।
VisualEditor Apply Changes-bn.png

টেমপ্লেট উপকল্পন করা

যখন একটি টেমপ্লেট উপকল্পন করা আবশ্যক, টেমপ্লেটের নাম আগে subst: (কোলন অন্তর্ভুক্ত করা সহ) টাইপ করুন।

স্বয়ং সম্পূর্ণতা subst: এর সাথে কাজ করবে না; যদি আপনার স্বয়ংপূর্ণতা প্রয়োজন হয়, শুধুমাত্র আপনি যেটি খুঁজছেন সেই টেমপ্লেট খুঁজে পাওয়ার পর subst: যোগ করুন।

এর পরে, সবুজ "Add template" বাটনে ক্লিক করুন।

যথারীতি যেকোন প্যারামিটার যোগ করুন এবং "পরিবর্তনসমূহ প্রয়োগ" করুন।

VisualEditor - Template editing 7.png

আপনি এই প্রারম্ভিক সময়ে পাতায় টেমপ্লেটের প্রসারন দেখতে পাবেন না।
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-bn.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

ছক সম্পাদনা করা

VisualEditor insert table.png
You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you click on "Table", in the "যোগ করো" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

বিষয়শ্রেণী সম্পাদনা করা

VisualEditor category item-bn.png
To edit categories, on the "পাতার অপশন" menu, click the "বিষয়শ্রেণীসমূহ" item.

VisualEditor category editing-bn.png

"Options" বাটন একটি ডায়ালগ খোলে যেখানে বিদ্যমান বিষয়শ্রেণীর তালিকা প্রদর্শন করবে এবং আপনাকে নতুন বিষয়শ্রেণীসমূহ যোগ করতে দিবে।

পাতার তালিকায় ব্যবহৃত সাজানো চাবি কনফিগার করার জন্য বিষয়শ্রেণীর পাতায় একটি অপশন আছে।

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
একটি নতুন বিষয়শ্রেণী যোগ করার জন্য, "কোনো বিষয়শ্রেণী যোগ" বক্সে বিষয়শ্রেণীর নাম লিখুন। হয় আপনি একটি নতুন বিষয়শ্রেণী তৈরি, অথবা একটি বিদ্যমান একটি নির্বাচন করতে পারবেন।

VisualEditor - Category editing 2.png

একটি বিদ্যমান বিষয়শ্রেণী মুছে ফেলার জন্য, এটির উপর ক্লিক করুন এবং প্রর্দশিত ডায়লগ বক্সে "অপসারণ" আইকনের (ট্র্যাশ ক্যান) উপর ক্লিক করুন।

এছাড়াও আপনি একটি নির্দিষ্ট বিষয়শ্রেণীর জন্য সাজানো কী নির্দিষ্ট করতে পারেন। এটি সাধারণ সাজানো কী ওভাররাইড করে।


VisualEditor Apply Changes-bn.png
যখন আপনার বিষয়শ্রেণী সম্পাদনা করা সমাপ্ত হবে, তখন মূল সম্পাদনা পাতায় ফিরে যাওয়ার জন্য "পরিবর্তনসমূহ প্রয়োগ"-এ ক্লিক করুন।

পাতার সেটিং সম্পাদনা করা

VisualEditor page settings item-bn.png
To edit a page's settings, click to open the "পাতার অপশন" menu, in the toolbar, and select the "পাতা সেটিং" button.

VisualEditor Page Settings-bn.png
The "পাতা সেটিং" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-bn.png
You can make a page a redirect to another page by checking the "এতে পাতা পুনর্নির্দেশ" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-bn.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "যদি প্রয়োজন হয়", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-bn.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-bn.png
Click "পরিবর্তনসমূহ প্রয়োগ" when you're done editing the পাতার অপশন to return to the page editor.

গাণিতিক সূত্র সম্পাদনা

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "সূত্র" icon ("Σ") in the "যোগ করো" menu on the toolbar.
VisualEditor Formula Insert Menu-bn.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "সম্পন্ন" button.
VisualEditor formula-bn.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, click the "Musical notation" option.

To edit an existing musical notation on the page, double click on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, click the "Done" button to close the dialog and save your changes.
Musical.png

কবিতা এবং অন্যান্য বিশেষ আইটেম সম্পাদনা করা

কিছু আইটেম, যেমন সমিতি তালিকা, কবিতা, এবং বাদ্যযন্ত্রের স্কোর এখনও ভিজ্যুয়ালএডিটর দ্বারা সমর্থিত নয়।

VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

কীবোর্ড শর্টকাট

অনেক সম্পাদক সরাসরি উইকিটেক্সট প্রবেশ করাতে অভ্যস্ত, বিশেষ করে গাঢ়, ইটালিক এবং উইকিলিঙ্ক। কীবোর্ড শর্টকাট সরঞ্জামদণ্ডের বোতামে ক্লিক না করেও অনুরূপ বিন্যাস দ্রুত সন্নিবেশ করার অনুমতি দেয়। এখানে ভিজ্যুয়াল এডিটরের সাধারণ কিছু শর্টকাট দেয়া হল:

পিসি শর্টকাট কাজ ম্যাক শর্টকাট

Ctrl+B গাঢ় Cmd+B

Ctrl+I বাঁকা Cmd+I

Ctrl+K লিঙ্ক সন্নিবেশ Cmd+K

Ctrl+X ছাঁটুন Cmd+X

Ctrl+C অনুলিপি Cmd+C

Ctrl+V প্রতিলেপন Cmd+V

Ctrl+Z পূর্বাবস্থা Cmd+Z