Help:ビジュアルエディター/利用者ガイド

< Help:VisualEditor
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 62% complete.

Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎British English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD 注意: このページを編集すると、編集内容が CC0 のもとで公開されることに同意したと見なされます。詳細はパブリック・ドメインのヘルプ ページを参照してください。
PD
本文記事の編集をすることなく、ビジュアルエディターを試してみたい場合は、こちらのサンドボックスのページで自由にどうぞ。 そのページではアカウントがなくてもビジュアルエディターを使用できます。

ビジュアルエディターを開く

ビジュアルエディターでページを編集するには、ページ上部の「編集」タブをクリックしてください。

編集のための画面を開くのに数秒かかる場合があります。ページサイズが非常に大きい場合はさらに長くかかる場合があります。

「ソースを編集」タブをクリックすると、ウィキテキストのソースを編集する古いエディターが開きます。

VisualEditor edit tab-ja.png

ビジュアルエディターを開くには、各節にある「編集」リンクをクリックするという方法もあります。
VisualEditor - Section edit links-en.png

編集を始める: ビジュアルエディター ツールバー

ビジュアルエディター ツールバーのスクリーンショット
編集を始めると、編集画面上部にビジュアルエディター ツールバーが表示されます。このツールバーにはおなじみのアイコンもいくつか並んでいます:

VisualEditor - Toolbar - Undo-redo.png
編集内容に対して「取り消し」や「やり直し」(元に戻すの取り消し) の操作ができます。

VisualEditor Toolbar Headings-ja.png
見出し」プルダウン メニュー: 段落がどのように整形されるかを変更できます。段落のスタイルを変更するには、カーソルを段落内に置き、このメニュー内のアイテムを選択します(テキストを選択する必要はありません)。セクション見出しは"見出し"となり、サブセクションは"見出し 2", "見出し 3" といったかたちになります。 文章のための通常のフォーマットは「段落」です。

VisualEditor Toolbar Formatting-ja.png

書式: "A" をクリックするとメニューが開きます。

  • 「太字」(B) は選択したテキストを太字化します。
  • 「斜体」(I) は選択したテキストを斜体化します。
  • 「上付き」(x2) は、選択したテキストをまわりのテキストより小さくして若干上寄りに表示させます。
  • The "下付き" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly lower than the surrounding text.
  • 「取り消し線」(S) は選択したテキストに取り消し線を加えます。
  • 「コンピューターのコード」(括弧の組み合わせ: {}) は、選択したテキストのフォントを等幅フォントに変更して、周りのプロポーショナル・フォントによるテキストと区別させます。
  • 「下線」(U) は、選択したテキストに下線を加えます。
  • 「言語」(Aあ) では、選択したテキストについて、言語 (例えば「日本語」) と方向 (例えば、右から左へ) を指定できます。
  • 最後の (VisualEditor MediaWiki theme clear icon bitmap.png)「書式を消去」は、選択したテキストから、リンクを含むすべての書式設定を除去します。

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
リンクツール: 鎖の輪アイコンは、リンクツールです。 これを(通常はどこかのテキストを選択した後で)クリックすると、リンク画面が開きます。

VisualEditor - Cite Pulldown.png
参照 menu: The "参照" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to basic reference formatting and the ability to re-use citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the 参照 menu at a specific wiki are available at VisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
Cite button:

If the citoid service is enabled on your wiki, then you will see a 引用 button instead of a 参照 menu.

参照管理サービスは自動的に参照テンプレートに記入しようとします。


VisualEditor Toolbar Lists and indentation-ja.png
箇条書きとインデント: 最初の2つの選択肢はテキストをそれぞれ "番号なし箇条書き" または "番号付き箇条書き" に設定する方法です。あとの2つで、箇条書きのインデントの階層を増減できます。

VisualEditor Insert Menu-ja.png
挿入:「挿入」のメニューはプロジェクトによって異なる場合があります。下は現れうるすべてのオプションの一覧です。
  • 「メディア」(山の絵) のアイコンで、メディアを挿入するダイアログが開きます。
  • 「テンプレート」(パズルのピース) のアイコンで、テンプレートを編集できます。
  • The "Table" item allows you to insert a table.
  • The "コメント" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.
  • 「象形文字」 (アンク (エジプト十字) - ☥) のアイコンで、ヒエログリフの挿入ができます (後述)。
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • 「ギャラリー」(一組の写真) のアイコンでは、ページにギャラリーを追加できます。
  • 「数式」 (Σ) のアイコンで、数式の挿入画面が開きます。
  • The "Graph" item allows you to insert a table.
  • The "Your signature" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • The "出典一覧" icon (three books) opens a dialog in which you can specify where references will be displayed to the reader. Usually this needs to be done only once on a page.

Special character insertion: The "特殊文字" (Ω) icon is next to the "挿入" menu. When clicked, it displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (この一覧はローカルでカスタマイズできます。説明はVisualEditor/Special charactersを参照してください。)
VisualEditor Toolbar SpecialCharacters-ja.png

VisualEditor toolbar edit notices icon.png
編集警告 のボタンはそのページに何かの警告があることを表示しています。

VisualEditor More Settings-ja.png
The ページ設定 menu is to the left of the ページを保存 button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories; and to see, using the "言語" item, the list of articles on the same subject that are in other languages.

VisualEditor bi-directional switching square brackets icon.png
ソースの編集に切り替える ボタンは ページを保存 ボタンの隣にあります。ウィキエディターに切り替えることができます。編集した内容は失われません。

変更内容の保存

編集が終わったら、ツールバーにある青色の "ページを保存" ボタンをクリックします。変更を加えていなければ、ボタンはクリックできません (グレー表示)。 To cancel all your editing changes, just close your browser window, or click the "Read" tab above the edit toolbar.
VisualEditor toolbar actions-ja.png

Pressing the blue "ページを保存" button opens a dialog. You can then enter a brief summary of your actions, mark your edit as minor, and add the page to your ウォッチリスト. The box for the summary is the equivalent of the 編集内容の要約: field in the wikitext editor.

編集内容を保存する前に「$レビュー」ボタンをクリックして、意図したとおりに表示するかどうか確認できます。いわば wikitext エディタの 差分を表示 ボタンのようなものです。

"編集を再開"ボタンをクリックすると編集中のページに戻ります。変更の内容はすべてそのあとで保存できます。

VisualEditor save dialog-ja.png

リンクの編集

VisualEditor - Toolbar - Linking.png
ツールバーの「リンク」 (鎖マーク) アイコンで、リンクを追加できます。ショートカットのCtrl+K (Mac では Command+K) でもリンクを追加できます。

テキストを選択 (強調表示) して"リンク"ボタンを押すと、リンクがそのテキストに挿入されます。単語の上にカーソルを置いて同じボタンを押すと、単語にリンクが付きます。そのテキストはリンクの生成に使われます。1語しか含まれないリンクについては、その単語を選ぶか、カーソルをその単語の中に入れるかします。


VisualEditor-link tool-search results.png
ボタンまたはショートカットのどちらを使用しても、ダイアログが開くため、そこにリンクをタイプできます。タイプし始めると、ビジュアルエディターは入力内容に一致する可能性がある内部リンク (同じウィキ内の他のページへのリンク) の候補を挙げて、あなたを手助けしようと試みます。

The link tool will try to help with internal links by searching for likely matches.


VisualEditor - Link editing inline box.png
リンクを記入または選択したら、Enter キーを押すか、"完了"ボタンを押せば、リンク付けが完了します。リンクは VisualEditor のページにすぐ表示されますが、ページ全体を保存するまではリンクも保存されません。

VisualEditor-link tool-external link.png
別のサイトのウェブページにリンクするのも、同じ手順です: "外部リンク"タブを選び、ボックスに URL を記入します。

VisualEditor link tool simple link.png
ラベルを付けない外部リンクの表示: [1]. これらを追加するには、カーソルを文章の単語以外の場所 (たとえばスペースのあと) に置きます。 リンクツールを開くには、ボタンを押すか、ショートカットを入力します。 リンクを挿入するには、ボックスに URL を入力してから "完了" ボタンを押します。

VisualEditor-context menu-link tool.png
既存のリンクの変更や除去をするには、文中のリンクをクリックして、ツールバーの "リンク"アイコンを押します。するとダイアログボックスが現われ、編集ができます (キーボードショートカット Ctrl+K でもダイアログボックスが開けます)。 リンクを選択すると、文字列の背景が青くなります。

In the link editing dialog, you can then change where the link goes. You can also remove the link altogether by pressing the "除去" button in the upper right corner of the dialog. You can also open the link's target in another window by clicking on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

リンクラベルを終了するか、このリンクの後に書き込みを続行したい場合は、リンクラベルを押すことができます。

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

出典の編集

詳細については Help using citation templates 又は、Help using citoid's Cite button を参照してください

Determining which system is in place

あなたのwikiには3脚注又はシステムのいずれかを使用することができます。 The one shown on the right is the simplest system, where the "参照" menu does not include any citation templates. もしあなたのウィキがこのシステムを使用しているなら、If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "参照" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Editing an existing reference

To edit an existing reference, click on it where it appears in the text (usually as a bracketed number). You will see either a "脚注" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, clicking on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1.png

For the "脚注" icon, clicking "Edit" opens the Reference dialog. To start changing the reference information, click on it.

Many wikis use templates to format references. If a template is used in your reference, then when you move your pointer over the reference information, all the information in that field will be highlighted .

If a template was used and you click on the reference information, then the テンプレート icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, click on "詳細情報を追加" at the bottom of the mini-editor.
VisualEditor - Editing references 5.png

完了したら、「変更内容を適用」をクリックします。
VisualEditor Apply Changes-ja.png

既存の出典の再使用

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

To re-use an existing reference, place your cursor in the body of the text where you want to add a new reference (number) for that citation. Then click on the "Re-use reference" item from the "参照" menu.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "参照" menu.)

VisualEditor references more.png

In the 脚注 dialog, look at the list for the reference you want to reuse, and select it. If there are many references, you can use the search box (labeled "現在の引用内を検索") to list only those references that include certain text.
VisualEditor - Editing references 18.png

新しい出典の追加

To add a citation using the "参照" menu, place your cursor where you want to add it in the text. Then select the appropriate citation type in the menu.
VisualEditor references more.png

「基本」の引用を使用しました

Shown here is what you will see if you select the basic references item. In the Reference editor, you can add your citation, including formatting.

脚注を既存のグループに属させることもできますが、通常はその方法に手をつけません。 (これは "出典一覧" ツールを使ってグループ化した脚注を表示させるオプションの説明です)

VisualEditor - Editing references 20.png

In the Reference dialog, if you want to include a citation template, or any other template, in your new reference, click the テンプレート icon (puzzle piece) in the "挿入" toolbar menu within the Reference editor.
VisualEditor Template Insert Menu-ja.png

それから、他のテンプレートの操作と同じように、使いたいテンプレートを探して追加してから望む通りに編集します。 (テンプレートの詳しい解説は、以下に 編集テンプレート のセクションがありますので参照してください。)

新しいテンプレートの編集が終わったら、"変更内容を適用" をクリックして引用エディターに戻り、もう一度 "変更内容を適用" をクリックして元の編集していたページに戻ります。

VisualEditor - Editing references 9.png

ページにまだ「出典の一覧」が無い場合(たとえば、そのページで初の出典を追加するときなど)、出典を表示させる場所を追加する必要があります。

脚注の一覧を表示させたい場所 (通常はページ下部) にカーソルを置き、"挿入" メニューを開いてから"出典一覧" アイコン (3 冊の本) をクリックします。

VisualEditor References List Insert Menu-ja.png

If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed on the page at the location where you are placing the group.

脚注一覧ダイアログを終えるには "挿入" をクリックします。

VisualEditor references list-ja.png

標準の引用テンプレートの使用

Your local wiki may have added extra citation templates to the "参照" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "詳細情報を追加" option.

Click on "挿入" when you're done.

VisualEditor - Editing references - Add parameter.png

画像などメディアファイルの編集

画像の編集

新しい画像 (または別の種類のメディア ファイル) を挿入するには、「挿入」メニューの「メディア」アイコン (山の絵) をクリックしてください。カーソルがどこにあっても画像が追加されます。
VisualEditor Media Insert Menu-ja.png

「メディア」アイコンをクリックすると、ダイアログが開いて、あなたが編集中のページのページ名と関連するメディア ファイルをウィキメディア・コモンズやローカル ウィキで自動的に検索します。

ダイアログの検索枠にあるテキストを変更すれば、また別のメディアファイルを探すことができます。

サムネイルをクリックしてファイルを選択してください。

こうするとあなたが編集中のページに画像が配置されます。

VisualEditor - Media editing 2.png

選んだ画像がページに追加されると、続いて新しいダイアログが開きます。このメディア ダイアログで、画像のキャプションの追加および編集ができます。キャプションでは書式設定やリンクもできます。
VisualEditor - Media editing 6.png

メディアダイアログでは、スクリーンリーダーを用いているユーザや画像表示をオフにしているユーザの助けになる代替テキストの追加もできます。
Media editing 7.png

"高度な設定"のウィンドウから様々なパラメータを設定できます。パラメータには画像の配置位置、タイプ、大きさなどがあります。
VisualEditor - Media editing 8.png

キャプションを編集したら「変更内容を適用」をクリックします。すると、ダイアログが閉じられ、通常の編集画面に戻ります。
VisualEditor Apply Changes-ja.png

すでに配置済みの画像に対しては、画像をクリックしてキャプションを追加または編集したり、設定を変更したりして、それから「メディア」をクリックします。

既存の画像をクリックしてサイズ変更アイコン(画像の隅に表示される両端がとがった矢印)を動かすことで画像のサイズを変更できます。

画像をドラッグ&ドロップすることにより、画像を上または下に移動することができます。

VisualEditor - Media editing 3.png

画像のアップロード

メディアダイアログのタブから画像をアップロードすることができます。

「アップロード」タブをクリックしてあなたのPCから画像を選択します。ファイル名をタイプするのでも、画像を枠内にドラッグするのでもかまいません。
VisualEditor - Media upload 1.PNG

画像に説明とカテゴリを加えて、ほかの人がその画像を見つけられるようにしてください。
VisualEditor - Media upload 2.PNG

完了すると画像はページに挿入されます。
VisualEditor-logo.svg

メディアギャラリーの編集

To add a new gallery, click the "ギャラリー" icon (a set of photos) on the "挿入" menu. (If you don't see this icon on that menu, then your local wiki has decided to delay implementing this functionality in the visual editor.)
VisualEditor - Gallery1.png

To edit an existing gallery in the visual editor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "完了" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

テンプレートの編集

開始

ページにテンプレートを新たに追加したい場合、テンプレートを挿入したい箇所にカーソルを置き、「挿入」メニューにある「テンプレート」アイコン (パズルのピース) をクリックします。
VisualEditor Template Insert Menu-ja.png

まず挿入したいテンプレートの名前を記入します。一覧にそれが表示されたら、名前をクリック、次に「テンプレートを追加」をクリックします。
VisualEditor - Template editing 4.png

You can also edit a template that is already on the page. When you click on the template to select it, it turns blue, and a box appears with an "テンプレート" icon (puzzle piece). Then click on the "編集" link.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

テンプレートのパラメーター

When you add a new template or open an existing one, the "参照読み込み" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

既存のテンプレートの場合、ダイアログに既にある引数を編集することも、ボックスのいちばん下にある「詳細情報を追加」をクリックして追加することもできます。
VisualEditor - Template editing 3.png

テンプレートにほかのテンプレートが埋め込まれている場合、下位テンプレートは引数として表示されます。それらは、下位テンプレートの名前をクリックすることで編集したり除去したりできます。

下位テンプレートを新たに追加するには、引数追加の手順を踏みます。下位テンプレートが使用可能かどうかは、テンプレートの説明で確認した方がいいでしょう。

VisualEditor - Template editing 5.png

Finishing

When you have finished editing a template, click "変更内容を適用" to close the dialog and return to editing the main page.
VisualEditor Apply Changes-ja.png

テンプレートをsubst展開する

テンプレートをsubst展開する (テンプレートの内容で置き換える) 必要がある場合、テンプレート名の前に subst: と (コロンも含めて) 書いてください。

Autocompletion doesn't work with subst:. If you want to use autocompletion, first find the template you are looking for, and then add subst: in front of the template name.

Then, click the blue "テンプレートを追加" button.

通常通り、必要に応じて引数を追加して、「挿入」をクリックします。

VisualEditor - Template editing 7.png

You will see the template expand on the page after you click "変更内容を適用".
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-ja.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

表の編集

VisualEditor insert table.png
ビジュアルエディターで、表を挿入したり編集したりできます。

利用者のコンピューターからカンマ区切りのテキストデータ (.csv) を、メインの編集ウィンドウにインポートすることまでできます。


When you click on "Table", in the "挿入" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
行と列を追加もしくは除去できます。

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

カテゴリの編集

VisualEditor category item-ja.png
カテゴリを編集するには、「ページ設定」メニューから「カテゴリ」ボタンをクリック。

VisualEditor category editing-ja.png
「カテゴリ」ボタンをクリックするとダイアログが開きます。カテゴリ一覧が表示され、新しいカテゴリを追加したり既存のものを削除したりできます。

カテゴリページでそのページを表示させる際のソートキーを変更するオプションがあります。一般的な (規定の) 検索キーはオプションで設定したり変更したりでき、同じカテゴリの別の記事と並べたときに画面のどこに表示するかを決定します。

たとえば「テイラー・スウィフト」の記事を検索するには基本的に「スウィフト、テイラー」の語順で実行します。「グラミー賞受賞者」のカテゴリでは、「テ」ではなく「ス」の項目に分類されるのです。


VisualEditor - Category editing 3.png
ページに新しいカテゴリを追加するには、"追加するカテゴリ" フィールドに新カテゴリの名前を記入します。すると同時に VisualEditor が既存のカテゴリから候補を検索し始めます。既存のカテゴリを選択できるし、 まだカテゴリページを割り振っていない新しいカテゴリの追加もできます。 ( 編集結果をすべて保存すると、赤リンクとして表示されます。その新しいカテゴリページが作られるまで赤リンクのままです。)

VisualEditor - Category editing 2.png
既存のカテゴリを除去するには、そのカテゴリをクリックして、開いたダイアログにある「除去」アイコン(ごみ箱)をクリックします。

特定のカテゴリをクリックしても、それにソートキーを設定できます。こうすると既定のソートキーを上書きします。


VisualEditor Apply Changes-ja.png
カテゴリの編集が完了したら「変更内容を適用」をクリックして通常の編集画面に戻ります。

ページ設定の編集

VisualEditor page settings item-ja.png
To edit a page's settings, click to open the "ページ設定" menu, in the toolbar, and select the "ページの設定" button.

VisualEditor Page Settings-ja.png
The "ページの設定" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-ja.png
You can make a page a redirect to another page by checking the "このページを以下のページにリダイレクト" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-ja.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "必要であれば表示", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-ja.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-ja.png
Click "変更内容を適用" when you're done editing the ページ設定 to return to the page editor.

数式の編集

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "数式" icon ("Σ") in the "挿入" menu on the toolbar.
VisualEditor Formula Insert Menu-ja.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "完了" button.
VisualEditor formula-ja.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

詩その他の特殊な項目の編集

ビジュアルエディターでは連想リスト、詩や楽譜など特殊なアイテムの編集はまだ部分的にしかサポートしていません。
VisualEditor editing poem 1.png

多くの場合、既存の項目は編集できるものの、新しい項目はビジュアルエディターに追加できません。
VisualEditor editing poem 2.png

You can not add an automatic signature or datestamp to a page in the visual editor.

ビジュアルエディターのサポート態勢が完全に整うまでは、直接、wikitext ソースを編集したり、ほかの記事からコピーしたりしましょう。

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

キーボード ショートカット

多くの編集者はウィキテキストを直接記入するのに慣れています。とりわけ、太字、斜体、ウィキリンクなど。 キーボードショートカットを使えば、ツールバーをクリックしなくても、同様な書式追加を迅速に行うことができます。ビジュアルエディターでも機能するショートカットがあります。

PC ショートカット 操作 Mac ショートカット

Ctrl+B 太字 Cmd+B

Ctrl+I 斜体 Cmd+I

Ctrl+K リンクを挿入 Cmd+K

Ctrl+X 切り取り Cmd+X

Ctrl+C コピー Cmd+C

Ctrl+V 貼り付け Cmd+V

Ctrl+Z 元に戻す Cmd+Z