ಸಹಾಯ:ದೃಶ್ಯ ಸಂಪಾದಕ/ಸಹಾಯ ಕೈಪಿಡಿ

< Help:VisualEditor
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 5% complete.

Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎British English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Note: When you edit this page, you agree to release your contribution under the CC0. See Public Domain Help Pages for more info.
PD
If you would like to try the visual editor without editing an article, here is a page where you can freely test it. You don't need an account to use the visual editor on that page.

ದೃಶ್ಯ ಸಂಪಾದಕವನ್ನು ತೆರೆಯಲಾಗುತ್ತಿದೆ

To edit a page using the visual editor, click on the "ಸಂಪಾದಿಸಿ" tab at the top of the page.

ಪುಟವನ್ನು ಸಂಪಾದನೆಗೆ ತೆರೆಯಲು ಸ್ವಲ್ಪ ಸಮಯ ಹಿಡಿಯಬಹುದು. ಅದರಲ್ಲೂ ಪುಟ ದೊಡ್ಡದಾಗಿದ್ದಷ್ಟೂ ಹೆಚ್ಚು ಸಮಯ ಹಿಡಿಯಬಹುದು

Clicking on the "ಮೂಲವನ್ನು ಸಂಪಾದಿಸು" tab will open the classic wikitext source editor.

VisualEditor edit tab-kn.png

You can also open the visual editor by clicking on the "ಸಂಪಾದಿಸಿ" link on each section.
VisualEditor - Section edit links-en.png

Getting started: the visual editor's toolbar

Screenshot of the the visual editor's toolbar
ದೃಶ್ಯ ಸಂಪಾದಕದ ಮೂಲಕ ಸಂಪಾದಿಸುವಾಗ ಅದರ ಸಾಧನಪಟ್ಟಿಯು ಪರದೆಯ ಮೇಲ್ಭಾಗದಲ್ಲಿ ಕಂಡುಬರುತ್ತದೆ. ಅದು ಕೆಲವು ಪರಿಚಿತ ಸಂಕೇತಗಳನ್ನು ಒಳಗೊಂಡಿರುತ್ತದೆ.

VisualEditor - Toolbar - Undo-redo.png
ಹಿಂದಿನಂತೆ and ಮತ್ತೆಮಾಡು the changes you have made.

VisualEditor Toolbar Headings-kn.png
Headings pull-down menu: allows you to change how the paragraph is formatted. To change the style of a paragraph, put your cursor in the paragraph and select an item in this menu (you don't have to highlight any text). Section titles are formatted "ತಲೆಬರಹ", and subsections are "ಶಿರೋನಾಮೆ ೨", "ಶಿರೋನಾಮೆ ೩", and so on. ಪಠ್ಯಕ್ಕೆ ಸಾಮಾನ್ಯ ವಿನ್ಯಾಸವು"ವಾಕ್ಯವೃಂದ".

VisualEditor Toolbar Formatting-kn.png

Formatting: Clicking the "A" opens a menu.

  • ದಪ್ಪ ಅಂಶವು ಪಠ್ಯವನ್ನು ದಪ್ಪ ಅಕ್ಷರಗಳಲ್ಲಿ ಕಾಣುವಂತೆ ಮಾಡುತ್ತದೆ.
  • ಓರೆಯಾದ ಅಂಶವು ಪಠ್ಯವನ್ನು ಓರೆ ಆಕ್ಷರಗಳಲ್ಲಿ ಕಾಣುವಂತೆ ಮಾಡುತ್ತದೆ.
  • ಮೇಲ್ಬರಹ ಅಂಶವು ಆಯ್ಕೆಮಾಡಿದ ಪಠ್ಯವನ್ನು ಸುತ್ತಲಿನ ಪಠ್ಯಕ್ಕಿಂತ ಸಣ್ಣದಾಗಿ ಹಾಗೂ ಸ್ವಲ್ಪ ಎತ್ತರದಲ್ಲಿ ಕಾಣುವಂತೆ ಮಾಡುತ್ತದೆ.
  • ಕೆಳಬರಹ ಅಂಶವು ಆಯ್ಕೆ ಮಾಡಿದ ಪಠ್ಯವನ್ನು ಸುತ್ತಲಿನ ಪಠ್ಯಕ್ಕಿಂತ ಸಣ್ಣದಾಗಿ ಮತ್ತು ಸ್ವಲ್ಪ ಕೆಳಗೆ ಕಾಣುವಂತೆ ಮಾಡುತ್ತದೆ.
  • ರದ್ದು ಮಾಡು ಅಂಶವು ಆಯ್ಕೆ ಮಾಡಿದ ಪಠ್ಯದ ಮೇಲೆ ಎರಡು ಗೆರೆಗಳು ಕಾಣುವಂತೆ ಮಾಡುತ್ತದೆ.
  • The "ಗಣಕಯಂತ್ರದ ಸಂಕೇತ" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • ಅಡಿಗೆರೆ ಅಂಶವು ಆಯ್ಕೆ ಮಾಡಿದ ಪಠ್ಯದ ಕೆಳಗೆ ಎರಡು ಗೆರೆಗಳು ಕಾಣುವಂತೆ ಮಾಡುತ್ತದೆ.
  • The "ಭಾಷೆ" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "ವಿನ್ಯಾಸವನ್ನು ತೆಗೆಯಿರಿ", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

VisualEditor - Cite Pulldown.png
ಉಲ್ಲೇಖಿಸಿ menu: The "ಉಲ್ಲೇಖಿಸಿ" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to "ಮೂಲಭೂತ" reference formatting and the ability to "ಮತ್ತೆ ಬಳಸು" citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the ಉಲ್ಲೇಖಿಸಿ menu at a specific wiki are available at VisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
ಉಲ್ಲೇಖಿಸಿ button: If the citoid service is enabled on your wiki, then you will see a "ಉಲ್ಲೇಖಿಸಿ" button instead of a ಉಲ್ಲೇಖಿಸಿ menu.

The citoid service tries to fill out citation templates automatically.


VisualEditor Toolbar Lists and indentation-kn.png
Lists and indentation: The first two items allow you to format text as either a "ಬಿಂದು ಪಟ್ಟಿ" or a "ಸಂಖ್ಯೆಯ ಪಟ್ಟಿ". The last two items allow you to decrease or increase the indentation level of list items.

VisualEditor Insert Menu-kn.png
ಸೇರಿಸು: The "ಸೇರಿಸು" menu may be different on some projects. Below is a list of all options that may appear.
  • "ಮಾಧ್ಯಮಗಳು" ಐಕಾನ್ (ಪರ್ವತಗಳ ಚಿತ್ರಗಳು) ಮಾಧ್ಯಮ ಸಂವಾದವನ್ನು ತೆರೆಯುತ್ತದೆ.
  • The "ಸಿದ್ಧವಿನ್ಯಾಸ" icon (a puzzle piece) allows you to edit templates.
  • The "ಟಿಪ್ಪಣಿ" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode and are then indicated by an exclamation mark icon.
  • The table item allows you to insert a table.
  • The "Gallery" icon (a set of photos) allows you to insert a gallery to the page.
  • The "Formula" icon (Σ) opens the formula inserter dialog.
  • The "Hieroglyphs" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "ಉಲ್ಲೇಖಗಳ ಪಟ್ಟಿ" icon (three books) opens a dialog in which you can specify where will references be displayed to the reader. Usually this only needs to be done once on every page.

Special character insertion: The "ವಿಶೇಷ ಅಕ್ಷರ" (Ω) icon on the "ಸೇರಿಸು" menu, when clicked, displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (This list may be customized locally. See VisualEditor/Special characters for instructions.)
VisualEditor Toolbar SpecialCharacters-kn.png

VisualEditor toolbar edit notices icon.png
The Edit notices button displays any notices for the page.

VisualEditor More Settings-kn.png
The ಪುಟದ ಆಯ್ಕೆಗಳು menu is to the left of the ಪುಟವನ್ನು ಉಳಿಸಿ button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories; and to see, using the "ಭಾಷೆ" item, the list of articles on the same subject that are in other languages. You can also switch (one-way only) from the visual editor to the classic wikitext source editor without losing the editing work you've done.

VisualEditor bi-directional switching square brackets icon.png
The ಮೂಲದಲಿ ಸಂಪಾದಿಸಲು ಹೊಗಿ button is next to the ಪುಟವನ್ನು ಉಳಿಸಿ button. It allows you to switch to the wikitext editor.

Saving changes

When you're done editing, click the blue "ಪುಟವನ್ನು ಉಳಿಸಿ" button in the toolbar. If you have made no changes, the button will be disabled (grayed out). To cancel all your editing changes, just close your browser window.
VisualEditor toolbar actions-kn.png

Pressing the green "ಪುಟವನ್ನು ಉಳಿಸಿ" button opens a dialog. You can then enter a brief summary of your actions, mark your edit as minor, and add the page to your ವೀಕ್ಷಣಾಪಟ್ಟಿ. The box for the summary is the equivalent of the ಸಾರಾಂಶ: field in the wikitext editor.

You can also review your changes using the "ನಿಮ್ಮ ಬದಲಾವಣೆಗಳನ್ನು ಪರಿಶೀಲಿಸಿ" button to be sure they will work as intended before saving your changes. This is similar to the "ಬದಲಾವಣೆಗಳನ್ನು ತೋರಿಸು" button in the wikitext editor.

The "ಸಂಪಾದನೆ ಮುಂದುವರಿಸಿ" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-kn.png

Editing links

VisualEditor - Toolbar - Linking.png
Links can be added through the "ಸಂಪರ್ಕ" icon (links in a chain) in the toolbar, or by using the shortcut Ctrl+K (or Command+K on a Mac).

If you select (highlight) text and then press the "ಸಂಪರ್ಕ" button, that text will be used in creating the link. For a link that involves just one word, you can either select that word or just put the cursor within that word.


VisualEditor-link tool-search results.png
When you use either the button or the shortcut, a dialog will open in which you may type the link.

VisualEditor will try to help with internal links by looking for likely matches.


VisualEditor link tool 2015.png
Once you have entered or selected the link, you complete the linking process by pressing Enter or by pressing the "ಮುಗಿಯಿತು" button. Your link will immediately appear on the page, but as with other changes to the page, it will not be saved until you save the entire page.

VisualEditor-link tool-external link.png
To link to a web page on another website, the process is similar: Choose the "ಬಾಹ್ಯ ಸಂಪರ್ಕ" tab, and enter a URL in the box.

VisualEditor link tool simple link.png
External links without labels look like this: [೧]. You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by clicking on the button or pressing the shortcut keys. Type the URL in the box, and click the "ಮುಗಿಯಿತು" button to insert the link.

VisualEditor-context menu-link tool.png
To change or remove an existing link, click within the text for that link, then press the "ಸಂಪರ್ಕ" icon that appears near it. The dialog will appear, for editing. (You can also get to the dialog with the Ctrl+K keyboard shortcut.) When a link is selected, it appears as blue framed.

In the link editing dialog, you can then change where the link goes. You can also remove the link altogether by pressing the "ತೆಗೆ" button in the lower left corner of the dialog. You can also open the link's target in another window by clicking on the link in the context menu. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • press it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • press it twice will put the cursor after the element linked, ready to type the rest of your text

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

Editing references

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "ಉಲ್ಲೇಖಿಸಿ" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "ಉಲ್ಲೇಖಿಸಿ" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates.
VisualEditor references more.png

VisualEditor citoid Cite button.png

In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full.
VisualEditor Citoid Automatic tab.png

Editing an existing reference

To edit an existing reference, click on it where it appears in the text (usually as a bracketed number). You will see either a "ಮೂಲಭೂತ" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, clicking on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1.png

For the "ಮೂಲಭೂತ" icon, clicking "Edit" opens the Reference dialog. To start changing the reference information, click on it.

Many wikis use templates to format references. If a template is used in your reference, then when you move your pointer over the reference information, all the information in that field will be highlighted .

If a template was used and you click on the reference information, then the ಸಿದ್ಧವಿನ್ಯಾಸ icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, click on "ಹೆಚ್ಚಿನ ಮಾಹಿತಿ ಸೇರಿಸಿ" at the bottom of the mini-editor.
VisualEditor - Editing references 5.png

Click on "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" when you're done.
VisualEditor Apply Changes-kn.png

Re-using an existing reference

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

To re-use an existing reference, place your cursor in the body of the text where you want to add a new reference (number) for that citation. Then click on the "ಮತ್ತೆ ಬಳಸು" item from the "ಉಲ್ಲೇಖಿಸಿ" menu.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "ಉಲ್ಲೇಖಿಸಿ" menu.)

VisualEditor Cite menu re-use.png

In the ಉಲ್ಲೇಖ dialog, look at the list for the reference you want to reuse, and select it. If there are many references, you can use the search box (labeled "Search within current citations") to list only those references that include certain text.
VisualEditor - Editing references 18.png

Adding a new reference

To add a citation using the "ಉಲ್ಲೇಖಿಸಿ" menu, place your cursor where you want to add it in the text. Then select the appropriate citation type in the menu.
VisualEditor references more.png

Using the "Basic" citation

Shown here is what you will see if you select the "ಮೂಲಭೂತ" item.

In the Reference editor, you can add your citation, including formatting.

You can make the reference belong to a given group, although normally this is left blank. (This option is used to display groups of references with the "ಉಲ್ಲೇಖಗಳ ಪಟ್ಟಿ" tool.)

VisualEditor - Editing references 20.png

In the Reference dialog, if you want to include a citation template, or any other template, in your new reference, click the ಸಿದ್ಧವಿನ್ಯಾಸ icon (puzzle piece) in the "ಸೇರಿಸು" toolbar menu within the Reference editor.
VisualEditor Template Insert Menu-kn.png

Then, look for the template you want to use, add it and edit it as you would any other template. (See the Editing templates section, below, if you need more information about templates.)

After you're done editing your new template, click on "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" to return to the Reference editor, and "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" again to return to the page you're editing.

VisualEditor - Editing references 9.png

If there isn't already a list of references on the page (for example, if you're adding the first reference for the page), you need to specify where the list of references, and their text, will be displayed to the reader.

Place the cursor where you want to display the references list (usually at the bottom of the page), open the "ಸೇರಿಸು" menu and click the "ಉಲ್ಲೇಖಗಳ ಪಟ್ಟಿ" icon (three books).

VisualEditor References List Insert Menu-kn.png

If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed on the page at the location where you are placing the group.

The final step in the References list dialog is to click "ಸೇರಿಸು".

VisualEditor references list-kn.png

Using standard cite templates

Your local wiki may have added extra citation templates to the "ಉಲ್ಲೇಖಿಸಿ" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "ಹೆಚ್ಚಿನ ಮಾಹಿತಿ ಸೇರಿಸಿ" option.

Click on "ಸೇರಿಸು" when you're done.

VisualEditor - Editing references - Add parameter.png

Editing images and other media files

Editing images

To add a new image (or another type of media file) to the page, click the "ಮಾಧ್ಯಮಗಳು" icon (a picture of mountains) in the "ಸೇರಿಸು" menu. The image will be added wherever your cursor is.
VisualEditor Media Insert Menu-kn.png

Clicking the "ಮಾಧ್ಯಮಗಳು" icon opens a dialog that automatically searches Wikimedia Commons and your local wiki for media files related to the title of the page you're editing.

You can change the search by changing the text in the dialog's search box.

To choose a file, click on its thumbnail image.

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

After the image you selected is inserted into the page, another dialog will open. This dialog allows you to add and edit the caption of the image. The caption can contain formatting and links.
VisualEditor - Media editing 6.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
Media editing 7.png

You can also set various parameters for the image in the "ಸುಧಾರಿತ ಸಂಯೋಜನೆಗಳು" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

When you're done, click "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" to close the dialog and return to editing the page.
VisualEditor Apply Changes-kn.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "ಮಾಧ್ಯಮಗಳು" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog.
VisualEditor Media Insert Menu-en.png

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Editing media galleries


To edit an existing gallery in the visual editor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "ಮುಗಿಯಿತು" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

Editing templates

Starting

To add a new template to a page, place your cursor where you want the template to be inserted, and click on the "ಸಿದ್ಧವಿನ್ಯಾಸ" icon (puzzle piece) in the "ಸೇರಿಸು" menu.
VisualEditor Template Insert Menu-kn.png

Start typing the name of the template you want to insert. When you see it on the list, click on its name. Then click "ಟೆಂಪ್ಲೆಟ್ ಸೇರಿಸಿ". frameless|border|500px|center

You can also edit a template that is already on the page. When you click on the template to select it, it turns blue, and a box appears with an "ಸಿದ್ಧವಿನ್ಯಾಸ" icon (puzzle piece). Then click on the "ಸಂಪಾದಿಸಿ" link.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the visual editor opens the "ಸೇರ್ಪಡೆ" dialog. What you see depends upon whether the visual editor knows extra information about that template, called TemplateDataExtension:TemplateData.

The template shown here has no TemplateData set up for it. The dialog shows a link to documentation for the template. You can read the documentation to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

For an existing template, you can edit the parameters shown in the dialog, and you can add parameters by clicking "ಹೆಚ್ಚಿನ ಮಾಹಿತಿ ಸೇರಿಸಿ", at the very bottom of the dialog. frameless|border|center|400px

When a template embeds other templates, these sub-templates will appear inside the parameters that display them. They can be edited or removed inside the parameter field.

New sub-templates are added by following the steps for adding a parameter. You may need to check the template documentation to make sure that the sub-template is supported.

frameless|border|center|400px

Finishing

When you have finished editing a template, click "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" to close the dialog and return to editing the main page.
VisualEditor Apply Changes-kn.png

Substituting templates

When a template must be substituted, type subst: (colon included) before the template's name.

Autocompletion doesn't work with subst:. If you want to use autocompletion, first find the template you are looking for, and then add subst: in front of the template name.

Then, click the green "ಟೆಂಪ್ಲೆಟ್ ಸೇರಿಸಿ" button.

Add any parameters as usual and click "ಸೇರಿಸು".

frameless|border|center|400px

You will see the template expand on the page after you click "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು".
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-kn.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editing tables

VisualEditor insert table.png
You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you click on "Table", in the "ಸೇರಿಸು" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png
|-

VisualEditor table editing add and remove columns.png
You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Editing categories

VisualEditor category item-kn.png
To edit categories, on the "ಪುಟದ ಆಯ್ಕೆಗಳು" menu, click the "ವರ್ಗಗಳು" item.

VisualEditor category editing-kn.png
Clicking on "ವರ್ಗಗಳು" opens a dialog that lists existing categories and allows you to add new ones, and to delete existing categories.

You also have the option of setting or changing the general (default) sorting key, which determines where the page appears when listed with other pages in the same category.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
To add a category for a page, type the name of the category into the field "ವರ್ಗ ಸೇರಿಸಿ". As you type, the visual editor will search for possible matching, existing categories. You can either select an existing category, or you can add a category that doesn't yet have its own category page. (Until that category page is created, your new category will show as a red link after you save all your editing changes.)

VisualEditor - Category editing 2.png
To remove an existing category, click on it and click on the "ತೆಗೆ" icon (trash can) in the dialog that opens.

Clicking on a category also allows you to specify a sorting key for that specific category. Such a sorting key overrides the default sorting key.


VisualEditor Apply Changes-kn.png
Click "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" when you're done editing categories to return to the page editor.

Editing page settings

VisualEditor page settings item-kn.png
To edit a page's settings, click to open the "ಪುಟದ ಆಯ್ಕೆಗಳು" menu, in the toolbar, and select the "ಪುಟದ ಸಂಯೋಜನೆಗಳು" button.

VisualEditor Page Settings-kn.png
The "ಪುಟದ ಸಂಯೋಜನೆಗಳು" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-kn.png
You can make a page a redirect to another page by checking the "ಈ ಪುಟವನ್ನು ಇದರೆಡೆ ಕಳಿಸು" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-kn.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "ಅಗತ್ಯವಿದ್ದರೆ", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-kn.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-kn.png
Click "ಬದಲಾವಣೆಗಳನ್ನು ಅಳವಡಿಸು" when you're done editing the ಪುಟದ ಆಯ್ಕೆಗಳು to return to the page editor.

Editing mathematical formulae

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "Formula" icon ("Σ") in the "ಸೇರಿಸು" menu on the toolbar.
VisualEditor Formula Insert Menu-kn.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "ಮುಗಿಯಿತು" button.
VisualEditor formula-kn.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing poems and other special items

Some items, such as association lists, poems, and musical scores, are not yet fully supported by the visual editor.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.
VisualEditor editing poem 2.png

You can not add an automatic datestamp to a page in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Keyboard shortcuts

Many editors are used to entering wikitext directly, especially bold, italics and wikilinks. Keyboard shortcuts allow to quickly insert similar formatting without having to use toolbar items. Here are the common general shortcuts in the visual editor:

PC shortcut Action Mac shortcut

Ctrl+B Bold Cmd+B

Ctrl+I Italics Cmd+I

Ctrl+K Insert link Cmd+K

Ctrl+X Cut Cmd+X

Ctrl+C Copy Cmd+C

Ctrl+V Paste Cmd+V

Ctrl+Z Undo Cmd+Z