Help:Visuele tekstverwerker/Gebruikershandleiding

This page is a translated version of the page Help:VisualEditor/User guide and the translation is 100% complete.
PD Let op: Als u deze pagina bewerkt, gaat u akkoord met het vrijgeven van uw bijdragen onder de CC0. Zie Helppagina’s Publiek Domein voor meer informatie.
PD


De visuele tekstverwerker openen

Om een pagina met de visuele tekstverwerker te bewerken klikt u op "Bewerken" bovenaan de pagina.

Het openen van de pagina om deze te bewerken kan enkele seconden duren, of langer als de pagina erg lang is.

Klikken op het tabblad "Brontekst bewerken" opent de klassieke wikitekst-verwerker.

VisualEditor edit tab-nl.png

U kunt de visuele tekstverwerker ook openen door naast een paragraafkop op "bewerken" te klikken.
VisualEditor - Section edit links-en.png

Aan de slag: de werkbalk van de visuele tekstverwerker

Schermafbeelding van de werkbalk van de visuele tekstverwerker
De werkbalk van de visuele tekstverwerker verschijnt bovenaan uw scherm zodra u met deze tekstverwerker aan de slag gaat. De werkbalk bevat enkele bekende pictogrammen:

VisualEditor - Toolbar - Undo-redo.png
Ongedaan maken en Opnieuw uitvoeren van de wijzigingen die u hebt aangebracht.

VisualEditor Toolbar Headings-nl.png
De keuzelijst Koppen: Maakt het mogelijk het kopniveau te wijzigen. De standaardsectiekop is "Kopje". Subsectiekoppen zijn "Onderkop 1", "Onderkop 2", enzovoort. Het normale tekstformaat is "Alinea".

VisualEditor Toolbar Formatting-nl.png

Opmaak: Door op "A" te klikken opent u een menu.

  • "Vet" (V) maakt de geselecteerde tekst vetgedrukt.
  • "Cursief" (C) maakt de geselecteerde tekst cursief.
  • "Superscript" (x2) maakt de geselecteerde tekst kleiner en plaatst deze iets hoger dan de rest van de tekst.
  • "Subscript" (x2) maakt de geselecteerde tekst kleiner en plaatst deze iets lager dan de rest van de tekst.
  • "Doorhalen" (S) plaatst een volle lijn door de geselecteerde tekst.
  • "Computercode" (twee accolades: {}) verandert het lettertype van de geselecteerde tekst in monospace. Dit onderscheidt het van de rest van de tekst.
  • "Onderstrepen" (U) onderstreept de geselecteerde tekst.
  • "Taal" (文A) wordt gebruikt om de taal (bijvoorbeeld Japans) en de schrijfrichting (bijvoorbeeld rechts naar links) van de geselecteerde tekst te labelen.
  • Verwijderen (VisualEditor MediaWiki theme clear icon bitmap.png) verwijdert alle opmaak in de geselecteerde tekst, inclusief links.

Wanneer u geen tekst geselecteerd heeft en u op de knop "A" klikt om het menu te openen en een item selecteert, zal die opmaak worden toegepast wanneer u begint met typen.


VisualEditor - Toolbar - Linking.png
Linkhulpmiddel: de 'kettingschakel' is het linkhulpmiddel. Als u hierop klikt (meestal nadat u een tekst geselecteerd heeft) wordt een dialoogvenster geopend.

VisualEditor - Cite Pulldown.png
Referentie menu: Het menu "Referentie" wordt gebruikt om voetnoten en referenties in de lopende tekst in te voegen. Op elk project bestaat de mogelijkheid om via dit menu een "$basic" aan referenties toe te voegen en om citaten te hergebruiken. Het menu bevat ook snelkoppelingen naar lokale referentiesjablonen, als deze geactiveerd zijn op uw wiki.

(Instructies voor het toevoegen van lokale referentiesjablonen aan het menu Referentie zijn te vinden op VisualEditor/Citation tool .)


VisualEditor citoid Cite button-nl.png
Referentie knop: Als de Citoid service is ingeschakeld op uw wiki, dan ziet u een Referentie knop, in plaats van een Referentie menu. (Om te zien of het is ingeschakeld, ga naar de pagina "Special:Version" op je wiki en de pagina waar citoid is ingeschakeld.)

De Citoid service zal proberen om referentiesjablonen automatisch in te vullen.


VisualEditor Toolbar Lists and indentation-nl.png
Lijsten en inspringen: De eerste twee pictogrammen maken het mogelijk respectievelijk een "Ongenummerde lijst" of "Genummerde lijst" te maken. De laatste twee dienen om de inspringing te verkleinen of vergroten.

VisualEditor Insert Menu-nl.png
Invoegen: dit menu kan verschillen tussen de projecten. Hieronder staat een lijst van alle mogelijke opties die er kunnen verschijnen.
  • "Afbeeldingen en media" (een afbeelding van een berglandschap) opent het media-dialoogvenster.
  • "Sjabloon" (een puzzelstuk) wordt gebruikt om sjablonen te bewerken
  • Met "Tabel" kunt u een tabel invoegen.
  • "Opmerking" (een tekstballon) wordt gebruikt om onzichtbare commentaren op de pagina in te voegen; deze zijn enkel zichtbaar in de bewerkingsmodus, waar ze worden aangegeven met een uitroepteken. In de bewerkingsmodus kan men op het uitroepteken klikken om de opmerking aan te passen of te verwijderen.
  • "Hiërogliefen" (een ankh - ☥) opent de hiërogliefenbewerker (zie onder).
  • Met "Codeblok" kunt u code invoegen.
  • "Muzieknotatie" stelt u in staat om bladmuziek toe te voegen.
  • "Galerij" (een reeks foto's) creëert een galerij van foto's op de pagina.
  • "Wiskundige formule" (Σ) opent het dialoogvenster voor wiskundige formules.
  • Met "Grafiek" kunt u een grafiek invoegen.
  • Met "Uw handtekening" kunt u uw bijdragen ondertekenen. Deze knop wordt grijs gemaakt wanneer u een pagina bewerkt waar handtekeningen niet zouden moeten worden toegevoegd, bijvoorbeeld een artikel.
  • "Referentielijst" (drie boeken) opent een dialoogvenster waarin u kunt aangeven op welke plaats de bronvermelding komt te staan. Dit hoeft meestal maar een keer per pagina te worden gedaan.

Invoegen van speciale tekens: de knop "Speciaal teken" in het menu "Invoegen" opent een dialoogvenster met verschillende speciale tekens. Door op een van de tekens te klikken wordt dat teken in de tekst ingevoegd. Deze lijst bevat standaardsymbolen, accenten en wiskundige symbolen. (Deze lijst kan lokaal worden aangepast. Zie VisualEditor/Special characters voor meer informatie.)
VisualEditor Toolbar SpecialCharacters-nl.png

VisualEditor toolbar edit notices icon.png
De "Meldingen"-knop toont eventuele meldingen voor de pagina.

VisualEditor More Settings-nl.png
Het Pagina-instellingen menu is links van de Wijzigingen publiceren knop en het Van tekstverwerker omschakelen menu. Op dit menu is een knop om een Opties dialoog te openen met de volgende (linkerzijde) tabbladen:
  • Categorieën laat u toe categorieën toe te voegen aan deze pagina en de sorteervolgorde van de pagina aan te passen, als ze wordt weergegeven in een categorie, door een andere sorteerindex te kiezen.
  • Pagina-instellingen staat je toe van de pagina een verwijzing te maken en de opties van deze verwijzing aan te passen; om de weergave-instellingen van een inhoudstabel aan te passen; om het bewerken van links naast iedere hoofding te verhinderen en om de pagina te definiëren als een Doorverwijspagina.
  • Geavanceerde instellingen laat je toe om de instellingen aan te passen voor indexatie van de pagina door zoekmachines; het toont een tabblad om een nieuwe sectie toe te voegen en de weergegeven titel.
  • Talen toont een lijst met pagina's in andere talen die gelinkt zijn naar die pagina.
  • Gebruikte sjablonen toont een lijst met links naar elk sjabloon dat is gebruikt op deze pagina.

De tabbladen van de dialoog Opties worden ook weergegeven in het menu Pagina-instellingen en kunnen worden geopend door erop te klikken. Bovendien bevat het menu Pagina-instellingen de items Toon als links-naar-rechts of Toon als rechts-naar-links en item Zoeken en vervangen, die een dialoog opent, waar je de woorden of Reguliere expressies die je zoekt kunt invoeren en datgene waarmee je ze wil vervangen, samen met nog wat optieknoppen.


OOjs UI icon edit-ltr.svg
De knop Van tekstverwerker omschakelen zit naast de knop Wijzigingen publiceren. Hiermee kunt u overschakelen op de wikitekstverwerker.

Wijzigingen publiceren

Wanneer u klaar bent met bewerken klikt u op de blauwe knop "Wijzigingen publiceren". Zolang u geen wijzigingen heeft aangebracht is deze knop grijs gemaakt. Om alle wijzigingen te annuleren kunt u gewoon uw browservenster sluiten. U kunt ook boven de werkbalk op de knop "Lezen" klikken.
VisualEditor toolbar actions-nl.png

Wanneer u op de blauwe knop "Wijzigingen publiceren..." klikt wordt er een dialoogvenster geopend. Hierin kunt u uw bewerking samenvatten, de bewerking markeren als een kleine wijziging, en/of de pagina aan uw volglijst toevoegen. Het veld voor de samenvatting is het equivalent van het veld Samenvatting: in de normale wikitextverwerker.

Alvorens uw wijzigingen op te slaan kunt u de knop "Wijzigingen controleren" gebruiken om te bevestigen dat ze het gewenste resultaat geven. Dit is het equivalent van de knop "Wijzigingen bekijken" in de wikitextverwerker.

"Doorgaan met bewerken" brengt u terug naar de bewerkingspagina. U kunt uw wijzigingen later opslaan.

VisualEditor save dialog-nl.png

Links bewerken

VisualEditor - Toolbar - Linking.png
Links kunnen worden toegevoegd door te klikken op het "Koppeling"-pictogram (kettingschakels) op de werkbalk of door de sneltoets Ctrl+K (of ⌘ Command+K op een Mac) te gebruiken.

U kunt bestaande tekst gebruiken om een link te maken door deze te selecteren en op "Koppeling" te klikken. Voor een link die slechts uit een enkel woord bestaat kunt u dat woord selecteren of uw cursor in dat woord plaatsen.


VisualEditor-link tool-search results-nl.png
Met de knop of sneltoets wordt een dialoogvenster geopend waarin u de link kunt typen.

Het linkhulpmiddel zal waar mogelijk helpen met interne links door suggesties te doen terwijl u typt. Wanneer u een link heeft ingevoerd of geselecteerd kunt u op ↵ Enter drukken, buiten het dialoogvenster klikken of op de knop "Afgerond" drukken. De link zal dan op de pagina verschijnen, maar pas worden opgeslagen wanneer u de volledige pagina opslaat.


VisualEditor-link tool-external link.png
Linken naar een webpagina buiten Wikipedia gaat op ongeveer dezelfde manier: kies het tabblad "Uitwendige pagina" en geef de URL in het tekstvak in.

VisualEditor link tool simple link.png
Externe links zonder labels zien er als volgt uit: [1] Deze kunnen worden toegevoegd door uw cursor buiten een woord te plaatsen (bijvoorbeeld na een spatie). Open het linkhulpmiddel door op de knop te klikken of de sneltoets te gebruiken. Typ de URL in in het veld en klik op "Afgerond" om de link in te voegen.

VisualEditor-context menu-link tool.png
Om een bestaande link te bewerken of te verwijderen klikt u eerst op de link in de tekst en daarna op de knop "Koppeling". Er verschijnt een dialoogvenster. (U kunt het dialoogvenster ook openen met de sneltoets Ctrl+K.) Wanneer u een link selecteert krijgt deze een blauwe achtergrond.

U kunt vervolgens in het dialoogvenster het doel van de link aanpassen. U kunt ook de link in zijn geheel verwijderen door te klikken op het pictogram "Verwijderen" (prullenbak) in de linkerbenedenhoek van het dialoogvenster. U kunt ook het doel van de link in een apart venster openen door in het dialoogvenster op de kopie van de link te klikken. (Dit kan van pas komen als u wilt controleren of een externe link correct werkt.)

Als u het dialoogvenster wilt verlaten of verder wilt typen na de link drukt op de toets :

  • Door eenmaal op de toets te drukken verdwijnt het dialoogvenster link bewerken en verschijnt uw cursor aan het einde van het gelinkte element.
  • Tweemaal op de toets drukken plaatst uw cursor achter het gelinkte element. U kunt nu de rest van uw tekst typen.

Om het label van een bestaande link aan te passen klikt u op "Label wijzigen" en typt u het nieuwe label. Maar let op als u het label in zijn geheel wilt vervangen:

  • Als u het hele linklabel geselecteerd heeft verdwijnt de link door op een toets te drukken.
  • Om de link te wijzigen klikt u in het linklabel en gebruikt u de ← Backspace- en delete-toetsen om het bestaande label te verwijderen. U houdt een dunne blauwe lijn over. Nu kunt u een nieuw label ingeven, met behoud van de oorspronkelijke link.
  • Het is ook mogelijk te linken naar categorieën, bestanden en meer.

Referenties bewerken

Zie voor meer informatie Hulp bij het gebruik van referentiesjablonen of Hulp bij het gebruik van citoids knop Referentie

Bepalen welk systeem gebruikt wordt

Uw wiki kan gebruikmaken van een van drie voetnootsystemen. Het systeem rechts is het simpelste, waar het menu "Referentie" geen citeersjablonen bevat. Als uw wiki dit systeem gebruikt vindt u alles wat u moet weten over voetnoten op deze pagina.
VisualEditor cite menu default.png

Het tweede systeem heeft eenzelfde soort "Referentie"-menu, aangevuld met een aantal veelgebruikte citeersjablonen voor snelle toegankelijkheid. Als uw wiki dit systeem gebruikt vindt u meer informatie op Help:VisualEditor/User guide/Citations-Templates .
VisualEditor references more.png

VisualEditor citoid Cite button-nl.png
In het derde systeem begint u ook door te klikken op de knop Referentie. Vervolgens opent een dialoogvenster met een automatisch citeerproces dat gebruikmaakt van citoid. Als uw wiki dit systeem gebruikt vindt u meer informatie op Help:VisualEditor/User guide/Citations-Full .
VisualEditor Citoid Inspector-nl.png

Een bestaande referentie bewerken

Om een bestaande referentie te bewerken klikt u op de referentie in de tekst (vaak een getal tussen vierkante haken). Vervolgens ziet u ofwel een "Referentie"-pictogram (bladwijzer) of het icoon en de naam van het sjabloon dat gebruikt werd om deze referentie in te voegen. Door op "Bewerken" te klikken opent u een dialoogvenster waarin u de referentie kunt bewerken.
VisualEditor - Editing references 1.png

Als u in het "Referentie"-pictogram op "Bewerken" klikt opent het referentiedialoogvenster. Klik erop om de referentie aan te passen.

Veel wiki's gebruiken sjablonen om referenties volgens een bepaalde standaard op te maken. Als een sjabloon werd gebruikt bij een bepaalde referentie zal alle informatie in dat veld gemarkeerd worden wanneer u uw muis over de referentie-informatie beweegt.

Indien er een sjabloon werd gebruikt en u de referentie-informatie bekijkt binnen dat sjabloon, zal het Sjabloon pictogram (puzzelstuk) verschijnen. Klik op de knop Bewerken om de inhoud van de referentie in de minibewerker te bewerken.

VisualEditor - Editing references 6.png

Als je op een referentie drukt, een pictogram voor een standaard citeersjabloon (rechts een voorbeeld) wordt getoond, kunt u naar het sjabloondialoogvenster gaan door op "Bewerken" te klikken.
VisualEditor - Editing References - Cite Web.png

In de minibewerker kunt u soorten informatie toevoegen en verwijderen of de bestaande inhoud veranderen. Enkel velden (sjabloonparameters) die inhoud bevatten worden getoond. Om velden toe te voegen klikt u op "Toevoegen" onderaan het dialoogvenster.
VisualEditor - Editing references 5.png

Klik op "Wijzigingen toepassen" als u klaar bent.
VisualEditor Apply Changes-nl.png

Een bestaande referentie hergebruiken

Als de pagina al een geschikte referentie bevat kan u deze hergebruiken.

Om een bestaande referentie te hergebruiken plaatst u de cursor daar waar u de nieuwe referentie(nummer) in de tekst wilt invoegen. Klik vervolgens op het item "Hergebruiken" in het Referentie menu.

(Let op: als uw wiki het derde voetnootsysteem gebruikt, zoals hierboven beschreven, dan ziet u een tabblad "Hergebruiken" in een dialoogvenster in plaats van een knop Hergebruiken" in het menu "Referentie".)

VisualEditor Cite menu re-use.png

Kijk in het Referentie-dialoogvenster naar de lijst voor de referentie die u opnieuw wilt gebruiken en selecteer deze. Als er veel verwijzingen zijn, kunt u het zoekvak (met het label "Zoeken in huidige citaten") gebruiken om alleen die verwijzingen weer te geven die bepaalde tekst bevatten.
VisualEditor - Editing references 18.png

Een nieuwe referentie toevoegen

Om een ​​bronvermelding toe te voegen met behulp van het menu "Referentie", plaatst u de cursor op de plaats waar u deze in de tekst wilt toevoegen. Selecteer vervolgens het juiste citatietype in het menu.
VisualEditor references more.png

Een "basis"-referentie gebruiken

Rechts ziet u het dialoogvenster dat verschijnt wanneer u voor een standaardreferentie kiest. In het referentiedialoogvenster kunt u uw referentie toevoegen, inclusief opmaak.

U kunt de referentie indelen in een bepaalde groep, hoewel dit veld vaak blanco wordt gelaten. (Deze optie wordt gebruikt om groepen referenties weer te geven met de "Referentielijst"-tool.)

VisualEditor - Editing references 20.png

Als u een nieuwe referentie toevoegt en daarbij een sjabloon wilt gebruiken, klikt u op het "Sjabloon"-pictogram (puzzelstukje) in het menu "Invoegen" binnen het referentiedialoogvenster.
VisualEditor Template Insert Menu-nl.png

Zoek vervolgens het sjabloon dat u wilt gebruiken, voeg het toe en bewerk het zoals een normaal sjabloon. (Zie de sectie over het bewerken van sjablonen hieronder voor meer informatie over sjablonen.)

Als u klaar bent klikt u op "Wijzigingen toepassen" om terug te keren naar het referentiedialoogvenster. Klik nogmaals op "Wijzigingen toepassen" om terug te keren naar de pagina die u aan het bewerken bent.

VisualEditor - Editing references 9.png

Wanneer de pagina nog geen referentielijst bevat (bijvoorbeeld wanneer u de eerste referentie aan het toevoegen bent), moet u deze lijst eerst toevoegen om uw referentie te kunnen weergeven.

Plaats de cursor op de plek waar u wilt dat de referenties komen te staan (meestal onderaan de pagina), open het menu "Invoegen" en klik op "Referentielijst" (drie boeken) om de lijst toe te voegen.

VisualEditor References List Insert Menu-nl.png

Wanneer u verschillende groepen referenties heeft gemaakt (hetgeen niet zo vaak voorkomt) kunt u in dit dialoogvenster de groep specificeren. Enkel die referenties die tot die groep behoren worden dan op die plek weergegeven.

Ten slotte klikt u op "Invoegen".

VisualEditor references list-nl.png

Standaard referentiesjablonen gebruiken

Op uw lokale wiki kunnen er bijkomstige referentiesjablonen aan het menu "Referentie" zijn toegevoegd. Zo krijgt u snel toegang tot de meestgebruikte referentiesjablonen. (Instructies voor het toevoegen van bijkomstige referentiesjablonen aan uw wiki zijn te vinden op VisualEditor/Citation tool .)
VisualEditor - Editing References - Cite Pulldown.png

Door te klikken op een sjabloonpictogram zoals "Citeer boek" komt u terecht in een minibewerker voor dat sjabloon. Belangrijke informatievelden zijn aangeduid met een asterisk. De meestgebruikte velden worden getoond, maar deze hoeft u niet allemaal verplicht in te vullen.
VisualEditor - Editing references - Cite book required fields.png

Om meer velden toe te voegen scrolt u naar beneden en klikt u op de optie "Toevoegen".

Klik op "Invoegen" als u klaar bent.

VisualEditor - Editing references - Add parameter.png

Afbeeldingen en andere mediabestanden bewerken

Afbeeldingen bewerken

Om een nieuwe afbeelding (of een ander mediabestand) aan de pagina toe te voegen klikt u op het "Afbeeldingen en media"-pictogram (een afbeelding van een berglandschap) in het menu "Invoegen". De foto zal worden toegevoegd op de plaats waar uw cursor zich op dat moment bevindt.
VisualEditor Media Insert Menu-nl.png

Door te klikken op het "Afbeeldingen en media"-pictogram opent u een dialoogvenster dat automatisch Wikimedia Commons en uw lokale wiki doorzoekt om bestanden te vinden die overeenkomsten vertonen met de naam van de pagina die u aan het bewerken bent.

U kunt andere mediabestanden zoeken door de tekst in het zoekvak van het dialoogvenster aan te passen.

Klik op een miniatuur om een bestand te kiezen.

Hiermee plaatst u de afbeelding op de pagina die u aan het bewerken bent.

VisualEditor - Media editing 2.png

Nadat de door u gekozen afbeelding toegevoegd is aan de pagina zal er een ander dialoogvenster openen. Hier kan u een onderschrift aan de afbeelding toevoegen of het bestaande onderschrift aanpassen. Het onderschrift mag opmaak en links bevatten.
VisualEditor - Media editing 6.png

Het mediadialoogvenster kan ook worden gebruikt om een alternatieve tekst aan te bieden voor gebruikers die een screenreader gebruiken of die afbeeldingen hebben uitgeschakeld.
VisualEditor - Media editing 7.png

U kan verschillende afbeeldingsparameters gebruiken in het venster "Geavanceerde instellingen". Het gaat hier onder andere om de uitlijning, het type afbeelding en de grootte.
VisualEditor - Media editing 8.png

Wanneer u klaar bent klikt u op "Wijzigingen toepassen" om het dialoogvenster te sluiten en terug te keren naar de tekstverwerker.
VisualEditor Apply Changes-nl.png

U kunt een onderschrift aan een bestaande afbeelding toevoegen of een bestaand onderschrift aanpassen door op de afbeelding te klikken en daarna voor "Bewerken" te kiezen.

U kunt het formaat van een bestaande afbeelding aanpassen door op de afbeelding te klikken en vervolgens met de bijbehorende knop (de tweezijdige pijl links beneden) de afbeelding te vergroten of verkleinen.

U kan ook een afbeelding verplaatsen (hoger of lager op de pagina) door deze te verslepen.

VisualEditor - Media editing 3.png

Afbeeldingen uploaden

U kunt afbeeldingen uploaden vanaf een tabblad in het media-dialoogvenster, of door een bestand in de editor te slepen, of door een afbeelding te plakken van het klembord.
VisualEditor - Media upload 1.png

Klik op het tabblad "Uploaden" en selecteer een afbeelding vanaf uw computer. U kunt de bestandsnaam intypen, of de afbeelding naar het hokje slepen. Deze tab opent automatisch, als u een afbeelding in de editor hebt gesleept, of geplakt van het klembord.
VisualEditor - Media upload 1.5.png

U wordt gevraagd de afbeelding van een beschrijving te voorzien en categorieën toe te voegen, zodat anderen het bestand kunnen vinden.
VisualEditor - Media upload 2.png

Wanneer u klaar bent wordt de afbeelding aan de pagina toegevoegd.
VisualEditor-logo.svg

Mediagalerijen bewerken

Om een nieuwe galerij toe te voegen klikt u op "Galerij" (een reeks foto's) in het menu "Invoegen". (Als deze optie niet zichtbaar is heeft uw lokale wiki besloten om deze functie nog niet te implementeren in de visuele tekstverwerker.)
VisualEditor - Gallery1.png

Om een bestaande galerij te bewerken klikt u op die galerij. Daarna vindt u onderaan de galerij het galerij-icoon (een reeks foto's). Hiermee opent u de galerijbewerker met een lijst van alle afbeeldingen die reeds in de galerij te vinden zijn.
VisualEditor - Gallery2.png
De galerijbewerker is een simpel venster waarmee u bestaande galerijen kunt aanpassen met wikitekstopmaak. Om een nieuwe afbeelding aan een bestaande galerij toe te voegen typt u de naam van de afbeelding, gevolgd door een sluisteken (|) en het onderschrift voor de afbeelding. Elke afbeelding moet op een aparte regel staan. U kunt deze lijst ook bewerken om afbeeldingen te herschikken, te verwijderen of om onderschriften aan te passen.

Wanneer u op de knop "Afgerond" drukt, verlaat u de galerij-editor. U zou dan uw wijzigingen moeten zien, met de galerij zoals deze nu voor de lezers zal verschijnen.

Let erop dat - door de galerijbewerker te sluiten - uw wijzigingen nog niet worden opgeslagen. Net zoals met andere bewerkingen in de visuele tekstverwerker worden uw wijzigingen pas doorgevoerd nadat de hele pagina opgeslagen wordt.

VisualEditor - Gallery3.png

Sjablonen bewerken

Het krachtige sjabloonsysteem van MediaWiki laat je dynamische inhoud toevoegen, tekst van andere pagina's, ... Voor meer uitleg en voorbeelden.

In de VisualEditor kun je zoeken naar een relevant sjabloon, een aanroep of een transclusie toevoegen op de wijzigen pagina en, indien nodig, aangepaste inhoud gebruiken met parameters.

Nieuw sjabloon toevoegen

Om een nieuw sjabloon aan de pagina toe te voegen plaatst u de cursor daar waar u het sjabloon wilt invoegen. Open het Invoegen menu en kies "OOjs UI icon puzzle-ltr.svg Sjabloon". Dezelfde dialoog kan ook geopend worden met twee accolades {{.
VisualEditor Template Insert Menu-nl.png
Zoek het sjabloon dat u wilt toevoegen op door de naam of een relevant sleutelwoord in te vullen. De resultaten (in een dropdownlijst) bevatten dan de zoekterm dan of in de naam of in de beschrijven. Hopelijk kunt u zo het gewenste sjabloon vinden ook al weet u niet de exacte naam.

Als het opzoeken van het sjabloon of sleutelwoord (keyword) niet lukt, probeer dan een wiki-pagina te kijken waar het sjabloon gebruikt wordt en kijk dan in de source welk sjabloon daar gebruikt wordt. Als u de gezochte naam van het sjabloon heeft gevonden dan kunt u die hier invullen.

Schermafdruk met het zoekscherm naar sjablonen in de Visuele tekstverwerker

Het is mogelijk reeds ingevoegde sjablonen te bewerken. Als u het sjabloon dat u wilt bewerken selecteert, dan wordt het blauw en in een veld wordt getoond "OOjs UI icon puzzle-ltr.svg Sjabloon". Selecteer dan de link "Bewerken" of dubbelklik op het sjabloon zelf om het sjabloon te openen.
Screenshot of the VisualEditor interface with a template selected

Sommige sjablonen zijn niet zichtbaar voor de lezer. Zulke verborgen sjablonen worden in de visuele tekstverwerker wel getoond zodat u er op kan klikken en ze bewerken of verwijderen. De naam van het sjabloon staat naast het puzzel-icoon, beide zijn grijs.
Screenshot of hidden templates in the Visual Editor interface

Sjabloonparameters

U ziet dan deze dialoog als u een nieuw sjabloon aanmaakt of een bestaande wijzigt. De inhoud hangt af of het bepaalde sjabloon een TemplateData bevat, nuttige medadata die door andere schrijvers is toegevoegd maken het gemakkelijker om een sjabloon te bewerken in de visuele tekstverwerker.

Als een sjabloon TemplateData bevat, kan de VisualEditor dat gebruiken om de velden te beschrijven die u moet invullen.


Bij sjablonen die door de gemeenschap aangedragen TemplateData bevatten, de VisualEditor toont een lijst met de parameters en meestal beschrijvingen en instructies per parameter die het doel uitleggen en het verlangde formaat.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

U kunt de optionele parameters uitschakelen (die worden aangegeven met blauwe keuzevakjes aan de linkerzijde). Een grijs keuzevakje geeft aan dat het keuzevakje niet aangepast kan worden, het zijn in het sjabloon verplichte velden.

Bij het aanmaken van een sjabloon zult u opmerken dat bepaalde optionele parameters al vooringevuld zijn. Dat geeft aan dat de schrijver van het sjabloon het gebruik van die parameter aanbeveelt. U kunt het beste alle parameter bekijken die in het sjabloon gebruikt worden en de bedoeling ervan proberen te begrijpen.

Door te klikken op een niet aangevinkte parameter wordt het toegevoegd aan het sjabloon. Door te klikken op een al toegevoegde parameter kunt u de waarde gaan invullen.

Soms wordt een parameter aangegeven als ontraden (deprecated). Gebruik deze parameters dan liever niet bij het toevoegen van dat sjabloon in een pagina; die parameter is dan alleen zichtbaar omdat het in oudere pagina's nog gebruikt kan worden bij een eerdere versie van het sjabloon.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Niet gedocumenteerde parameters toevoegen

Als u een sjabloon toevoegt of wijzigt waarvan de schrijver de parameters niet heeft uitgelegd in de TemplateData, dan nomen wij dat niet gedocumenteerde of onbenoemde parameters. In die gevallen moet u helaas voor een uitleg de pagina van het sjabloon zelf raadplegen. Daar kunt u vinden hoe u de parameters van het sjabloon op de goede manier kunt gebruiken. U ziet dan ook de exacte namen van de parameters.

Als u ontdekt in de documentatie van het sjabloon dat er parameters zonder namen verwacht worden, vul dan een getal in als placeholder voor de parameternaam met de niet gedocumenteerde parameter invoer, voeg daarna tekst toe aan de waarden zoals u dat normaal gesproken zou doen.

Voorbeeld:

  • eerste onbenoemde parameter: “1”
  • waarde van die parameter: “en_US”
  • tweede onbenoemde parameter: “2”
  • Waarde van die parameter: “ja”

Bij het per ongeluk toevoegen van een niet bestaande parameter, wat een tikfoutje kan zijn, dan wordt de waarde van die parameter niet getoond op de pagina die bewerkt wordt.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Automatisch gegenereerde parameters

In dit voorbeeld, het sjabloon heeft geen TemplateData maar de parameters konden toch automatisch gegenereerd worden. De niet gedocumenteerde parameters zijn dus al voor u toegevoegd, maar de namen zijn mogelijk vaag en dat kan niet met een beschrijving worden toegelicht omdat er geen beschrijvingen zijn. Ale resultaat toont de dialoog een link naar de documentatie van het sjabloon, die u het mogelijk zou kunnen maken om de verschillende parameters van het sjabloon goed in te vullen.
Autogenerated parameters in the VisualEditor.png

Meervoudige delen sjablooninhoud bewerken

Bij het bijwerken kunt u de inhoud van het sjabloon openen die uit een of meerdere sjablonen kan bestaan gelinkt aan een wikitext. Dit verschilt van de hieronder geschreven geneste sjablonen. In dit geval worden de sjablonen beter weergegeven als zijnde gestapeld of verbonden.

Deze inhoud bevat vaak “niet gebalanceerde sjablonen”, deze zijn niet volledig op zichzelf omdat ze gekoppeld zijn aan een ander sjabloon wat dan daarna gebruikt moet worden.

Deze gerelateerde stukjes sjabloon inhoud kunnen in wikitext worden aangemaakt, maar kunnen in de VisualEditor worden aangepast. In deze gevallen ziet een opmerking bovenaan de dialoog om u hierop te wijzen en onderaan de zijbalk wordt een gespecialiseerde werkbalk weergegeven. Dar kunt u de icoon-knoppen gebruiken om aanvullende sjablonen of wikitext toe te voegen, onderdelen te verwijderen of de volgorde aan te passen.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Geneste sjablonen

Een sjabloon kan een of meerdere sjablonen bevatten als de waarde voor parameters. U kunt dit herkennen door het gebruik van dubbele accolades ( {{ }} ) die een sjaloon aangeven.

De VisualEditor kan dit sjabloon niet in een sjabloon aangegeven met de eenvoudige interface, dus als u dit zelf wilt gaan toepassen, dat moet u inzien hoe het sjabloon handmatig wordt toegevoegd in wikitext in het te gebruiken veld.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

De wijziging afronden

Wanneer u klaar bent met het bewerken van het sjabloon klikt u op "Wijzigingen toepassen". Bekijk eerst vooraf uw wijziging om te kijken of het is wat u wilde doen.

U kunt een foutbericht krijgen die (zoals de eerder gemelde TemplateData) afkomstig is van de gemeenschap en waarvan de nut sterk kan verschillen. U moet mogelijk de documentatie van het sjabloon zelf bekijken om bepaalde fouten te kunnen oplossen. Als het niet lukt, kunt u via de overleg-pagina van het sjabloon proberen om ondersteuning te vragen.

VisualEditor Apply Changes-nl.png

Sjabloon verwijderen

Om in de VisualEditor een sjabloon te verwijderen klikt u op de het paneel van het sjabloon. Druk op de knop "Delete" of de knop "Backspace" van uw toetsenbord. Het sjabloon wordt van de pagina verwijderd.
Screenshot of the button to remove a template
Een sjabloon in de VisualEditor verwijderen

Een mobiel toestel gebruiken

Als u een sjabloon op een pagina met VisualEditor wijzigt op een mobiel toestel, ziet u dat de zijbalk in het begin verborgen is. Druk op de knop om de opties weer te geven / te verbergen.
Screenshot of editing a template on a mobile device
Een sjabloon op een mobiel toestel in de VisualEditor wijzigen

Sjablonen substitueren

Bij het toevoegen van een sjabloon aan een pagina wordt de inhoud en de weergave elke keer dat de pagina geladen wordt opnieuw bepaald. Fit op basis van de code van het sjabloon en de waarden van de parameters. Dit betekent dat bij wijziging van de code van het sjabloon elke pagina die dat sjabloon gebruikt wordt aangepast als die pagina wordt gepubliceerd.

Er is ook een minder gebruikelijke manier om sjablonen te gebruiken, dat is het substitueren / vervangen van een sjabloon. Door dit te doen wordt het sjabloon blijvend ingevoegd zoals het er op dat moment uitziet op het moment van het toevoegen. Het wordt dus niet bijgewerkt als het sjabloon later wordt bijgewerkt.

De meeste gebruikers willen nooit een substitutie herstellen. Substitueren is meestal alleen nuttig als u de exacte versie van de weergave van een versie van het sjabloon wil vastleggen, zoals wanneer de inhoud ontwikkelt wordt en er nog aanpassingen gepland zijn.

Om dit in VisualEditor te doen, voeg een sjabloon toe met gebruik van subst:<template name>. (Automatisch aanvullen werkt in dit geval niet.) Druk daarna op de blauwe knop op het sjabloon toe te voegen.

Klik daarna op “Invoegen”, dat zal de huidige inhoud van het sjabloon invoegen.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Lijsten bewerken

VisualEditor Toolbar Lists and indentation-nl.png
Met de visuele tekstverwerker kunt u nieuwe lijsten maken of bestaande lijsten bewerken. Er zijn twee soorten lijsten: ongeordende (ongenummerd) en geordende (genummerd).

Om een nieuwe lijst te maken klikt u op een van de twee menu-opties die links staan afgebeeld. Als u al een lijst getypt heeft (met de items op aparte regels) kunt u die ook selecteren en vervolgens op een van de menu-opties klikken.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Hiernaast ziet u voorbeelden van de twee lijstsoorten: ongeordend (ongenummerd) en geordend (genummerd).

VisualEditor lists 3 select to indent.png
Om de mate van inspringing van een deel van een bestaande lijst aan te passen selecteert u dat deel van de lijst dat u wilt aanpassen.

VisualEditor lists 4 indentation menu.png
Vervolgens kiest u in het menu voor 'Inspringing verkleinen' of 'Inspringen vergroten'. U kunt ook op de Tab-toets op uw toetsenbord drukken. (Met Tab vergroot u de inspringing. Met Shift + Tab verkleint u de inspringing.)

VisualEditor lists after indenting.png
Hier ziet u het resultaat van een vergrote inspringing.

VisualEditor lists mixed.png
Het is zelfs mogelijk om geordende en ongeordende lijsten door elkaar te gebruiken, op voorwaarde dat de lijstitems verschillend zijn ingesprongen.

Tabellen bewerken

VisualEditor insert table-nl.png
U kunt de visuele tekstverwerker gebruiken om tabellen in te voegen en te bewerken.

Het is zelfs mogelijk om een tabel te importeren door een csv-bestand van uw computer naar het bewerkingsscherm te slepen.


Wanneer u in het menu "Invoegen" op "Tabel" klikt voegt de visuele tekstverwerker een tabel met vier kolommen en vier rijen toe.

Nu verschijnt het menu "Tabel". Vanuit dat menu kunt u een bijschrift boven de tabel invoegen.

VisualEditor empty table.png

Om een cel te selecteren klikt u er eenmaal op.
VisualEditor tables select one cell.png

Om de inhoud van de cel te bewerken (bijvoorbeeld om inhoud toe te voegen of een spelfout te verbeteren) klikt u tweemaal op die cel. U kunt de cel ook selecteren en op Enter drukken.

Om te stoppen met het bewerken van de cel klikt u op een willekeurige andere plek op de pagina.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
U kunt een kolom of rij toevoegen, verplaatsen of verwijderen.

U kunt cellen samenvoegen: selecteer ze en klik dan in het menu Tabel op "Cellen samenvoegen".
VisualEditor tables merge cells.png

Als u cellen samenvoegt behoudt u slechts de tekst in een van de cellen; tekst in andere cellen wordt verwijderd wanneer u cellen samenvoegt. Als u besluit dat u de verwijderde tekst toch wilt gebruiken, gebruik dan de knop Ongedaan maken en verplaats of kopieer de tekst alvorens de cellen opnieuw samen te voegen.
VisualEditor tables post-merge cell.png

Het is ook mogelijk om eerder samengevoegde cellen te splitsen. Wanneer u een cel splitst komt de inhoud daarvan in de eerste cel te staan. Desgewenst kunt u deze tekst daarna knippen en in andere cellen plakken.
VisualEditor tables split cells.png

Categorieën bewerken

VisualEditor category item-nl.png
Om categorieën te bewerken klikt u op "Categorieën" in het menu "Pagina-instellingen".

VisualEditor category editing-nl.png
De knop "Categorieën" opent een dialoogvenster dat de huidige categorieën weergeeft en het mogelijk maakt nieuwe toe te voegen en bestaande categorieën te verwijderen.

Je hebt ook de keuze om in te stellen of wijzigen de algemene (standaard) sorting key, die de plaats bepaalt van de pagina als ze met andere opgelijst wordt in eenzelfde categorie.

Een voorbeeld: de standaard sorteernaam voor het artikel "George Washington" is "Washington, George", waardoor het artikel in de categorie "Presidenten van de Verenigde Staten van Amerika" onder de letter "W" wordt gesorteerd (en niet onder "G").


VisualEditor - Category editing 3.png
Om een nieuwe categorie toe te voegen vult u in het tekstvak "Categorie toevoegen" de naam van de categorie in. Terwijl u typt zal de visuele tekstverwerker mogelijke overeenkomsten zoeken in bestaande categorieën. U kunt een bestaande categorie kiezen of u kunt een nieuwe, onbestaande categorie toevoegen. (Tot deze categoriepagina is aangemaakt zal de nieuwe categorie als een rode link getoond worden.)

VisualEditor - Category editing 2.png
Om een bestaande categorie te verwijderen klikt u erop en daarna op het pictogram "Verwijderen" (prullenbak) in het dialoogvenster dat verschijnt.

Door op een categorie te klikken kunt u ook een sorteernaam voor die specifieke categorie opgeven. Hierdoor wordt de normale sorteervolgorde genegeerd.


VisualEditor Apply Changes-nl.png
Wanneer u klaar bent met categorieën bewerken klikt u op "Wijzigingen toepassen" om terug te keren naar de tekstverwerker.

Pagina-instellingen bewerken

VisualEditor page settings item-nl.png
Om de instellingen van een pagina te bewerken klikt u in het menu "Pagina-instellingen" op het pictogram "Pagina-instellingen".

VisualEditor Page Settings-nl.png
Het pictogram "Pagina-instellingen" opent een dialoogvenster met verschillende opties.

VisualEditor Page Settings Redirects-nl.png
U kunt gemakkelijk een pagina als doorverwijzing instellen door "Pagina doorsturen naar" aan te vinken en vervolgens de pagina waarnaar u de lezer wilt verwijzen in te typen.

Onderaan het venster is er de mogelijkheid om ervoor te zorgen dat hernoeming van een pagina niet automatisch deze doorverwijzing updaten. Deze functie wordt zeer zelden gebruikt.


VisualEditor Page Settings TOC-nl.png
Het wel of niet tonen van de inhoudstafel op een pagina kan worden aangeduid met een van deze drie knoppen. De standaardwaarde is "Als nodig", waarmee een inhoudstafel wordt getoond van zodra er drie of meer koppen in het artikel staan.

VisualEditor Page Settings Edit Links-nl.png
Door dit kadertje aan te vinken zorgt u ervoor dat er geen "bewerk"-knop verschijnt naast elke kop.

VisualEditor Apply Changes-nl.png
Klik op "Wijzigingen toepassen" wanneer u klaar bent met het bewerken van de Pagina-instellingen (pagina-instellingen) om terug te keren naar de tekstverwerker.

Kaarten bewerken.

Visual editor showing editing an existing map.jpg
Je kan kaarten toevoegen en wijzigen. Zie Help:VisualEditor/Maps .

Wiskunde formules bewerken

Om een nieuwe wiskundige formule in te voegen plaatst u uw cursor op de plaats waar u deze wilt toevoegen en klikt u op het "Wiskundige formule"-pictogram("Σ") in het menu "Invoegen".
VisualEditor Formula Insert Menu-nl.png

Hierna wordt er een venster geopend waarin u de formule kunt ingeven met behulp van LaTeX-syntax. De visuele tekstverwerker zal de formule tijdens het typen updaten, zodat u uw wijzigingen meteen kunt zien. Wanneer u klaar bent klikt u op "Invoegen".
VisualEditor formula-nl.png

Om een bestaande wiskundige formule aan te passen klikt u op deze formule en klikt u op het "Σ"-pictogram dat verschijnt. Hierna wordt het dialoogvenster voor formules geopend, waar u uw wijzigingen kunt doorvoeren.
VisualEditor - editing existing mathematical formula.png

Wiskundige formules kunnen in de tekst zelf geplaatst worden of als een blok gecentreerd worden.
VisualEditor mathematic formula inline.png

Bladmuziek bewerken

Om bladmuziek toe te voegen plaatst u uw cursor waar u wilt dat de bladmuziek wordt ingevoegd. Klik vervolgens in de werkbalk op het menu "Invoegen" en daarna op "Muzieknotatie".

Klik twee keer achter elkaar op bestaande bladmuziek om deze te bewerken.

VisualEditor-Insert-Musical-Notation.png

Hiermee opent u het dialoogvenster "Muzieknotatie". De muzieknotatie kan op toonladder bewerkt worden, in ABC of in LilyPond. Het is ook mogelijk de notatie te koppelen aan een audio- of MIDI-bestand. Wanneer u klaar bent klikt u op "Invoegen" om het dialoogvenster te sluiten en uw wijzigingen te publiceren.
Musical.png

Gedichten en andere bijzondere onderdelen bewerken

Sommige onderdelen, zoals associatie lijsten en gedichten, worden nog niet volledig door de visuele tekstverwerker ondersteund.
VisualEditor editing poem 1.png

In de meeste gevallen kunnen bestaande items wel bewerkt worden, maar kunnen met de visuele tekstverwerker geen nieuwe items worden ingevoegd.

Tot ze volledig ondersteund worden kunt u een bestaande van een andere pagina kopiëren, of direct de broncode bewerken.

VisualEditor editing poem 2.png

Schakelen tussen de visuele tekstverwerker en de wikitekstverwerker

Om van de visuele tekstverwerker over te schakelen op de wikitekstverwerker klikt u op de knop [[ ]] helemaal rechts op de werkbalk.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

U ziet een diff. (Als u op "Wijzigingen niet opslaan" heeft geklikt ziet u slechts wikitekst, klaar om te bewerken met de wikitekstverwerker.)

Als u naar beneden scrolt ziet u het wikitekstbewerkingsvenster.

VisualEditor bi-directional switching diff before wikitext.png

Het is ook mogelijk om van de wikitekstverwerker over te schakelen naar de visuele tekstverwerker. Klik daarvoor op het potlood-icoon helemaal rechts op de werkbalk.

VisualEditor bi-directional switching pencil icon in wikitext.png

Sneltoetsen

Veel bijdragers aan de encyclopedie zijn eraan gewend geraakt om wikitekst rechtstreeks toe te voegen, vooral vet, cursief en interne links. Sneltoetsen maken het mogelijk om dergelijke opmaak vlug toe te voegen zonder de werkbalk te gebruiken. De volgende veelgebruikte sneltoetsen worden door de visuele tekstverwerker ondersteund:

Sneltoetsen op pc Actie Sneltoetsen op Mac

Ctrl+B Vet ⌘ Cmd+B

Ctrl+I Cursief ⌘ Cmd+I

Ctrl+K Link invoegen ⌘ Cmd+K

Ctrl+X Knippen ⌘ Cmd+X

Ctrl+C Kopiëren ⌘ Cmd+C

Ctrl+V Plakken ⌘ Cmd+V

Ctrl+Z Ongedaan maken ⌘ Cmd+Z