วิธีใช้:เครื่องมือแก้ไขแบบเห็นภาพ/คู่มือผู้ใช้

This page is a translated version of the page Help:VisualEditor/User guide and the translation is 45% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Bahasa Melayu • ‎Bikol Central • ‎Cebuano • ‎Cymraeg • ‎Deutsch • ‎English • ‎Esperanto • ‎Fiji Hindi • ‎Frysk • ‎Ilokano • ‎Interlingue • ‎Jawa • ‎Lëtzebuergesch • ‎Malagasy • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Napulitano • ‎Nederlands • ‎Oromoo • ‎Picard • ‎Scots • ‎Sunda • ‎Tagalog • ‎Tiếng Việt • ‎Tûnsî • ‎Türkçe • ‎Yorùbá • ‎Zazaki • ‎asturianu • ‎azərbaycanca • ‎bosanski • ‎català • ‎dansk • ‎eesti • ‎emiliàn e rumagnòl • ‎español • ‎euskara • ‎français • ‎furlan • ‎føroyskt • ‎galego • ‎hrvatski • ‎isiXhosa • ‎italiano • ‎latviešu • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎shqip • ‎slovenčina • ‎slovenščina • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎беларуская (тарашкевіца)‎ • ‎български • ‎македонски • ‎русский • ‎саха тыла • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎ייִדיש • ‎עברית • ‎العربية • ‎تۆرکجه • ‎سنڌي • ‎فارسی • ‎پښتو • ‎मराठी • ‎संस्कृतम् • ‎हिन्दी • ‎অসমীয়া • ‎বাংলা • ‎ਪੰਜਾਬੀ • ‎ଓଡ଼ିଆ • ‎தமிழ் • ‎తెలుగు • ‎ಕನ್ನಡ • ‎മലയാളം • ‎ไทย • ‎မြန်မာဘာသာ • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎日本語 • ‎ꯃꯤꯇꯩ ꯂꯣꯟ • ‎한국어
PD หมายเหตุ: เมื่อคุณแก้ไขหน้านี้ ถือว่าคุณยินยอมที่จะเผยแพร่งานของคุณภายใต้สัญญาอนุญาต CC0 ดูที่ Public Domain Help Pages สำหรับข้อมูลเพิ่มเติม
PD
หากคุณประสงค์ทดลองเครื่องมือแก้ไขแบบเห็นภาพโดยไม่แก้ไขบทความ นี่คือหน้าที่คุณสามารถทดสอบได้อย่างเสรี คุณไม่จำเป็นต้องมีบัญชีเพื่อใช้เครื่องมือแก้ไขแบบเห็นภาพในหน้านั้น


การเปิดเครื่องมือแก้ไขแบบเห็นภาพ

ในการแก้ไขหน้าโดยใช้เครื่องมือแก้ไขแบบเห็นภาพ ให้คลิกแถบ "แก้ไข" ที่บนสุดของหน้า

การเปิดหน้าเพื่อแก้ไขอาจใช้เวลาหลายวินาที และนานกว่านั้นหากหน้ามีความยาวมาก

คลิกที่แท็บ "แก้ไขต้นฉบับ" จะเปิดตัวแก้ไขข้อความวิกิ (wikitext) แบบดั้งเดิม

VisualEditor edit tab-en.png

คุณยังสามารถเปิดเครื่องมือแก้ไขแบบเห็นภาพโดยคลิกลิงก์ "แก้ไข" ในแต่ละส่วน
VisualEditor - Section edit links-en.png

เริ่มต้น: แถบเครื่องมือของเครื่องมือแก้ไขแบบเห็นภาพ

ภาพจับหน้าจอของแถบเครื่องมือเครื่องมือแก้ไขแบบเห็นภาพ
แถบเครื่องมือเครื่องมือแก้ไขแบบเห็นภาพปรากฏที่บนสุดของจอภาพเมื่อคุณเริ่มต้นแก้ไข ในแถบมีสัญรูปที่คุ้นเคยอยู่บ้าง

VisualEditor - Toolbar - Undo-redo.png
เลิกทำ และ ทำซ้ำ การแก้ไขที่คุณสร้าง

VisualEditor Toolbar Headings-th.png
รายการเลือกดึงลงหัวเรื่อง: ทำให้คุณเปลี่ยนแปลงการจัดรูปแบบย่อหน้า ในการเปลี่ยนแปลงลีลาของย่อหน้า ให้คุณวางเคอร์เซอร์ไว้ในย่อหน้าแล้วเลือกรายการในรายการเลือกนี้ (ไม่จำเป็นต้องเน้นข้อความใด ๆ ทั้งสิ้น) ชื่อส่วน (section) จะจัดรูปแบบเป็น "หัวเรื่อง" และส่วนย่อย (subsection) เป็น "หัวเรื่องรอง 1", "หัวเรื่องรอง 2" ฯลฯ "ย่อหน้า" เป็นรูปแบบปกติสำหรับข้อความ

VisualEditor Toolbar Formatting-th.png

การจัดรูปแบบ: เมื่อกด "A" จะเปิดรายการเลือก

  • รายการ "ตัวหนา" (B) ทำให้ข้อความที่เลือกเป็นตัวเส้นหนา
  • รายการ "ตัวเอน" (I) ทำให้ข้อความที่เลือกเป็นตัวเอน
  • รายการ "ตัวยก" (x2) ทำให้ข้อความที่เลือกปรากฏเล็กลงและอยู่สูงกว่าข้อความที่แวดล้อมเล็กน้อย
  • รายการ "ตัวห้อย" (x2) ทำให้ข้อความที่เลือกปรากฏเล็กลงและอยู่ต่ำกว่าข้อความที่แวดล้อมเล็กน้อย
  • รายการ "ขีดทับ" (S) เพิ่มขีดทึบทับข้อความที่เลือก
  • รายการ "รหัสคอมพิวเตอร์" (วงเล็บปีกกาเปิดและปิด: {}) เปลี่ยนชุดแบบอักษรของข้อความที่เลือกให้เป็นชุดแบบอักษรความกว้างคงที่ ซึ่งจะแยกข้อความนี้กับข้อความที่อยู่แวดล้อม (ที่มีความกว้างแบบสัดส่วน)
  • รายการ "เส้นใต้" (U) เพิ่มขีดทึบใต้ข้อความที่เลือก
  • รายการ "ภาษา" (文A) ทำให้คุณระบุภาษา (เช่น ภาษาญี่ปุ่น) และทิศทาง (ตัวอย่างเช่น จากขวาไปซ้าย) ของข้อความที่เลือก
  • รายการสุดท้าย (VisualEditor MediaWiki theme clear icon bitmap.png) เรียก "เอาออก" ลบการจัดรูปแบบอักขระทั้งหมดจากข้อความที่เลือก รวมทั้งลิงก์

หากคุณไม่ได้เลือกข้อความใด เมื่อคุณกด "A" เพื่อเปิดรายการเลือก แล้วคลิกรายการหนึ่ง การจัดรูปแบบจะใช้กับข้อความที่คุณพิมพ์หลังจากนั้น เริ่มจากตำแหน่งของเคอร์เซอร์


VisualEditor - Toolbar - Linking.png
เครื่องมือการเชื่อมโยง: สัญรูปโซ่เป็นเครื่องมือการเชื่อมโยง เมื่อคลิกแล้ว (ปกติหลังเลือกข้อความส่วนหนึ่ง) จะเปิดคำโต้ตอบลิงก์

VisualEditor - Cite Pulldown.png
รายการเลือกอ้างอิง: รายการ "อ้างอิง" ใช้เพื่อเพิ่มแหล่งที่มาในบรรทัด (เรียกร้อง "เชิงอรรถ" หรือ "อ้างอิง") ทุกโครงการเข้าถึงการจัดรูปแบบอ้างอิงพื้นฐานและความสามารถใช้แหล่งที่มาซ้ำโดยรายการเลือกนี้ นอกจากนี้ ยังให้ผู้ใช้เข้าถึงแม่แบบแหล่งที่มาท้องถิ่นได้อย่างรวดเร็ว หากเปิดใช้งานแม่แบบดังกล่าวในวิกิของตน

(ดูคำชี้แจงสำหรับการเพิ่มแม่แบบแหล่งที่มาท้องถิ่นเข้ารายการเลือกอ้างอิงในวิกิจำเพาะได้ที่ VisualEditor/Citation tool )


VisualEditor citoid Cite button-en.png
ปุ่ม ⧼citoid-citefromidtool-title⧽: หากเปิดใช้งานบริการไซทอยด์บนวิกิของคุณ คุณจะเห็นปุ่ม ⧼citoid-citefromidtool-title⧽ แทนรายการเลือก อ้างอิง

บริการไซทอยด์พยายมกรอกแม่แบบแหล่งที่มาอัตโนมัติ


VisualEditor Toolbar Lists and indentation-th.png
รายการและย่อหน้า: สองสัญรูปแรกให้คุณจัดรูปแบบข้อความเป็น "รายการสัญลักษณ์" หรือ "รายการลำดับเลข" สองรายการหลังให้คุณเพิ่มหรือลดระดับการเยื้องรายการ

VisualEditor Insert Menu-th.png
แทรก: รายการเลือก "แทรก" อาจแตกต่างกันในบางโครงการ ด้านล่างเป็นตัวเลือกทั้งหมดที่อาจปรากฏ
  • ไอคอน "สื่อ" รูปภูเขา เปิดตัวจัดการสื่อ.
  • สัญรูป "Template" (ชิ้นส่วนจิ๊กซอว์) เปิดให้คุณแก้ไขแม่แบบ
  • รายการ "ตาราง" ให้คุณแทรกตาราง
  • รายการ "ความเห็น" (บอลลูนคำพูด) เปิดให้คุณแทรกความเห็นซึ่งผู้อ่านจะมองไม่เห็น ความเห็นเหล่านี้จะเห็นเฉพาะเมื่ออยู่ในภาวะแก้ไข โดยมีการบ่งชี้โดยสัญรูปเครื่องหมายอัศเจรีย์ (!) ในภาวะแก้ไข เมื่อกดที่สัญรูปเครื่องหมายอัศเจรีย์จะทำให้คุณแก้ไขหรือลบความเห็นดังกล่าว
  • สัญรูป "Hieroglyphs" (เครื่องหมายอังก์ - ☥) เปิดให้คุณเข้าเครื่องมือแรกเฮียโรกริฟ (ดูด้านล่าง)
  • รายการ "Code block" เปิดให้คุณแทรกรหัส
  • รายการ "เครื่องหมายกำกับดนตรี" เปิดให้คุณแทรกเครื่องหมายกำกับดนตรี
  • สัญรูป "Gallery" (ชุดภาพถ่าย) เปิดให้คุณแทรกแกลอรีเข้าในหน้า
  • สัญรูป "สูตรคณิตศาสตร์" (Σ) เปิดคำโต้ตอบเครื่องมือแทรกสูตร
  • รายการ "กราฟ" ให้คุณแทรกกราฟ
  • รายการ "Your signature" ให้คุณแทรกลายเซ็นที่คุณใช้ในโครงการนั้น เครื่องมือจะกลายเป็นสีเทา (เลือกไม่ได้) เมื่อคุณแก้ไขหน้าบางประเภท ("เนมสเปซ") เช่น บทความ ซึ่งไม่ควรแทรกลายเซ็น
  • ไอคอน รายการอ้างอิง" รูปหนังสือสามเล่มเปิดหน้าต่างแสดงรายการอ้างอิง

การแทรกอักขระพิเศษ: สัญรูป "อักขระพิเศษ" (Ω) อยู่ถัดจากรายการเลือก "แทรก" เมื่อกดจะแสดงคำโต้ตอบที่แสดงอักขระพิเศษจำนวนมาก เมื่อคลิกที่อักขระใดอักขระหนึ่งจะเป็นการวางในข้อความ อักขระพิเศษเหล่านี้ประกอบด้วยสัญลักษณ์มาตรฐาน เครื่องหมายเสริมสัทอักษรและเครื่องหมายคณิตศาสตร์ (รายการนี้อาจปรับแต่งได้ในท้องถิ่น ดูคำชี้แจงที่ VisualEditor/Special characters )
VisualEditor Toolbar SpecialCharacters-th.png

VisualEditor toolbar edit notices icon.png
ปุ่มประกาศแก้ไขแสดงผลประกาศใด ๆ สำหรับหน้านั้น

VisualEditor More Settings-th.png
รายการเลือก ตัวเลือกหน้า อยู่ซ้ายมือของปุ่ม เผยแพร่การเปลี่ยนแปลง และรายการเลือก "เปลี่ยนเครื่องมือแก้ไข" ในรายการเลือกนี้มีปุ่มเปิดคำโต้ตอบตัวเลือกโดยมีแถบดังต่อไปนี้ (อยู่ซ้ายมือ)
  • หมวดหมู่ ให้คุณเพิ่มหมวดหมู่เข้าหน้านี้และปรับเปลี่ยนวิธีการเรียงลำดับหน้า เมื่อแสดงผลภายในหมวดหมู่โดยการตั้งค่าดัชนีต่าง ๆ ให้สำหรับเรียงลำดับ
  • การตั้งค่าหน้า ให้คุณแปลงหน้าเป็นหน้าเปลี่ยนทางและปรับเปลี่ยนตัวเลือกของการเปลี่ยนทางนี้, ปรับเปลี่ยนการตั้งค่าว่าด้วยการแสดงผลสารบัญ, ปิดใช้งานข้อความลิงก์แก้ไขที่อยู่ถัดจากหัวเรื่อง และนิยามหน้าเป็นหน้าแก้ความกำกวม
  • การตั้งค่าขั้นสูง ให้คุณปรับเปลี่ยนการตั้งค่าเกี่ยวกับการทำดัชนีของหน้าโดยเสิร์ชเอนจิน แสดงแถบให้เพิ่มส่วนใหม่และชื่อเรื่องที่แสดงผล
  • Languages ซึ่งแสดงรายการหน้าในภาษาอื่นที่เชื่อมโยงมาหน้านั้น
  • แม่แบบที่ใช้ แสดงรายการลิงก์ไปแม่แบบที่ใช้ในหน้านี้

แถบคำโต้ตอบตัวเลือกยังแสดงผลในรายการเลือกตัวเลือกหน้า สามารถเปิดได้โดยคลิก ยิ่งไปกว่านั้นรายการเลือกตัวเลือกหน้ายังมีปุ่ม ดูเป็นขวาไปซ้าย และปุ่ม ค้นหาและแทนที่ ซึ่งเปิดคำโต้ตอบที่คุณสามารถแทรกอักขระ พจน์หรือนิพจน์ปรกติที่คุณกำลังค้นหาและที่จะแทนที่ ร่วมกับตัวเลือกอีกหลายปุ่ม


VisualEditor bi-directional switching square brackets icon.png
ปุ่มเปลี่ยนเป็นการแก้ไขต้นฉบับอยู่ถัดจากปุ่ม เผยแพร่การเปลี่ยนแปลง ซึ่งจพทำให้คุณเปลี่ยนเป็นเครื่องมือแก้ไขแบบข้อความวิกิ

การเผยแพร่การเปลี่ยนแปลง

เมื่อคุณแก้ไขเสร็จแล้ว คลิกปุ่ม "เผยแพร่การเปลี่ยนแปลง" สีน้ำเงินในแถบเครื่องมือ ถ้ายังไม่ได้เปลี่ยนแปลงอะไร ปุ่มจะยังปิดใช้งาน (เป็นสีเทา) หากต้องการยกเลิกการเปลี่ยนแปลงแก้ไขทั้งหมด ให้ปิดหน้าต่างเบราว์เซอร์ หรือกดแถบ "อ่าน" ที่อยู่บนแถบเครื่องมือแก้ไข
VisualEditor toolbar actions-th.png

การกดปุ่ม "เผยแพร่การเปลี่ยนแปลง" สีน้ำเงินจะเปิดคำโต้ตอบ คุณสามารถกรอกความย่อการแก้ไขการกระทำของคุณ ระบุว่าการแก้ไขของคุณเป็นการแก้ไขเล็กน้อย และเพิ่มหน้าเข้ารายการเฝ้าดู กล่องสำหรับความย่อเทียบเท่ากับเขตข้อมูลความย่อ:ในเครื่องมือแก้ไขข้อความวิกิ

คุณยังสามารถทบทวนการเปลี่ยนแปลงของคุณโดยใช้ปุ่ม "ทบทวนการเปลี่ยนแปลงของคุณ" เพื่อยืนยันว่าการแก้ไขนั้นจะทำงานได้ตามที่คุณประสงค์ก่อนบันทึกการเปลี่ยนแปลง ซึ่งคล้ายกับปุ่ม "แสดงการเปลี่ยนแปลง" ในเครื่องมือแก้ไขข้อความวิกิ

ปุ่ม "แก้ไขต่อ" ให้คุณย้อนกลับไปหน้าที่คุณกำลังแก้ไข คุณสามารถเผยแพร่การเปลี่ยนแปลงของคุณทีหลังได้

VisualEditor save dialog-th.png

การแก้ไขลิงก์

VisualEditor - Toolbar - Linking.png
สามารถเพิ่มลิงก์ผ่านสัญรูป "ลิงก์" (รูปข้อต่อโซ่) ในแถบเครื่องมือหรือผ่านทางลัด Ctrl+K (หรือ Command+K บนแมค)

หากคุณเลือก (เน้น) ข้อความแล้วกดปุ่ม "ลิงก์" จะใช้ข้อความนั้นในการสร้างลิงก์ สำหรับลิงก์ที่ใช้คำคำเดียว คุณสามารถเลือกคำคำนั้นหรือเพียงวางเคอร์เซอร์ในคำนั้นก็ได้


VisualEditor-link tool-search results-th.png
ไม่ว่าคุณจะกดปุ่มในแถบเครื่องมือหรือผ่านทางลัด หน้าต่างจะปรากฏให้คุณพิมพ์ลิงก์ที่คุณต้องการเชื่อม VisualEditor จะพยายามช่วยคุณหาลิงก์ภายใน (ลิงก์หน้าอื่นๆ ของวิกิพีเดีย) โดยการค้นหาหน้าที่อาจใช่ทันทีที่คุณเริ่มพิมพ์

เครื่องมือลิงก์จะพยายามช่วยเหลือลิงก์ภายในโดยการค้นหาคำตรงกันที่เป็นไปได้


VisualEditor link tool 2015.png
เวลาคุณกรอกหรือเลือกลิงก์ การกด Enter หรือกดปุ่ม "สำเร็จ" จะเป็นการเสร็จสิ้นกระบวนการเชื่อมโยง ลิงก์ของคุณจะปรากฏบนหน้าทันที แต่จะยังไม่เผยเแพร่จนกว่าจะเผยแพร่ทั้งหน้าพร้อมกับการเปลี่ยนแปลงอย่างอื่น

VisualEditor-link tool-external link.png
การลิงก์ไปยังเว็บเพจในเว็บไซต์อื่นมีกระบวนการคล้ายกัน: เลือกแถบ "External site" แล้วกรอกยูอาร์แอลในกล่อง

VisualEditor link tool simple link.png
ลิงก์ภายนอกที่ไม่มีป้ายจะเป็นดังตัวอย่าง: [1] คุณสามารถเพิ่มลิงก์ภายนอกโดยวางเคอร์เซอร์ไม่ให้อยู่บนคำใดคำหนึ่ง (เช่น ตามหลังช่องว่าง) เปิดเครื่องมือลิงก์โดยกดปุ่มหรือกดแป้นทางลัด พิมพ์ยูอาร์แอลในกล่อง แล้วกดปุ่ม"สำเร็จ" เพื่อแทรกลิงก์

VisualEditor-context menu-link tool.png
ในการเปลี่ยนแปลงหรือลบลิงก์ที่มีอยู่แล้ว กดภายในข้อความสำหรับลิงก์นั้น แล้วกดสัญรูป "ลิงก์" ซึ่งปรากฏอยู่ใกล้เคียง จะปรากฏคำโต้ตอบสำหรับแก้ไข คุณยังสามารถไปยังคำโต้ตอบดังกล่าวได้โดยกดทางลัดคีย์บอร์ด Ctrl+K ก็ได้ เมื่อเลือกลิงก์ จะปรากฏโดยมีกรอบสีน้ำเงิน

ในคำโต้ตอบแก้ไขลิงก์ คุณสามารถเปลี่ยนแปลงปลายทางของลิงก์ คุณยังสามารถลบลิงก์ได้โดยกดปุ่ม "ลบออก" ที่อยู่มุมขวาบนของคำโต้ตอบ คุณยังสามารถเปิดเป้าหมายลิงก์ในหน้าต่างอื่นได้โดยกดสำเนาของลิงก์ในกล่องคำโต้ตอบ (เผื่อคุณต้องการตรวจสอบว่าลิงก์ภายนอกนั้นใช้การได้หรือไม่)

หากคุณต้องการออกจากป้ายลิงก์ (ข้อความที่แสดงผลเป็นลิงก์) หรือเขียนต่อหลังจากลิงก์นี้ สามารถกด :

  • เมื่อกดหนึ่งครั้งจะออกจากคำโต้ตอบแก้ไขลิงก์ และวางเคอร์เซอร์ไว้ที่ปลายสุดของส่วนย่อยที่เลือก (กรอบสีน้ำเงินเพื่อแก้ไขส่วนย่อยนี้)
  • เมื่อกดสองครั้งจะวางเคอร์เซอร์ไว้หลังส่วนย่อยที่ลิงก์ พร้อมกรอกข้อความที่เหลือ

ในการแก้ไขป้ายลิงก์สำหรับลิงก์ที่มีอยู่ ให้กดภายในป้ายลิงก์แล้วกรอกป้ายใหม่ แต่ห้ากคุณต้องการเปลี่ยนทั้งป้าย กรุณาทราบว่า:

  • หากคุณเลือก (เน้น) ป้ายลิงก์ทั้งหมด การพิมพ์แป้นใด ๆ จะเป็นการลบลิงก์ คุณอาจต้องเชื่อมโยงใหม่ตั้งแต่ต้น
  • ในการเก็บลิงก์โดยตรง คุณอาจกดภายในป้ายลิงก์นั้น กดย้อนกลับและลบแป้นโดยไม่กดมากกว่าจำเป็นหนึ่งครั้ง แล้วจะยังเหลือบริเวณลิงก์สีน้ำเงินแคบ ๆ ตรงนั้น ตอนนี้คุณสามารถพิมพ์ป้ายใหม่สำหรับลิงก์ที่เก็บไว้ได้
  • คุณยังสามารถเชื่อมโยงไปหมวดหมู่ ไฟล์ และอื่น ๆ

การแก้ไขแหล่งอ้างอิง

For further information, see คำอธิบายการใช้แม่แบบยกแหล่งที่มา หรือคำอธิบายการใช้ปุ่ม Cite ของไซทอยด์

การดูว่าใช้ระบบใด

วิกิของคุณอาจใช้ระบบเชิงอรรถหนึ่งในสามระบบ ระบบที่แสดงด้านขวามือเป็นระบบง่ายสุด โดยที่รายการเลือก "อ้างอิง" ไม่รวมแม่แบบยกแหล่งที่มาใด หากวิกิของคุณใช้ระบบนี้ คุณจำเป็นต้องทราบเกี่ยวกับเชิงอรรถเฉพาะเท่าที่อยู่ในหน้านี้
VisualEditor cite menu default.png

ระบบที่สองมีรายการเลือก "อ้างอิง" ประเภทเดียวกัน แต่มีแม่แบบยกแหล่งที่มาที่ได้รับความนิยมหลายแม่แบบสำหรับเข้าถึงได้อย่างรวดเร็ว หากวิกิของคุณใช้ระบบนี้ รายละเอียดเพิ่มเติมจะอยู่ที่ Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button-en.png
ในระบบที่สาม คุณเริ่มจากการกดปุ่ม Cite เช่นกัน จะปรากฏกล่องคำโต้ตอบซึ่งมีกระบวนการยกแหล่งที่มาอัตโนมัติโดยใช้บริการไซทอยด์ หากวิกิของคุณใช้ระบบนี้ รายละเอียดเพิ่มเติมจะอยู่ที่ Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

แก้ไขแหล่งอ้างอิงที่มีอยู่

ในการแก้ไขแหล่งอ้างอิงที่มีอยู่แล้ว ให้กดที่แหล่งอ้างอิงนั้นที่ปรากฏในข้อความ (ปกติเป็นเลขในวงเล็บเหลี่ยม) คุณจะเห็นสัญรูป "แหล่งอ้างอิง" (ที่คั่นหนังสือ) หรือสัญรูป (และชื่อ) สำหรับแม่แบบที่ใช้สร้างแหล่งอ้างอิงนั้น ทั้งสองกรณี เมื่อกดปุ่ม "แก้ไช" จะเปิดคำโต้ตอบให้คุณแก้ไขแหล่งที่มา
VisualEditor - Editing references 1.png

สำหรับสัญรูป "แหล่งอ้างอิง" เมื่อกด "แก้ไข" จะเป็นการเปิดคำโต้ตอบอ้างอิง การเปลี่ยนแปลงสารนิเทศแหล่งอ้างอิงให้เริ่มจากกดปุ่ม

หลายวิกิใช้แม่แบบในการจัดรูปแบบแหล่งอ้างอิงในมาตรฐานที่แตกต่างกัน คุณจะสังเกตได้เมื่อคุณแก้ไขแหล่งอ้างอิงที่มีอยู่และพบว่าเนื้อหาข้อความอ้างอิงเปลี่ยนเป็นสีฟ้าเมื่อคุณเลือกมัน

หากใช้แม่แบบและคุณกดสารนิเทศอ้างอิง จะปรากฏสัญรูป Template (ชิ้นส่วนจิ๊กซอว์) พร้อมกับสารนิเทศบางส่วน เมื่อกดปุ่ม "แก้ไข" จะแก้ไขเนื้อหาของแม่แบบนั้นในคำโต้ตอบเครื่องมือแก้ไขแม่แบบขนาดย่อม

VisualEditor - Editing references 6.png

If what appears when you press on a reference is an icon for a standard template for citations (an example is at right), then pressing "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, press on "เพิ่มข้อมูลอีก" at the bottom of the mini-editor.
VisualEditor - Editing references 5.png

คลิกที่ "ใช้การเปลี่ยนแปลง" เมื่อคุณเสร็จแล้ว
VisualEditor Apply Changes-en.png

การใช้ซ้ำแหล่งอ้างอิงที่มีอยู่

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

To re-use an existing reference, place your cursor in the body of the text where you want to add a new reference (number) for that citation. Then press on the "Re-use reference" item from the "อ้างอิง" menu.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "อ้างอิง" menu.)

VisualEditor Cite menu re-use.png

In the อ้างอิง dialog, look at the list for the reference you want to reuse, and select it. If there are many references, you can use the search box (labeled "ค้นหาภายในแหล่งอ้างอิงปัจจุบัน") to list only those references that include certain text.
VisualEditor - Editing references 18.png

Adding a new reference

To add a citation using the "อ้างอิง" menu, place your cursor where you want to add it in the text. Then select the appropriate citation type in the menu.
VisualEditor references more.png

Using the "Basic" citation

Shown here is what you will see if you select the basic references item. In the Reference editor, you can add your citation, including formatting.

You can make the reference belong to a given group, although normally this is left blank. (This option is used to display groups of references with the "รายการอ้างอิง" tool.)

VisualEditor - Editing references 20.png

In the Reference dialog, if you want to include a citation template, or any other template, in your new reference, press the Template icon (puzzle piece) in the "แทรก" toolbar menu within the Reference editor.
VisualEditor Template Insert Menu-th.png

Then, look for the template you want to use, add it and edit it as you would any other template. (See the Editing templates section, below, if you need more information about templates.)

After you are done editing your new template, press on "ใช้การเปลี่ยนแปลง" to return to the Reference editor, and "ใช้การเปลี่ยนแปลง" again to return to the page you are editing.

VisualEditor - Editing references 9.png

If there isn't already a list of references on the page (for example, if you are adding the first reference for the page), you need to specify where the list of references, and their text, will be displayed to the reader.

Place the cursor where you want to display the references list (usually at the bottom of the page), open the "แทรก" menu and press the "รายการอ้างอิง" icon (three books).

VisualEditor References List Insert Menu-th.png

If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed on the page at the location where you are placing the group.

The final step in the References list dialog is to press "แทรก".

VisualEditor references list-th.png

Using standard cite templates

Your local wiki may have added extra citation templates to the "อ้างอิง" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool .)
VisualEditor - Editing References - Cite Pulldown.png

Pressing on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and press on the "เพิ่มข้อมูลอีก" option.

Press on "แทรก" when you are done.

VisualEditor - Editing references - Add parameter.png

Editing images and other media files

Editing images

การเพิ่มภาพใหม่ (หรือไฟล์สื่ออื่นๆ) ลงในหน้า คลิกที่ไอคอน "Media" (รูปภูเขา) ในแถบเครื่องมือ
VisualEditor Media Insert Menu-th.png

การคลิกไอคอน "สื่อ" จะเปิดหน้าต่างสำหรับค้นหาไฟล์สื่อจากวิกิมีเดียคอมมอนส์ที่เกี่ยวข้องกับหน้าที่คุณแก้ไขอยู่

คุณอาจหาไฟล์สื่ออื่นๆ โดยการเปลี่ยนข้อความในกล่องค้นหา

คลิกที่รูปย่อเพื่อเลือกไฟล์

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

After the image you selected is inserted into the page, another dialog will open. This dialog allows you to add and edit the caption of the image. The caption can contain formatting and links.
VisualEditor - Media editing 6.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
VisualEditor - Media editing 7.png

You can also set various parameters for the image in the "การตั้งค่าขั้นสูง" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

เมื่อคุณเสร็จแล้ว คลิก "ใช้การเปลี่ยนแปลง" เพื่อปิดหน้าต่างและย้อนกลับไปสู่ตัวแก้ไขหน้า
VisualEditor Apply Changes-en.png

For an existing image, you can add or edit a caption or other settings by pressing on the image, then pressing on the "สื่อ" icon that appears below the picture.

You can resize an existing image by pressing on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog, or by dragging and dropping a file into the editor, or by pasting an image from your clipboard.
VisualEditor - Media upload 1.png

Press the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.png

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.png

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Editing media galleries

To add a new gallery, press the "Gallery" icon (a set of photos) on the "แทรก" menu. (If you don't see this icon on that menu, then your local wiki has decided to delay implementing this functionality in the visual editor.)
VisualEditor - Gallery1.png

To edit an existing gallery in the visual editor, press that gallery. Then, near the bottom of the gallery, press the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you press the "สำเร็จ" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not publish your changes. As with other changes made using the visual editor, you must publish the entire page in order to publish your work.

VisualEditor - Gallery3.png

Editing templates

Starting

To add a new template to a page, place your cursor where you want the template to be inserted, and press on the "Template" icon (puzzle piece) in the "แทรก" menu.
VisualEditor Template Insert Menu-th.png

Start typing the name of the template you want to insert. When you see it on the list, press on its name. Then press "เพิ่มแม่แบบ".
VisualEditor - Template editing 4.png

You can also edit a template that is already on the page. When you press on the template to select it, it turns blue, and a box appears with an "Template" icon (puzzle piece). Then press on the "แก้ไข" link.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the "ใช้แม่แบบ" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

For an existing template, you can edit the parameters shown in the dialog, and you can add parameters by pressing "เพิ่มข้อมูลอีก", at the very bottom of the dialog.
VisualEditor - Template editing 3.png

When a template embeds other templates, these sub-templates will appear inside the parameters that display them. They can be edited or removed inside the parameter field.

New sub-templates are added by following the steps for adding a parameter. You may need to check the template documentation to make sure that the sub-template is supported. Nested templates can currently be edited as wikitext only, without the facility offered by VisualEditor (see phab:T52182).

VisualEditor - Template editing 5.png

Finishing

When you have finished editing a template, press "ใช้การเปลี่ยนแปลง" to close the dialog and return to editing the main page.
VisualEditor Apply Changes-en.png

Substituting templates

When a template must be substituted, type subst: (colon included) before the template's name.

Autocompletion doesn't work with subst:. If you want to use autocompletion, first find the template you are looking for, and then add subst: in front of the template name.

Then, press the blue "เพิ่มแม่แบบ" button.

Add any parameters as usual and press "แทรก".

VisualEditor - Template editing 7.png

You will see the template expand on the page after you press "ใช้การเปลี่ยนแปลง".
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-th.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just press on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then press on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editing tables

VisualEditor insert table-th.png
You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you press on "Table", in the "แทรก" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, press it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double press in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just press elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, press on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Editing categories

VisualEditor category item-th.png
To edit categories, on the "ตัวเลือกหน้า" menu, press the "หมวดหมู่" item.

VisualEditor category editing-en.png
Pressing on "หมวดหมู่" opens a dialog that lists existing categories and allows you to add new ones, and to delete existing categories.

You also have the option of setting or changing the general (default) sorting key, which determines where the page appears when listed with other pages in the same category.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
To add a category for a page, type the name of the category into the field "เพิ่มหมวดหมู่". As you type, the visual editor will search for possible matching, existing categories. You can either select an existing category, or you can add a category that doesn't yet have its own category page. (Until that category page is created, your new category will show as a red link after you publish all your editing changes.)

VisualEditor - Category editing 2.png
To remove an existing category, press on it and press on the "ลบออก" icon (trash can) in the dialog that opens.

Pressing on a category also allows you to specify a sorting key for that specific category. Such a sorting key overrides the default sorting key.


VisualEditor Apply Changes-en.png
Press "ใช้การเปลี่ยนแปลง" when you are done editing categories to return to the page editor.

Editing page settings

VisualEditor page settings item-th.png
To edit a page's settings, press to open the "ตัวเลือกหน้า" menu, in the toolbar, and select the "การตั้งค่าหน้า" button.

VisualEditor Page Settings-en.png
The "การตั้งค่าหน้า" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-en.png
You can make a page a redirect to another page by checking the "Redirect this page to" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you are editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-en.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "If needed", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-en.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-en.png
Press "ใช้การเปลี่ยนแปลง" when you are done editing the ตัวเลือกหน้า to return to the page editor.

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Editing mathematical formulae

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and press on the "สูตรคณิตศาสตร์" icon ("Σ") in the "แทรก" menu on the toolbar.
VisualEditor Formula Insert Menu-th.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, press the "แทรก" button.
VisualEditor formula-th.png

To edit an existing mathematical formula on the page, press on it and then press on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, press the "Musical notation" option.

To edit an existing musical notation on the page, double press on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, press the "Done" button to close the dialog and publish your changes.
Musical.png

Editing poems and other special items

Some items, such as association lists and poems, are not yet fully supported by the visual editor.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, press the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll press on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, press the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you press the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you press "Keep changes", you'll go to the visual editor. If you press "Discard changes", you'll be asked to confirm that is what you want to do (press on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

ทางลัดบนคีย์บอร์ด

Many editors are used to entering wikitext directly, especially bold, italics and wikilinks. Keyboard shortcuts allow to quickly insert similar formatting without having to use toolbar items. Here are the common general shortcuts in the visual editor:

PC shortcut Action Mac shortcut

Ctrl+B ตัวหนา Cmd+B

Ctrl+I ตัวเอียง Cmd+I

Ctrl+K เพิ่มลิงก์ Cmd+K

Ctrl+X ตัด Cmd+X

Ctrl+C คัดลอก Cmd+C

Ctrl+V วาง Cmd+V

Ctrl+Z Undo Cmd+Z