Open main menu

ダウンロード

This page is a translated version of the page Download and the translation is 100% complete.

Other languages:
Bahasa Banjar • ‎Bahasa Indonesia • ‎Bahasa Melayu • ‎Basa Banyumasan • ‎Cymraeg • ‎Deutsch • ‎English • ‎Hausa • ‎Ido • ‎Lëtzebuergesch • ‎Mirandés • ‎Nederlands • ‎Scots • ‎Tagalog • ‎Taqbaylit • ‎Tarifit • ‎Tiếng Việt • ‎Türkçe • ‎Zazaki • ‎aragonés • ‎bosanski • ‎brezhoneg • ‎català • ‎dansk • ‎eesti • ‎español • ‎euskara • ‎français • ‎galego • ‎hrvatski • ‎interlingua • ‎italiano • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎occitan • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎slovenčina • ‎slovenščina • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎беларуская • ‎български • ‎русский • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎עברית • ‎ئۇيغۇرچە / Uyghurche • ‎العربية • ‎جهلسری بلوچی • ‎سنڌي • ‎فارسی • ‎پښتو • ‎کوردی • ‎अङ्गिका • ‎नेपाली • ‎मराठी • ‎मैथिली • ‎हिन्दी • ‎বাংলা • ‎মেইতেই লোন্ • ‎தமிழ் • ‎ಕನ್ನಡ • ‎മലയാളം • ‎සිංහල • ‎ไทย • ‎ဘာသာ မန် • ‎မြန်မာဘာသာ • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎吴语 • ‎日本語 • ‎粵語 • ‎조선말 • ‎한국어

最新リリース

 
MediaWiki の歩き方

コンテンツ


その他すべての話題

  • 左側のナビゲーションをご利用ください

ライセンス

MediaWiki は、GNU General Public License バージョン 2 のもとで利用許諾されるフリー ソフトウェアです。MediaWiki は無料で利用許諾されるため、適用される法律が許す範囲内で、一切の保証はありません。詳しくは GNU GPL バージョン 2 の全文をお読みください。

システム要件

MediaWiki には PHP 7.0.0 以降に加え、MySQL 5.5.8+、MariaDB、または 3 種類のデータベース ソフトウェアのうちのいずれか、が必要です。更なる情報については、システム要件互換性の各ページをお読みください。

その他のダウンロード

Gitからのダウンロード

MediaWiki のアクティブな開発者は、MediaWiki ソフトウェアの最新版をGit からダウンロードすべきです。 Git リポジトリには、ソフトウェアの以前のバージョンも格納されていて、特定のリリースに切り替える (checkout する) ことができます。

注記

PHP のディレクティブ register_globalsMediaWiki 1.24 で廃止されました。あなたのサーバにインストールされている PHP が 5.4 以降であった場合、この件について心配する必要はありません。もし PHP のバージョンが 5.3 以前であった場合、このディレクティブに関する設定が「OFF」になっていることを確認してください。もしあなたのシステムで register_globals を off に設定できない場合は、MediaWiki 1.23.9 (ダウンロード) お使いください。

MediaWiki 1.19 以降には MySQL/MariaDB 5 の機能が必須です。 – MySQL の古いバージョンを使用していて、かつアップグレードできない場合は、MediaWiki 1.18.6 (ダウンロード) を使用できます。このバージョンはサポート対象外であることにご注意ください。

手動インストールの代替手段

統合済みの MediaWiki ソフトウェア アプライアンスホスティング サービスを使用したいユーザーもいるでしょう。一部の Linux ディストリビューションでは MediaWiki 向けのパッケージも提供していますが、更新頻度や拡張機能の収録範囲はそれぞれ異なります (例: Debian、Ubuntu、Fedora、Gentoo)。

次は?

最新情報に追随して、あなたのサーバーを安全に保ちましょう!

旧版リリース

MediaWiki インストールを大きく変更している場合は、最新の公式版の MediaWiki の変更/更新を反映させるのが難しい場合があります。そのような利用者を支援するために、旧版リリースを最大1年間、旧版 LTS リリースを最大3年間、保守します。

開発者向けリリース

最新の開発版 (つまり、アルファ版) を使用したい場合は、アワリーからダウンロードするか、または Git からダウンロードしてください。

Git から以下のいずれかをダウンロードできます: 完全なリポジトリ (約 528 MiB)

git clone https://gerrit.wikimedia.org/r/mediawiki/core.git

または、最新リビジョンのみ (約 85 MiB。これはよく shallow clone と呼ばれます: ダウンロード時間が短くてサイズが小さいです)。[1]

git clone --depth 1 https://gerrit.wikimedia.org/r/mediawiki/core.git

ブラウザーで最新のソースコードを閲覧することもできます。

以前のリリース

MediaWiki ダウンロード アーカイブを見ると2005年3月 (最古は MediaWiki 1.3.11) までさかのぼって、MediaWiki のすべてのバージョンの tarball (拡張子 *.tar.gz) を探せます。

古いバージョンも含めてブラウズするには、Git リポジトリのタグを参照してください。

インストール支援

脚注

  1. 後に "git pull" を使ってあなたの shallow clone をアップグレードしたり、まだあなたのシステムにダウンロードされていない古いリビジョンを新しいリビジョンが参照したりする際に、これは参照問題を起こす可能性があります。そのような場合は、単により多い(depth 値を増やす)あるいはすべてのリビジョンを後でダウンロードするか、新しい shallow clone を作ります。

関連項目