Open main menu

Descàrrega

This page is a translated version of the page Download and the translation is 90% complete.

Outdated translations are marked like this.
Other languages:
Bahasa Banjar • ‎Bahasa Indonesia • ‎Bahasa Melayu • ‎Basa Banyumasan • ‎Cymraeg • ‎Deutsch • ‎English • ‎Hausa • ‎Ido • ‎Lëtzebuergesch • ‎Mirandés • ‎Nederlands • ‎Scots • ‎Tagalog • ‎Taqbaylit • ‎Tarifit • ‎Tiếng Việt • ‎Türkçe • ‎Zazaki • ‎aragonés • ‎bosanski • ‎brezhoneg • ‎català • ‎dansk • ‎eesti • ‎español • ‎euskara • ‎français • ‎galego • ‎hrvatski • ‎interlingua • ‎italiano • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎occitan • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎slovenčina • ‎slovenščina • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎беларуская • ‎български • ‎русский • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎עברית • ‎ئۇيغۇرچە / Uyghurche • ‎العربية • ‎جهلسری بلوچی • ‎سنڌي • ‎فارسی • ‎پښتو • ‎کوردی • ‎अङ्गिका • ‎नेपाली • ‎मराठी • ‎मैथिली • ‎हिन्दी • ‎বাংলা • ‎মেইতেই লোন্ • ‎தமிழ் • ‎ಕನ್ನಡ • ‎മലയാളം • ‎සිංහල • ‎ไทย • ‎ဘာသာ မန် • ‎မြန်မာဘာသာ • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎吴语 • ‎日本語 • ‎粵語 • ‎조선말 • ‎한국어

Últimes versions


Llicència

MediaWiki és programari lliure llicenciat sota la versió 2 de la GNU General Public License. Atès que MediaWiki està llicenciat lliure de costos, no té cap garantia, fins a l'extrem permès per la llei aplicable. Llegiu el text complet de la llicència GNU GPL versió 2 per a detalls.

Requisits del sistema

MediaWiki requereix PHP 7.0.0+ i MySQL 5.5.8+, MariaDB o un altre dels tres possibles gestors de bases de dades. Per a més informació, llegiu les pàgines de requisits del sistema i compatibilitat.

Altres descàrregues

Descàrrega alternativa amb Git

Els desenvolupadors actius de MediaWiki alternativament i recomanadament haurien de descarregar des de Git per aconseguir la versió del programari MediaWiki. El repositori git conté versions antigues del programari, així que és possible canviar ("per donar un cop d'ull") a una versió en concret.

Notes

  • Es requereix PHP 5 des de MediaWiki 1.7 - Si utilitzeu PHP 4, l'heu d'actualitzar ara! PHP 4 ja no funciona amb el grup PHP i té molts errors i vulnerabilitats. Molts proveïdors d'allotjament compartit ofereixen tant PHP 4 com PHP 5, simultàniament. Si no la podeu actualitzar, podeu utilitzar MediaWiki 1.6.12 (descarregar). Tingues en compte que ja no es dóna suport a aquesta versió.

Es requereix MySQL/MariaDB 5 des de MediaWiki 1.19 - Si esteu usant una versió anterior de MySQL i no la podeu actualitzar, podeu utilitzar MediaWiki 1.18.6 (descarregar). Tingueu en compte que ja no es dóna suport a aquesta versió.

Alternatives a la instal·lació manual

Alguns usuaris prefereixen saltar-se la instal·lació manual usant un MediaWiki pre-integrat en dispositius de programes d'aplicacions o serveis d'allotjament; cada vegada més distribucions Linux ofereixen en els seus repositoris paquets per MediaWiki, amb diferents graus de freqüència i cobertura de les extensions (Debian, Ubuntu, Fedora i Gentoo entre d'altres).

Propers passos

Estigueu informat sobre les noves actualitzacions i mantingueu el vostre servidor segur!

Versions prèvies

Si heu modificat molt la vostra instal·lació MediaWiki, pot ser difícil incorporar els canvis i actualitzacions oficials de MediaWiki. Per donar suport a aquests usuaris, manteniu branques prèvies del nostre codi durant 1 any per a la versió previa i fins a 3 anys per al versió previa de suport a llarg termini.

Versions de desenvolupament

Si desitgeu utilitzar l'última versió en desenvolupament (és a dir, la versió alfa), podeu descarregar-la des de Hourlies o des de Git.

Des de Git podeu baixar-ne o bé el repositori complet (uns 528 MiB)

git clone https://gerrit.wikimedia.org/r/mediawiki/core.git

o bé només l'última versió del repositori (uns 85 MiB; això és el que es coneix normalment com un clon superficial: mida i temps de descàrrega menors).[1]

git clone --depth 1 https://gerrit.wikimedia.org/r/mediawiki/core.git

També podeu veure'n el latest codi font al navegador.

Versions antigues

Pots trobar paquets (amb l'extensió *.tar.gz) de totes les versions de MediaWiki fins al març del 2005 (la més antiga és MediaWiki 1.3.11) en els arxius de descàrrega de MediaWiki.

Per navegar pel codi, incloent versions més antigues, vegeu les etiquetes del repositori Git.

Assistència d'instal·lació

Referències

  1. Això pot causar problemes de referència més endavant, quan empreu "git pull" per actualitzar el vostre clon superficial i la versió nova es refereix a alguna versió més antiga que encara no s'ha descarregat al vostre sistema. En aquest cas, podeu solucionar-ho simplement descarregant més (incrementant el valor de profunditat) o totes les versions més endavant, o fent un clon superficial nou.

Vegeu també