Ajuda:Extensão:Translate/Instalação

This page is a translated version of the page Help:Extension:Translate/Installation and the translation is 47% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎Deutsch (Sie-Form) • ‎English • ‎Kiswahili • ‎Lëtzebuergesch • ‎Nederlands • ‎Türkçe • ‎Zazaki • ‎català • ‎dansk • ‎español • ‎français • ‎italiano • ‎lietuvių • ‎polski • ‎português • ‎português do Brasil • ‎slovenčina • ‎svenska • ‎čeština • ‎русский • ‎українська • ‎العربية • ‎हिन्दी • ‎বাংলা • ‎中文 • ‎日本語 • ‎한국어

A extensão Translate, devido à sua natureza de rápido desenvolvimento, requer uma versão relativamente recente do MediaWiki para funcionar. O objetivo é suportar a versão de desenvolvimento e as duas versões estáveis ​​mais recentes do MediaWiki. Nos gestores de pacotes, a versão poderá ser demasiada antiga para corresponder com os requisitos. Nesse caso, precisa de transferir uma versão mais recente em mediawiki.org ou do repositório Git da Wikimedia. The aim is to support the development version and the two latest stable versions of MediaWiki. In package managers, the version may be too old to fulfill the requirements. In that case you need to download a newer release from mediawiki.org or from Wikimedia's Git repository.

A extensão Translate utiliza um modelo de desenvolvimento contínuo, o que significa que a versão mais recente nunca deverá estar totalmente quebrada, porque todas as modificações na extensão Translate são revistas por pares e passam por testes de unidade. A principal funcionalidade é bastante estável, mas poderá haver alterações maiores ao longo do tempo. The core functionality is pretty stable, but there may be bigger changes from time to time.

Requisitos

É necessário o seguinte "software" para instalar esta extensão:

  1. Versão recente do MediaWiki
  2. Base de dados MySQL – SQLite (experimental)
  3. Extensão 'Seletor de Idioma Universal' (incluída no MediaWiki Language Extension Bundle)
  4. (opcional) PHPlot para gráficos de estatísticas
  5. (opcional) Syck ou phpyaml para uma análise e geração melhor e mais rápida do YAML
  6. (opcional) ElasticSearch para funcionalidades de pesquisa avançada e memória de tradução
  7. (opcional) Acesso à Internet no servidor para os serviços de tradução automática
PHP deve estar instalado com o módulo "curl" para permitir a funcionalidade de sugestão de tradução.

MediaWiki precisa de ter a configuração de fila de trabalhos correta. Se a sua fila de trabalhos não for processada, não irá funcionar nada no Translate.

Além disso, é necessário acesso ao shell para executar scripts de manutenção.

A utilização de memcached para a colocação em cache e por exemplo, acelerador APC PHP é recomendado num ambiente de produção.

Instruções de instalação

Vá para Pacote de Extensão de Idioma MediaWiki para obter links de download e instruções. O pacote inclui extensões adicionais comumente usadas junto com a extensão Translate. Também inclui uma configuração padrão funcional para você começar. The bundle includes additional extensions commonly used together with the Translate extension. It also includes a functioning default configuration to get you started. Consulte Ajuda:Extensão:Translate/Configuração para uma descrição destas configurações.