Ayuda:Extensión:Translate/Instalación

This page is a translated version of the page Help:Extension:Translate/Installation and the translation is 37% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎Deutsch (Sie-Form) • ‎English • ‎Kiswahili • ‎Lëtzebuergesch • ‎Nederlands • ‎Türkçe • ‎Zazaki • ‎català • ‎dansk • ‎español • ‎français • ‎italiano • ‎lietuvių • ‎polski • ‎português • ‎português do Brasil • ‎slovenčina • ‎svenska • ‎čeština • ‎русский • ‎українська • ‎العربية • ‎हिन्दी • ‎বাংলা • ‎中文 • ‎日本語 • ‎한국어

La extensión Translate, debido a su naturaleza de desarrollo rápido, requiere una versión relativamente reciente de MediaWiki para funcionar. El objetivo es soportar la versión en desarrollo y las dos últimas versiones estables de MediaWiki. En los gestores de paquetes, la versión puede ser demasiado vieja para cumplir los requisitos. En ese caso, es necesario descargar una nueva versión desde mediawiki.org o desde el repositorio Git de Wikimedia. The aim is to support the development version and the two latest stable versions of MediaWiki. In package managers, the version may be too old to fulfill the requirements. In that case you need to download a newer release from mediawiki.org or from Wikimedia's Git repository.

La extensión Translate utiliza un modelo de desarrollo continuo, lo que significa que la última versión nunca debería estar totalmente rota, porque todas los cambios de la extensión Translate son revisados ​​por pares y pasan las pruebas unitarias. La funcionalidad básica es bastante estable, pero puede haber cambios más grandes de vez en cuando. The core functionality is pretty stable, but there may be bigger changes from time to time.

Requisitos

El siguiente software se requiere para instalar esta extensión:

  1. Versión reciente de MediaWiki
  2. Base de datos MySQL – SQLite (experimental)
  3. La extensión Universal Language Selector (incluida en MediaWiki Language Extension Bundle)
  4. (opcional) PHPlot para gráficos de estadísticas
  5. (opcional) Syck para "parseo" rápido de YAML
  6. (opcional) Instancia Solr para funcionalidades de búsqueda avanzada
  7. (opcional) Acceso a internet en el servidor para los servicios de traducción automática
PHP must be installed with the curl module to allow for the translation suggestion feature.

MediaWiki needs to have the job queue set up correctly. If your job queue is not processed, nothing will work in Translate.

Además, se requiere acceso a la línea de comandos para ejecutar scripts de mantenimiento.

Para un ambiente de producción se recomienda el uso de memcached para "cachear" y, por ejemplo, el acelerador de PHP "APC".

Instrucciones de instalación

Véase MediaWiki Language Extension Bundle para enlaces e instrucciones de descarga. El paquete incluye algunas de las extensiones más comúnmente usadas junto con la extensión Translate. También incluye una configuración útil predeterminada para empezar. The bundle includes additional extensions commonly used together with the Translate extension. It also includes a functioning default configuration to get you started. Véase Ayuda:Extensión:Translate/Configuración para una descripción de estas opciones.