Open main menu

Manual:Extensii

This page is a translated version of the page Manual:Extensions and the translation is 99% complete.

Other languages:
Bahasa Indonesia • ‎Bahasa Melayu • ‎Deutsch • ‎English • ‎Mirandés • ‎Türkçe • ‎dansk • ‎español • ‎français • ‎italiano • ‎magyar • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎čeština • ‎Ελληνικά • ‎български • ‎русский • ‎العربية • ‎سنڌي • ‎پښتو • ‎ไทย • ‎中文 • ‎日本語 • ‎한국어
Gnome-preferences-other.svg Extensions: Development Tag extensions Parser functions Hooks Special pages Skins Magic words API Content models

Ce sunt extensiile?

Extensiile pentru MediaWiki

Extensiile vă permit să personalizați modul în care MediaWiki arată și funcționează.

Utilizatorii Wiki pot naviga prin extensiile existente sau cere o nouă extensie. Administratorii de sistem pot extinde instala (sau elimina) extensiile instalărilor MediaWiki pe care le administrează. Dezvoltatorii pot scrie noi extensii sau îmbunătăți sau întreține extensiile actuale.

Căutați extensiile după cuvântul cheie(e):

Contents

În funcție de obiectivele dvs., puteți utiliza extensiile pentru:

extindeți marcajul wiki folosit pentru a scrie articole - vedeți Category:Parser function extensions și Category:Parser extensions pentru exemple.

În timp ce unele extensii sunt menținute de dezvoltatorii MediaWiki, altele au fost scrise de dezvoltatori terți. Ca rezultat, mulți au bug-uri, și nu toate sunt garantate a fi compatibile unul cu celălalt. Unele sunt neîntreținute; nu toate extensiile funcționează pe toate versiunile de MediaWiki. Utilizați orice extensie, în special cele marcate ca nesigure, pe propriul dvs. risc. Când utilizați o extensie care necesită patch-uri pentru codul sau intrările din baza de date MediaWiki din baza de date, asigurați-vă că creați o copie de rezervă a bazei dvs. de date și/sau a codului de bază al MediaWiki, pentru a evita riscul ruperii permanente a wiki-ului.

Extensiile de navigare

Puteți căuta Categorie:Extensii după categorie pentru a vedea întreaga gamă de extensii care au fost deja scrise. Pentru informații despre instalarea acestor extensii sau despre scrierea propriilor dvs., vedeți mai jos.

Verificarea extensiilor instalate

Numai cineva cu acces administrativ la sistemul de fișiere (și adesea și baza de date) pe un server poate instala extensii pentru MediaWiki, dar oricine poate verifica ce extensii sunt active pe o instanță a MediaWiki prin accesarea Special:Version page. De exemplu, aceste extensii sunt active în Wikipedia engleză.

Instalarea unei extensii

MediaWiki este gata să accepte extensii imediat după finalizarea instalarea. Pentru a adăuga o extensie, urmați acești pași:

  1. Înainte de a începe
    Multe extensii oferă instrucțiuni destinate instalării folosind comenzi unix. Aveți nevoie de accesul shell (SSH) pentru a introduce aceste comenzi afișate pe paginile de ajutor pentru extensii.
  2. Descărcați extensia.
    Distribuitor Extensie vă ajută să selectați și să descărcați majoritatea extensiilor populare.
    Extensiile sunt de obicei distribuite ca pachete modulare. În general, aceștia merg în propriul lor subdirector de $IP /extensions/. O listă de extensii stocate în depozitul Wikimedia Git repository este localizată la git:mediawiki/extensions. Unele extensii nu folosesc controlul versiunii și nu sunt recomandate.
    Unele extensii sunt de asemenea disponibile în bundles, composer sau package repositories.
  3. Instalați extensia..
    În general, la sfârșitul fișierului LocalSettings.php (dar deasupra limbajului de limită PHP, ?>", dacă este prezent), se adaugă următorul rând:
    // mw.v 1.24.x or less
    require_once "$IP/extensions/extension_name/extension_name.php";
    // mw.v 1.25.x or above
    wfLoadExtension( '<extension-name>' );
    
    Această linie forțează interpretul PHP să citească fișierul de extensie și astfel să îl acceseze pentru MediaWiki.
    Unele extensii pot intra în conflict cu scripturile de întreținere, de exemplu dacă accesează direct $_SERVER (nu se recomandă).
    În acest caz, ele pot fi înfășurate în condiționat, astfel încât scripturile de întreținere pot fi încă executate.
//for mw.v 1.24.x or less
if ( !$wgCommandLineMode ) {
   require_once "$IP/extensions/extension_name/extension_name.php";
}
//for mw.v 1.25.x or above
if ( !$wgCommandLineMode ) {
   wfLoadExtension ( '<extension-name>' );
}
Scriptul de întreținere importDump.php va eșua pentru orice extensie care necesită spațiu de nume personalizat care este inclus în interiorul condiționalului de mai sus, cum ar fi Extension:Semantic MediaWiki , Extension:Semantic Forms .
Asigurați-vă că permisiunile necesare sunt setate pentru extensii!
În timp ce această procedură de instalare este suficientă pentru majoritatea extensiilor, unele necesită o altă procedură de instalare. Verificați documentația extensiei pentru detalii.
Dacă doriți să modificați variabilele de configurare în LocalSettings.php, trebuie să faceți acest lucru de obicei după, inclusiv extensia. În caz contrar, valorile implicite definite în extensie vor suprascrie setările.
  Caution: În timp ce declararea extensiei poate fi plasată în alte locații din fișierul LocalSettings.php, extensiile niciodată nu plasează extensiile înainte de linia de require_once "includes/DefaultSettings.php"; pentru versiunile MediaWiki sub 1.17. În acest fel, se vor șterge matricele funcției de configurare a extensiei, fără a se instala extensii și, probabil, vor face ca wiki-ul dvs. să fie inaccesibil până când îl rezolvați!


Actualizarea unei extensii

Unele extensii trebuie să fie actualizate ori de câte ori actualizați MediaWiki, în timp ce altele lucrează cu mai multe versiuni. Pentru a trece la o versiune nouă a unei extensii:

  1. Descărcați noua versiune a extensiei
  2. Înlocuiți toate fișierele de extensie din directorul extension/ExtensionName cu fișierele noi. Nu eliminați configurația de extensie prezentă în LocalSettings.php
  3. În funcție de extensie, poate fi necesar să rulați scriptul de întreținere Update.php. Majoritatea extensiilor vor menționa dacă acest script trebuie rulat sau nu. (Perform backup of your data before executing the script). Dacă nu aveți acces la linia de comandă, puteți utiliza, de asemenea, web updater.
  4. Asta e tot ce trebuie să faci. În majoritatea cazurilor, orice configurație de extensie pe care o aveți în LocalSettings.php va funcționa, de asemenea, cu versiunea mai nouă a extensiei.
Aceste instrucțiuni acoperă 99% din extensii. Dacă extensia specifică pe care o actualizați are instrucțiuni care diferă de acestea, ar trebui probabil să urmați instrucțiunile de extensie specifică

Dezinstalați o extensie

Extensiile sunt adăugate prin adăugarea unei linii către LocalSettings.php, care în principiu arată astfel:

// mw.v 1.24.x or less
require_once "$IP/extensions/extension_name/extension_name.php";
// mw.v 1.25.x or above
wfLoadExtension( '<extension-name>' );
În funcție de extensia pe care doriți să o dezinstalați, alte lucruri se pot realiza la instalare, pe care doriți să o anulați acum. Pentru detalii, consultați secțiunea privind instalarea unei extensii.
  1. Scoate această linie, iar extensia este dezinstalată. Dacă doriți, puteți (și dacă nu doriți să utilizați această extensie în viitor ar trebui) să eliminați fișierele acestei extensii în interiorul directorului "extensii/".
  2. Puteți avea și alte linii în LocalSettings.php, care au legătură cu extensia pe care doriți să o eliminați. Cel mai probabil vor fi linii care dau anumitor utilizatori dreptul de a accesa paginile furnizate de extensie. Aceste linii conțin variabila "$wgGroupPermissions" și fac unele setări acolo. În măsura în care au de-a face cu drepturile care provin din extensia eliminată, puteți elimina și aceste linii.
  3. Poate că extensia dvs. a adăugat, de asemenea, coloane în baza de date. Întreținerea actualizare/update.php le elimină, atunci când o executați, după ce ați dezinstalat extensia.

Dezvoltarea extensiilor

Acest subiect complex este tratat în pagina de manual dezvoltarea extensiilor.

Vezi şi