Manual:Persyaratan instalasi

This page is a translated version of the page Manual:Installation requirements and the translation is 97% complete.

Setelah mengunduh perangkat lunak MediaWiki, Anda perlu:

Sebagai tambahan, ada berbagai ketergantungan opsional yang dibutuhkan jika Anda ingin menggunakan fitur lanjut tertentu (lihat di bawah).

Jika situs web Anda dihos (Anda tidak mengaturnya secara langsung), hubungi administrator peladen Anda atau perusahaan hosnya untuk memastikan paket-paket perangkat lunak berikut dipasang dan tersedia.

Untuk menjalankan skrip pemeliharaan MediaWiki, Anda akan memerlukan akses baris perintah.

Instalasi satu-kali-unduh sederhana

Jika Anda menggunakan Linux, sebaiknya Anda menginstal server web Apache, PHP, dan server basis data MariaDB menggunakan manajer paket Anda. Di Debian dan Ubuntu, jalankan perintah berikut:

sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql php-calendar mariadb-server apache2

Bundel perangkat lunak

Di sistem operasi lain, gunakan paket perangkat lunak seperti XAMPP dari https://www.apachefriends.org untuk menginstal dan mengonfigurasi semua paket yang penting – peladen web Apache, PHP, dan MariaDB – dengan hanya sekali unduh. XAMPP tersedia di Linux, Windows, Mac dan Solaris. Per Januari 2021, versi terkini XAMPP mengandung PHP 8.0 (MediaWiki memerlukan paling tidak 7.3.19/7.4.3).

Selain itu, jika Anda menggunakan komputer Apple, Anda bisa menggunakan MAMP, yang merupakan ekuivalen XAMPP. MAMP mampu menjalankan peladen web Apache dan sebuah basis data MySQL. MAMP tersedia untuk Windows dan Mac, tetapi umumnya digunakan di Mac bukannya Windows.

Server web

Untuk melayani halaman wiki kepada peramban, MediaWiki memerlukan perangkat lunak peladen web. Biasanya Anda tidak bisa memilih perangkat lunak yang mana yang digunakan – perangkat lunaknya akan disediakan oleh penyedia hos Anda.

MediaWiki kompatibel secara luas dengan semua peladen web besar yang bisa memanggil versi PHP yang kompatibel. Kebanyakan instalasi menggunakan peladen web Apache HTTPD. nginx (contoh konfigurasi) juga merupakan pilihan yang baik.

PHP

PHP adalah bahasa pemrograman yang digunakan untuk menulis MediaWiki, dan diperlukan untuk menjalankan perangkat lunak tersebut.

  • Untuk versi stabil MediaWiki terbaru, diperlukan paling tidak

PHP 7.3.19/7.4.3. Lihat halaman mengenai Kompatibilitas untuk informasi lebih lanjut.

MediaWiki tidak kompatibel dengan PHP 7.4.0 - 7.4.2 dikarenakan sebuah bug di PHP. Use PHP 7.4.3+ instead. Lihat task T246594 untuk informasi lebih lanjut.
Support for PHP 8.0 in MediaWiki is experimental. We are not aware of any issues, but it is not as well tested as PHP 7. PHP 8.1 is not supported. See task T248925 for more information.
  • Ekstensi-ekstensi berikut diperlukan:
  • Perhatikan bahwa semua ini diaktifkan di PHP secara bawaan.
  • Di kebanyakan distro berbasis Debian/Ubuntu, paket php-mysql diperlukan apabila Anda ingin MediaWiki menggunakan MySQL.
  • Beberapa fitur MediaWiki mungkin memerlukan fungsi PHP yang menjalankan proses-proses eksternal, seperti pembuatan thumbnail gambar, yang beberapa hos murah biasanya matikan. Tolong pertimbangkan ini apabila Anda hendak menginstal MediaWiki di sebuah hos bersama.
  • Ekstensi-ekstensi MediaWiki mungkin memerlukan fitur PHP tambahan, contohnya VisualEditor membutuhkan dukungan libcurl (php-curl di distro berbasis Debian/Ubuntu).

Jika Anda perlu menyusun PHP dari sumbernya, lihatlah Konfigurasi PHP untuk pilihan-pilihan kompilasi yang memengaruhi MediaWiki.

Server basis data

MediaWiki menyimpan semua teks dan data (halaman konten, rincian pengguna, pesan sitem, dll.) dalam sebuah basis data, yang harus mampu membagikannya dengan aplikasi berbasis web lainnya (phpBB, dsb.). Anda memerlukan salah satu dari peladen basis data berikut untuk menjalankan versi terbaru MediaWiki:

Using MariaDB or MySQL is recommended as Wikimedia uses MariaDB. Any other database servers are less tested and you may likely run into some bugs.

  Peringatan Since MediaWiki 1.34 , we no longer support using Oracle and Microsoft SQL Server . We strongly advise to no longer to use these.

Beberapa pengguna merasakan kegunaan menginstal perangkat lunak panel kendali tambahan seperti phpMyAdmin (MySQL/MariaDB) atau phpPgAdmin (PostgreSQL) untuk membantu mengelola peladen basis data. Some hosting services also provide such software.

Persyaratan perangkat keras

Persyaratan minimum yang disarankan adalah 256MB RAM untuk sebuah situs web komputer dan 85MB untuk penyimpanan, tetapi ini tidak akan cukup untuk situs publik yang sibuk atau situs yang mengaktifkan pengunggahan. Beberapa pengguna melaporkan MediaWiki dijalankan di komputer dengan RAM sekecil 48MB.

Ukuran instalasi bisa dikurangi menjadi sekitar 50MB untuk instalasi pengembang dan sekitar 26MB untuk instalasi non-pengembang dan pengguna akhir. Lihat Manual:Reduce size of the installation .

Ketergantungan opsional

Lihat pula