Handbuch:Installationsvoraussetzungen

This page is a translated version of the page Manual:Installation requirements and the translation is 89% complete.
Outdated translations are marked like this.

Zusätzlich zu der MediaWiki-Software selbst benötigst du:

Zusätzlich gibt es verschiedene optionale Abhängigkeiten, die relevant werden, wenn du gewisse fortgeschrittene Programmbestandteile einsetzen möchtest (siehe weiter unten).

Wenn deine Website gehostet wird (wenn du z.B. keine direkte Kontrolle über diese hast), setze dich mit dem Systemadministrator oder Hostingunternehmen in Verbindung, um sicherzustellen, dass diese installiert sind.

Um MediaWiki-Wartungsskripte auszuführen, benötigst du Kommandozeilenzugriff.

Installation in einem Download

Wenn du Linux verwendest, installiere am besten den Apache-Webserver, PHP und den MariaDB-Datenbankserver mit deinem Packagemanager. Mache folgendes unter Debian und Ubuntu:

sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql php-calendar mariadb-server apache2

Software-Pakete

Verwende unter anderen Betriebssystemen ein Softwarepaket wie XAMPP von https://www.apachefriends.org zur Installation und konfiguriere alle wichtigen Pakete – Apache-Internetserver, PHP und MariaDB – mit nur einem Download. Dieses ist für Linux, Windows, Mac und Solaris erhältlich. Seit Januar 2021 enthält die neueste XAMPP Version PHP 8.0 (MediaWiki benötigt mindestens 7.3.19/7.4.3).

Alternativ kannst du, wenn du macOS verwendest, MAMP verwenden, welches das Equivalänt zu XAMPP ist. MAMP enthält die Fähigkeit einen Apache-Internetserver und eine MySQL-Datenbank laufen zu lassen Es ist sowohl für Windows als auch für Mac verfügbar, wird aber eher auf Mac als auf Windows verwendet

Webserver

Um die erzeugten Wikiseiten Browser anzubieten, benötigt MediaWiki eine Webserver-Software. Häufig wirst du keine Wahl haben, welche Software du verwendest; es wird die eine vom Hosting-Provider angebotene sein.

MediaWiki is broadly compatible with all major web servers that can invoke a compatible version of PHP. Die meisten Installationen verwenden den Apache HTTPD-Webserver. nginx (configuration example) is a good choice as well.

PHP

PHP ist die Programmiersprache, in welcher MediaWiki geschrieben ist und die auch benötigt wird, um die Software auszuführen.

MediaWiki ist nicht kompatibel mit PHP 7.4.0 - 7.4.2 aufgrund eines Upstream-Bugs. Use PHP 7.4.3+ instead. Siehe task T246594 für weitere Informationen.
If using PHP8 we recommend using MediaWiki 1.38.4+ or the upcoming MediaWiki 1.39.0+. PHP8 is not in use by Wikimedia wikis, and thus gets less testing, but other groups do use MediaWiki with PHP8 without issue. If you encounter any bugs when using MediaWiki with PHP8 please report them. Siehe task T248925 für weitere Informationen.
  • Die folgenden Erweiterungen werden benötigt:
  • Beachte, dass all diese Erweiterungen standardmäßig in PHP aktiviert sind.
  • In den meisten Debian/Ubuntu-basierten Distributionen wird das php-mysql-Paket benötigt, wenn du willst, dass MediaWiki MySQL verwendet.
  • Einige Features von MediaWiki benötigen möglicherweise PHP-Funktionen, die externe Prozesse wie das Thumbnailing von Bilder ausführen, die einige günstige Hoster üblicherweise deaktivieren. Bitte beachte dies, wenn du planst, MediaWiki auf einem Shared Webhosting-Dienst zu installieren.
  • MediaWiki-Erweiterungen benötigen möglicherweise zusätzliche PHP-Erweiterungen. So braucht beispielsweise VisualEditor Unterstützung für libcurl (php-curl auf Debian/Ubuntu-basierten Distributionen).

Wenn du PHP von der Quelle kompilieren musst, dann schaue nach Kompilierungsoptionen (die MediaWiki beeinflussen) unter PHP-Einrichtung nach.

Datenbankserver

MediaWiki speichert den gesamten Text und die Daten (Artikel, Einzelheiten der Benutzer, Systemmeldungen) in einer Datenbank, welche zusammen mit anderen webbasierten Anwendungen genutzt werden kann (z.B. phpBB, usw.). Du benötigst einen der folgenden Datenbankserver für den Einsatz der neuesten Version von MediaWiki:

Using MariaDB or MySQL is recommended as Wikimedia uses MariaDB. Any other database servers are less tested and you may likely run into some bugs.

  Warnung: Seit MediaWiki 1.34 unterstützen wir nicht mehr die Verwendung mit den Handbuch:Oracle und Handbuch:Microsoft SQL Server . Wir raten dringend, diese nicht mehr zu verwenden.

Einige Anwender finden es hilfreich zusätzlich ein Softwarepaket wie phpMyAdmin (MySQL/MariaDB) oder phpPgAdmin (Postgres) zu installieren, um den Datenbankserver besser verwalten zu können. Some Hosterdienste also provide such software.

Hardwareanforderungen

Die empfohlenen minimalen Anforderungen für eine Ein-Computer-Website sind 256 MB RAM und 85 MB Speicherplatz. Dies wird jedoch für eine verkehrsreiche öffentliche Seite oder eine Seite mit Upload-Möglichkeit nicht ausreichen. Einige Anwender berichteten jedoch, dass sie MediaWiki auf Computern mit 48 MB RAM laufen ließen.

Die Größe der Installation kann um etwa 50MB bei Entwicklerversionen und um etwa 26MB bei Installationen für Endnutzer reduziert werden. Siehe Manual:Reduce size of the installation .

Optionale Abhängigkeiten

Siehe auch