Шаблон:DownloadMediaWiki

This page is a translated version of the page Template:DownloadMediaWiki and the translation is 100% complete.

Скачать MediaWiki 1.39.0 (.zip)

Скачать вместо этого .tar.gz

Помощь со скачиванием

Его можно извлечь в большинстве операционных систем без установки какого-либо дополнительного программного обеспечения и он обычно рекомендуется для пользователей Windows.

Пользователи 7-Zip: Обратите внимание, что до 2021 года 7-Zip не мог правильно извлекать файлы .tar.gz (T257102). Рекомендуется сначала обновиться до последней версии.

Пользователи macOS: Обратите внимание, что в The Unarchiver не может правильно извлечь файлы .tar.gz (T258716). Можно использовать Archive Utility.

Все версии

Для пользователей MediaWiki версий 1.36, версии 1.34 и раннее: Эти версии больше не поддерживаются. Пожалуйста, обновите MediaWiki до новой версии:

Лицензия

MediaWiki — свободное программное обеспечение распространяемое под 2 версией GNU General Public License. Поскольку эта программа лицензируется безвозмездно, не предоставляется никаких гарантий, в той степени, в какой это допускается действующим законодательством. Подробности читайте в полном тексте GNU GPL версии 2.

Системные требования

MediaWiki требует PHP 7.4.3+, программное обеспечение веб-сервера, и либо MariaDB 10.3.0+, MySQL 5.7.0+, SQLite 3.8.0+ или PostgreSQL 10.0+. Рекомендуется использовать MariaDB или MySQL, поскольку Викимедиа использует MariaDB. Любые другие серверы баз данных менее протестированы, и вы, вероятно, столкнетесь с некоторыми ошибками.

Более подробную информацию можно найти в системных требованиях и совместимости.

MediaWiki несовместима с версиями PHP 7.4.0 - 7.4.2 из-за ошибки в самом PHP. Вместо этого используйте PHP 7.4.3+. См. задача T246594 для более детальной информации.
При использовании PHP8 мы рекомендуем использовать MediaWiki 1.38.4+ или готовящуюся версию MediaWiki 1.39.0+. PHP8 не используется вики-сайтами Викимедиа, поэтому тестируется меньше, но другие группы без проблем используют MediaWiki с PHP8. Если вы столкнулись с какими-либо ошибками при использовании MediaWiki с PHP8, пожалуйста, сообщите о них. Дополнительную информацию смотрите в разделе задача T248925.