قالب:تنزيل برمجيات ميدياويكي

This page is a translated version of the page Template:DownloadMediaWiki and the translation is 100% complete.

نزل ميدياويكي 1.39.0 (.zip)

نزل ‎.tar.gz بدلًا منه

مساعدة بخصوص التنزيل

يمكن لأغلب الحواسيب استخلاص ملف zip دون الحاجة لتنصيب برمجيات إضافية.

مستخدمو 7 زيب: لاحظ أنه قبل سنة 2021، كان برنامج 7 زيب غير قادر على استخلاص ملفات ‎.tar.gz استخلاصًا صحيحًا (T257102). نحبّذ تحديث البرنامج إلى أحدث إصدار أولًا.

مستخدمو نظام macOS: لاحظ أن The Unarchiver غير قادر على استخلاص ملفات ‎.tar.gz استخلاصًا صحيحًا (T258716). يمكن استخدام برنامج Archive Utility بديلا عنه.

كافة الإصدارات

إلى مستخدمي برمجيات ميدياويكي الإصدارات 1.36 و1.34 وما قبلهما: لم نعد ندعم هذه الإصدارات. يرجى التحديث إلى إصدار أحدث من برمجيات ميدياويكي:

الرخصة

برمجيات ميدياويكي هي برمجيات حرة مجانية مرخصة بموجب النسخة 2 من رخصة جنو العمومية. ومنذ أن برمجيات ميدياويكي مرخصة دون مقابل، لا توجد ضمانات إلى الحد الذي تسمح به القوانين المنطبقة. اقرأ النص الكامل لرخصة جنو العمومية النسخة 2 لمزيد من التفاصيل.

متطلبات النظام

تتطلب برمجيات ميدياويكي بي إتش بي 7.4.3‎+‎ و برمجيات خادوم ويب وأي من MariaDB 10.3.0+ أو MySQL 5.7.0+ أو SQLite 3.8.0+ أو PostgreSQL 10.0+. نوصي باستخدام MariaDB أو MySQL منذ أن برمجيات ميدياويكي تستخدم MariaDB. لم يجري اختبار أية خوادم قواعد بيانات أخرى بما يكفي ويجوز أن تتعرض لحدوث أعطال.

لمزيد من المعلومات يرجى قراءة الصفحات التي تتناول متطلبات النظام وكذا التوافق.

برمجيات ميدياويكي ليست متوافقة مع إصدارات بي إتش بي من رقم 7.4.0 - 7.4.2 بسبب خلل تقني في برمجيات بي إتش بي ذاتها. استخدم بي إتش بي 7.4.3+ بدلا من ذلك. طالع مهمة T246594 لمزيد من المعلومات.
If using PHP8 we recommend using MediaWiki 1.38.4+ or the upcoming MediaWiki 1.39.0+. PHP8 is not in use by Wikimedia wikis, and thus gets less testing, but other groups do use MediaWiki with PHP8 without issue. If you encounter any bugs when using MediaWiki with PHP8 please report them. See مهمة T248925 for more information.