Skin:Vector/2022

This page is a translated version of the page Skin:Vector/2022 and the translation is 100% complete.
Diese Oberfläche ist üblicherweise in MediaWiki 1.38 und darüber enthalten. Daher muss sie nicht erneut heruntergeladen werden. Allerdings müssen die folgenden Anweisungen trotzdem beachtet werden.
MediaWiki-Skins-Handbuch - Kategorie
OOjs UI icon layout-ltr.svg
Vector 2022
Freigabestatus: stabil
Sticky header logged in.png
Compatibility policy Snapshots releases along with MediaWiki. Master is not backwards compatible.
Composer mediawiki/vector-skin
Lizenz GNU General Public License 2.0 oder neuer
Herunterladen
Beispiel https://fr.wikipedia.org/
https://vi.wikipedia.org/
https://test.wikipedia.org/
Parameter
Übersetze den Vector/2022 skin wenn es auf translatewiki.net verfügbar ist
Prüfe die Benutzungs- und Versionsmatrix.
Vagrant-Rolle vector
Probleme : Offene Aufgaben · Einen Fehler melden

Vector 2022 ist die zweite Evolution des MediaWiki-Vector-Skin und ist in der Entwicklung als Teil des Desktopverbesserungs-Projekts und in MediaWiki 1.38 . Es ist der Standardskin für verschiedene Wikimedia-Projekte.

Installation

  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens Vector im Ordner skins/ ablegen.
  • Ergänze folgenden Code am Ende deiner LocalSettings.php:
wfLoadSkin( 'Vector' );
  •   Erledigt - Navigiere zu Special:Version in deinem Wiki, um zu überprüfen, ob der Skin erfolgreich installiert ist.

Optional dependencies

Vector 2022 makes use of the following extensions, though none are hard requirements:

Hinweis zur Version 1.38

Die Version 1.38 markiert die offizielle Unterstützung von Drittanbietern für den Skin, aber zwischen 1.36 und 1.38 war der Skin auf eigenes Risiko für Drittanbieter verfügbar.

Wenn eine Website den neuen Vector zwischen 1.36 und 1.38 verwendet hat, wird sie beim Upgrade auf die Version 1.38 auf Probleme stoßen. Dies ist unvermeidlich und einer der Gründe, warum wir von der Verwendung des neuen Skins vor 1.38 abgeraten haben.

Wenn Sie Vector 2022 als Standard-Skin verwendet haben, müssen Sie nach dem Upgrade wgDefaultSkin in LocalSettings.php aktualisieren:

$wgDefaultSkin = 'vector-2022';

Wenn die Website den Nutzern die Möglichkeit gibt, sich für die neue Darstellung zu entscheiden, wird diesen Nutzern das alte Vector angezeigt, und sie müssten erneut Special:Preferences aufwenden, um ihre Skin-Präferenz auf Vector 2022 zu aktualisieren.

Für große Wikis, bei denen eine Änderung des Skins für die angemeldeten Benutzer störend sein kann, sollten Sie ein Wartungsskript schreiben, um die bestehenden Datenbankeinstellungen zu aktualisieren. Siehe T299104 und Erweiterung:WikimediaMaintenance für weitere Details.

Configuration parameters

Note Vector has several unstable feature flags that may disappear at any time. Most of these feature flags relate to incomplete features. We do not recommend changing any feature flag from its default value unless listed here.

wgVectorMaxWidthOptions

Can be used to configure whether the max-width applies. Relatively stable at this point.

VectorLanguageInMainPageHeader

Controls whether the language button shows on the main page in the header.