Manual:WrapOldPasswords.php

This page is a translated version of the page Manual:WrapOldPasswords.php and the translation is 62% complete.
MediaWiki sürümü:
1.24

Ayrıntılar

wrapOldPasswords.php dosyası, belirli bir türdeki tüm parolaları eski türün etrafına saran belirli bir katman türüne sarmak için bir bakım betiğidir.

Gerekirse, eski MD5 karma işlemi $wgPasswordDefault ögesini 'B' olarak değiştirerek geri yüklenebilir.

Kullanıcılarınızın oturum açmasını beklemek istemiyorsanız, bu bakım betiği 'pbkdf2-legacyA' veya 'pbkdf2-legacyB' içindeki tüm parolaları sarabilir.

Options/Arguments

Seçenek Açıklama Required?
--type Dönüştürmek için yazın. Bu $wgPasswordConfig öğesinin katmanlı türlerinden biri olmalıdır, yani pbkdf2-legacyA veya pbkdf2-legacyB. Gerekli
--verbose Yürütme sırasında ayrıntılı çıkış oluşturun. İsteğe bağlı
--update Actually wrap passwords İsteğe bağlı

Kullanım

php maintenance/wrapOldPasswords.php --type PasswordConfigKey [ --verbose| --update ]

Dry run

Terminal
$ php maintenance/wrapOldPasswords.php --type pbkdf2-legacyA

7 user rows found using old password formats. Run script again with --update to update these rows

Updating the password

Terminal
$ php maintenance/wrapOldPasswords.php --type pbkdf2-legacyA --update

7 users rows updated.

See also