Extension:VEForAll

This page is a translated version of the page Extension:VEForAll and the translation is 93% complete.
Other languages:
MediaWiki 拡張機能マニュアル
OOjs UI icon advanced-invert.svg
VEForAll
リリースの状態: 安定
説明 他の拡張機能でビジュアルエディターをフォームのテキストエリアに組み込むための JavaScript 機能を定義する
作者 Pierre Boutet, Clément Flipo, Ike Hecht, Yaron Koren and Cindy Cicalese
最新バージョン 0.4 (2021年11月)
互換性ポリシー master は後方互換性を維持しています。
MediaWiki 1.32+
データベースの変更 いいえ
Composer mediawiki/v-e-for-all
ライセンス GNU 一般公衆利用許諾書 2.0 以降
ダウンロード
translatewiki.net で翻訳を利用できる場合は、VEForAll 拡張機能の翻訳にご協力ください

使用状況とバージョン マトリクスを確認してください。

問題点 未解決のタスク · バグを報告

The VEForAll ("VisualEditor For All") extension allows other extensions to incorporate the VisualEditor interface into textareas for user editing.

This extension does not directly impact the user interface. Rather, it defines a JavaScript function (called "applyVisualEditor()") that can be called by other extensions on their textareas. At the moment, CommentStreams , Page Forms and FlexForm can make use of VEForAll.

当然のことですが、この拡張機能を動作させるためには、VisualEditor 拡張機能をインストールする必要があります。

ダウンロード

You can download the VEForAll code, in .zip format, here.

また、MediaWiki のソース コード リポジトリから Git 経由で直接ダウンロードすることもできます。 コマンドラインから、以下のように呼び出せます:

git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/VEForAll

You can also view the code online here.

インストール

To install this extension, create a 'VEForAll' directory (either by extracting a compressed file or downloading via Git), and place this directory within the main MediaWiki 'extensions' directory. Then, in the file 'LocalSettings.php', add the following line:

wfLoadExtension( 'VEForAll' );

Using VEForAll with other extensions

VEForAll can currently be used with the CommentStreams , Page Forms and FlexForm extensions:

  • For CommentStreams (version 4.5 or higher), you simply need to have VEForAll (and VisualEditor) installed, and then textareas for entering comments will automatically get the VisualEditor interface.
  • For Page Forms (version 4.7 or higher), in the form definition, add |editor=visualeditor to the tag for any textarea input (including the "free text" input), and the VisualEditor interface should show up when viewing that form.
  • For FlexForm, use editor="ve" when defining a textarea. E.g. <_input type="textarea" editor="ve"></_input>. You can have as many VE editors on a page as needed and you can even add a menu/button to the VE Editor that will open another VE Editor.

設定

既定では、ツールバーはテキストエリアの下部に表示されます。 In Page Forms, you can instead display it at the top by adding |class=toolbarOnTop to the textarea's tag in the form definition.

You can use the "VEForAllToolbarConfigNormal" hook to customize the display of the VisualEditor toolbar. For example, to add "math" and "media" buttons, add the following to LocalSettings.php:

$wgHooks['VEForAllToolbarConfigNormal'][] = function( &$defaultConfigNormal ) {
        $defaultConfigNormal[4]['include'][] = 'math';
        $defaultConfigNormal[4]['include'][] = 'media';
};

既知の問題点

一部の外装では、ドロップダウンがかなり圧縮されて表示される場合があります。 CSS を少し修正することで、これを解決できます:

table.multipleTemplateInstanceTable {  	border-collapse: inherit; }

作者とクレジット情報

VEForAll is heavily based on the (now-obsolete) VEForPageForm extension by Pierre Boutet and Clément Flipo. Some work to make the code more generic was done by Ike Hecht, Yaron Koren and Cindy Cicalese. Others who contributed to the code include Anysite and Mark Hershberger. VEForAll also includes code from the StructuredDiscussions extension.

バージョン履歴

  • 0.1 - (2018-05-03) - Initial version
  • 0.2 - (2020-02-07) - Made toolbar configurable; removed dependency on the Math extension; fixed submitting values for "focused" textareas; set VE direction (RTL/LTR) correctly; added "veForAll.targetCreated" hook; many other fixes
  • 0.3 - (2021-05-05) - Improved support for MW 1.35+; removed support for MW < 1.29; added handling for Page Forms "max height" parameter; added escaping of pipes in table wikitext within Page Forms template fields; bug fixes
  • 0.4 - (2021-11-03) - Improved support for MW 1.34+; removed support for MW < 1.32; fixes for pipe escaping