Extension:DiscourseSsoConsumer

PluggableAuth Icon.svg This extension requires the PluggableAuth extension to be installed first.
MediaWiki extensions manual
OOjs UI icon advanced.svg
DiscourseSsoConsumer
Release status: beta
Implementation User identity , User rights , Database
Description Provides authentication via the SSO Provider API of a Discourse discussion forum
Author(s) Matt Marjanovic (CtapMaddogtalk)
Maintainer(s) Center for Transparent Analysis and Policy
Latest version 2.0.0 (2021-12-07)
MediaWiki 1.35+
PHP 7.4+
Database changes Yes
Composer centertap/discourse-sso-consumer
Tables discourse_sso_consumer_meta
discourse_sso_consumer_link
License GNU General Public License 3.0 or later
Download
README.md
RELEASE-NOTES.md
Translate the DiscourseSsoConsumer extension if it is available at translatewiki.net

Check usage and version matrix.

The DiscourseSsoConsumer extension is a PluggableAuth plugin that allows a MediaWiki site to authenticate users via a Discourse discussion forum, using its SSO provider API (also known as "Discourse Connect").

InstallationEdit

This extension can be installed using composer. This will automatically install the PluggableAuth extension, which is a prerequisite for DiscourseSsoConsumer.

The complete installation and configuration instructions can be found in README.md.

Configuration parametersEdit

The complete description of configuration parameters can be found in README.md.