Open main menu

Compatibility/Software for using MediaWiki

Software for using MediaWikiEdit

Desktop browsersEdit

Grade AEdit

1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master
  Internet Explorer 9+
  Firefox 4+
  Safari 5.0+
  Opera 11.6+
  Chrome 17+
Internet Explorer 6-8  
Internet Explorer <= 5.5  
  Firefox 2  
  Firefox 3  
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master
  Safari 3  
  Opera 11.0-11.5  
  Opera 9-11.0  
  Chrome 5-9  
  Chrome 1-5  
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master

All current major web browsers are compatible with most versions of MediaWiki. "Grade A" functionality is maintained for the following browser requirements:

  • Internet Explorer 9+
  • Firefox 4+
  • Safari 5.0+
  • Opera 11.6+
  • Chrome 17+

However, no version of Internet Explorer, and only recent versions of Chrom(e|ium) and Firefox, are fully supported for all features (like VisualEditor): extension pages often have more information.

Grade BEdit

1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master
Internet Explorer 6+
  Firefox 2.0+
  Safari 3+
  Opera 10+
  Chrome 9+
Internet Explorer <= 5.5  
  Chrome 5-9  
  Chrome 1-5  
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master

Basic compatibility is maintained for legacy versions of web browsers until they fall to a sufficiently low level of utilization (typically under 0.1%). In particular, compatibility is currently maintained for:

  • Internet Explorer 6+
  • Firefox 2.0+
  • Safari 3.0+
  • Opera 10.0+
  • Chrome 9+

Browsers which are not explicitly marked as incompatible are often generally compatible. Support is not guaranteed for old non-standards compatible browsers and issues with those browsers might not be resolved. Security vulnerabilities affecting any browser will be addressed if possible.

Mobile browsersEdit

Mobile view is supported by the MobileFrontend extension.

Grade AEdit

1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master
  Mobile Safari 5+
  Android Browser 2.3+
  Chrome for Android 18+
  Firefox for Android, latest
  IE Mobile 9+
  Blackberry Webkit 7+
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master

"Grade A" functionality means full support, including JavaScript features. All current major mobile web browsers are compatible with most versions of MediaWiki. "Grade A" functionality is maintained for the following browsers:

  • Mobile Safari 5+ (that includes Chrome for iOS since it uses Safari's engine)
  • Android Browser 2.3+ (image uploads in 2.3, everything supported in 4+)
  • Chrome for Android 18+
  • Firefox for Android, latest version
  • IE Mobile 9+ (no editing and image uploads in 9.0, everything supported in 10+)
  • Blackberry Webkit 7+
  • UC Browser and UC Mini (not in speed mode), latest version

Browsers from this list are tested as often as possible and bug fixes for them are a priority.

Grade BEdit

1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master
  Opera Mini 4+
  NetFront 3+
  Ovi Browser 2+
  Nokia Browser 7+
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 master

"Grade B" functionality means basic reading and navigation. A web browser is usually degraded to grade B when it is used by less than 0.5% of users. This level of compatibility is currently maintained for:

  • Lower versions of browsers in Grade A
  • Opera Mini 4+
  • NetFront 3+
  • Ovi Browser 2+
  • Nokia Browser 7+
  • UC Mini (speed mode)

Browsers from this list are not tested on a regular basis, but user-reported bugs for them are accepted.

CSSEdit

MediaWiki is compatible with user agents which do not process CSS3 markup. Some additional features are available to browsers which can process these styles.

JavaScriptEdit

MediaWiki is accessible to user agents which do not process JavaScript. MediaWiki degrades gracefully and all essential functionality works without JavaScript, although some things might be less convenient.

Text-only browsersEdit

MediaWiki is accessible to text-only user agents such as Lynx, and to interpreters such as JAWS. Some functionality is reduced.

Note that older text-only browsers like Lynx are not representative of text-to-speech assistive tools like JAWS and other screen readers, which tie into browsers such as Internet Explorer and Firefox through their accessibility interfaces and make use of CSS styles, dynamic JavaScript, etc.

NotesEdit

  • Software marked in blue is supported while software marked in orange is not supported.

See alsoEdit