Open main menu

Bozonbozon

Joined 29 November 2016

– Hi, are u still using Parsoid on shared hosting? user:Azot944

– Yes, I have installed it a few days ago, and it works fine. Bozonbozon (talk) 13:16, 2 December 2016 (UTC)

– Could you help me edit the necessary files? I also have installed Parsoid but old version and now this instruction don't working.

– I am far from being an expert, so I can only list what I have done (with respect to the seemingly unchanged repository under the link above):

  • In .gitignore, I have simply deleted two lines, the one for localsettings.js, and the one for config.yaml.
  • In localsettings.js, I uncommented the lines below, as well as changed the URI of the API to the appropriate value (the location of api.php of your wiki):
            parsoidConfig.setMwApi({
                    uri: 'http://your.wiki.tld/wiki/api.php',
            });
  • In config.yaml, I touched only one line, the one defining the same URI:
            uri: 'http://your.wiki.tld/wiki/api.php'

Note that I altered two configuration files, but obviously only one has effect. I do not know for sure which is that lucky one (and I have absolutely no time for experiments ;-)), but the instructions say that principally localsettings.js is for older versions while config.yaml is for newer ones.

Are these changes different from the ones you have made? If yes, please let me know the results of these, because if they also do not work for you, there is something further to clarify before these instructions are written to the article. A first guess is resetting the domain: settings (see here), but first try the above. Maybe a look at heroku logs is also helpful (I do not remember how they are accessed, but Google helps). Bozonbozon (talk) 03:22, 3 December 2016 (UTC)

(And excuse me for text rearrangements. A bulleted list would be good for formatting a conversation, but when it contains more than bare text, everything gets messed up by the totally weird behaviour of newline characters in the source. This can be considered a structural bug in MediaWiki and several other wiki softwares, by my opinion: there is no generally usable list format in wikitext. You have to default to html.)

And a small update: Do not forget the VisualEditor things in LocalSettings.php. Bozonbozon (talk) 23:10, 3 December 2016 (UTC)

- Thanks! Everythings work very well! Also updated the instructions :)