Open main menu

Topic on Talk:Phabricator/Help

< Talk:Phabricator/Help

I am registered on Phabricator but unable to log in

8
Summary by AKlapper (WMF)

Solved by LDAP password change/reset

Ineuw (talkcontribs)
I am registered on Phabricator with the same account and password as Mediawiki, but unable to log in. Tried to re-register, but both my login name and password are used already, meaning that I am registered
Whatamidoing (WMF) (talkcontribs)

Did you type your username in the big "LDAP Username" fields? (Don't do that. Instead, click the button underneath them, which has the MediaWiki sunflower on it.)

AKlapper (WMF) (talkcontribs)

https://phabricator.wikimedia.org/p/ineuw/ shows that Ineuw registered via their Gerrit/wikitech/LDAP account and not via their mediawiki.org/SUL/OAuth account. Hence they must use the big "LDAP Username" field and enter the username and password also used for Gerrit and wikitech.wikimedia.org. As the "MediaWiki sunflower" won't work here (no SUL account attached to the Phabricator account).

Ineuw (talkcontribs)

Please look at my uploaded screenshots. File:Sequence of login attempts.jpg .

My apologies to User:Whatamidoing (WMF) but as I attempted every variation of logins, I forgot to reply. The first instructions through Mediawiki did not work, so I posted on your talk page. Since seeing is believing, I assembled a series of screen shots to demonstrate what happens. These images were made before I saw your reply here.

I deleted all the cookies and saved logins to Mediawiki and Phabricator.

Frame 1. (very narrow strip on top) shows that I am logged in to Mediawiki

Frame 2. I clicked on the Phabricator login from the Phabricator/Help#Creating your account which got me to the OAuth screen. When I clicked on Allow . . .

Frame 3. Login or Register to Wikimedia Phabricator and I clicked on the Mediawiki link at the bottom which led to

Frame 4. The login screen of Phabricator, which recognized my existence, but displayed the message that something is wrong. I used my email address to get confirmation from one of the screens but Phabricator did not recognize it as a registered email.

At this point I logged it to Github (I have an account) and made it to Phabricator, checked my email address if it's correct, proceeded, but then I was blocked again when tried to login to Mediawiki. So I searched for Phabricator/Mediawiki login on the web and . . . .

Frame 5. This is what I got. A registration screen but, no login option no contact option, no email option.

I think I also bookmarked all pages.

P.S: It's the same problem when attempting to login to Wikitech.

AKlapper (WMF) (talkcontribs)

There are two authentication methods available. When you registered your Phabricator account Ineuw, it was registered by linking it to your Gerrit/wikitech.wikimedia.org/LDAP account (which is the non-default way). Hence it's irrelevant whether you are logged in on mediawiki.org or not - Your screenshots (thanks!) show that you tried to register a new account Ineuw in Phabricator via the (default) SUL/mw.org method so you get an error as that account already exists in Phabricator.

Please log in on either gerrit.wikimedia.org or wikitech.wikimedia.org. Then enter the same username and password into the corresponding LDAP fields in Phabricator. Ignore the button with the sunflower. :)

AKlapper (WMF) (talkcontribs)

Wikimedia Phabricator does not offer login via Github. You probably went to some other Phabricator instance on the internet. The 4th screenshot is definitely not Wikimedia Phabricator as the logo is different.

Ineuw (talkcontribs)

Mystery solved. I found the problem by requesting a password renewal. The password rule at both sites changed to minimum 10 characters. I logged in at the end of August (21st is my last backup) and perhaps even early September with an 8 character password. This solved the issue at both Wikitech and at Phabricator.

Thanks for your kind attention and patience.

AKlapper (WMF) (talkcontribs)

Great to hear it works for you now!