Topic on Project:Support desk

Upgrading from 1.26 to 1.27 breaks putting pages in a category

Summary by MarkAHershberger

Putting pages in the category now runs in the job queue. (talkcontribs)

I upgraded my wiki from 1.26 to 1.27. Now, when I put a page in a category, I get the category at the bottom of the page. However, it is not placed in that category. I'm not sure why this has happened. I have narrowed it down to the upgrade. Any suggestions on how to fix this?


AhmadF.Cheema (talkcontribs)

Browse to:


If there are "jobs" remaining, then until the category job has not been executed, the category page will not update.

See Manual:Job queue

MwColin (talkcontribs)

Thanks. There are 5040 jobs. Is there a way to force it to run. As I am using SMW and forms, I want it in the correct category so that it can be immediately edited with the form.

AhmadF.Cheema (talkcontribs)

In SSH, go to the MediaWiki directory and run: php maintenance/runJobs.php

Note that 5000+ jobs will take quite some time to execute.

Also, for future purposes better to setup a cron job for this.

MwColin (talkcontribs)

Thanks again. This cleared the queue and didn't take long. I read somewhere else that this piece of code has been moved to the job queue in 1.27. Therefore the behaviour has changed. With 1.26 it was added immediately to the category, now you have to wait for the job to run. I would like the previous behaviour, so will look at methods to get the queue to be cleared as quickly as possible.

AhmadF.Cheema (talkcontribs)
MwColin (talkcontribs)

Thanks again. I tried this but the page is still not "instantly" added to the category. It appears to be added about 5 minutes later. I suppose this is a new "feature". And perhaps my way of doing things, adding it to a category and then immediately wanting to edit the page, is not a common way of working. I like to save page that is automatically generated with a form, and then edit it to add text. However, I can live with this. Thanks a lot for the help.