Topic on Project:Support desk (talkcontribs)

1: Complete novice.

2: I have downloaded MediaWiki 1.24, renamed the root file (ThamesBoats) and uploaded it to my host site. ( When I try to open MediaWiki in the browser I get the following message - MediaWiki 1.24 internal error MediaWiki 1.24 requires at least PHP version 5.3.2, you are using PHP 5.2.17. I have downloaded PHP 5.4.35 and now have the root file php-5.4.35 unpacked on my desktop. I can find no instruction in the MediaWiki installation document to tell me what to do with, or where to place the php-5.4.35 file. How do the two work together.

(I am already using php for a forum site -, so 1: above is not strictly true!)

MarkAHershberger (talkcontribs)

You have to configure your host to use the updated PHP. Usually, this requires root access to the server.

You should contact the people providing web hosting for you to see if you can get them to upgrade PHP or how you can use a newer version.

If you can't do that, then you should download 1.19 which is an LTS supported till this next April and should work for your version of PHP. (talkcontribs)

Thanks for this. Host server now upgraded PHP to v5.3 New error message displayed searching for config file in browser - ( -

[3cce11cc] [no req] Exception from line 61 of /websites/123reg/LinuxPackage23/wi/nd/so/ MediaWiki does not function when magic quotes are enabled.


  1. 0 /websites/123reg/LinuxPackage23/wi/nd/so/ WebRequest->__construct()
  2. 1 /websites/123reg/LinuxPackage23/wi/nd/so/ require_once(string)
  3. 2 /websites/123reg/LinuxPackage23/wi/nd/so/ require(string)
  4. 3 {main}

any ideas?

Florianschmidtwelzow (talkcontribs)

> MediaWiki does not function when magic quotes are enabled.

You need to contact your host to disable php's magic quotes, which is deprecated since php 5.3. MediaWiki will not be working with magic quotes enabled, see Release_notes/1.24.

Reply to "php"