Open main menu

Topic on Project:Support desk

< Project:Support desk

wfLoadExtensionMessages() removed from 1.21.1?

15
70.176.119.200 (talkcontribs)

My web host recently prompted me to upgrade to MW 1.21.1, so I did. Now several of my pages are broken. The error message is:

Fatal error: Call to undefined function wfLoadExtensionMessages() in [path to one of my installed extensions]

Was this function removed, or do I just need to re-enable it somehow?

MarkAHershberger (talkcontribs)

You need to upgrade your extensions, too.

70.176.119.200 (talkcontribs)

The extension that's giving me problems isn't very well maintained. I've fixed a few bugs in it myself, and I'm probably capable of fixing this. But in order to do so, I need to know why wfLoadExtensionMessages() was removed, and what replaced it.

IAlex (talkcontribs)

You may simply remove the call to wfLoadExtensionMessages() and it will continue to work, you don't need to replace it by something else.

109.238.67.2 (talkcontribs)

I have the same problem. This may fix the problem, but it doesn't answer Mark's question.

Nick

IAlex (talkcontribs)

It was removed. wfLoadExtensionMessages() used to load messages from the given extension so that they could be used. Since the addition of the "localisation cache" in 1.16 messages are always loaded and thus calling wfLoadExtensionMessages() was useless (for more details see r52503).

That was the point of the last part of my previous post.

70.176.119.200 (talkcontribs)

Oh, that's good news. Thanks for the info.

Katkov Yury (talkcontribs)

Removing this function have made alsmost all the older extensions incompatible with the current version of MW. It think it's better to create an empty function since there is a lot of people who are not propgrammers and will be just disappointed that it doesn't work.

Pchestek (talkcontribs)

Thanks for the info, it helped me out too.

FlightTime (talkcontribs)

Removing wfLoadExtensionMessages( 'CategoryBrowser' ); also worked for me.

Thanx

79.153.9.9 (talkcontribs)

Same here. I had this problem after upgrading from 1.15 to 1.22

Thanks!

112.198.197.170 (talkcontribs)

Better to insert the following line function wfLoadExtensionMessages(){ }

in the LocalSettings.php after the line require_once( "$IP/extensions/WikiSync/WikiSync.php" );

In this way you will not need to edit the source of the Extension. Also, if in future you get PHP error "duplicate function wfLoadExtensionMessages ..." (or so) after you install another Extension, you will know that you cannot use both or make another remedy.

167.230.96.9 (talkcontribs)

What other bugs did you find/fix? I just installed this extension and fixed the bugs listed on the extension's page. Just curious to know what other bugs are there.

130.11.160.145 (talkcontribs)

I had this same exact problem from my Delete Page Permanently extension. Turns out it was my short url settings. Not the extension.

Reply to "wfLoadExtensionMessages() removed from 1.21.1?"