Vorlage:ExtensionInstall

This page is a translated version of the page Template:ExtensionInstall and the translation is 100% complete.
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens ExtensionInstall im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/ExtensionInstall/ExtensionInstall.php";
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.
Vorlagendokumentation

Verwendung

[Edit template data]

Template parameters

This template prefers inline formatting of parameters.

ParameterDescriptionTypeStatus
Extension name1

Set the extension name manually.

Default
The current page name without namespace prefix.
Auto value
{{ROOTPAGENAME}}
Stringoptional
Vagrant role namevagrant

If given, shows how to install extension with the Vagrant's enable-role command

Auto value
Stringoptional
Download linkdownload-link

Overwrite the download link.

Default
Link to Special:ExtensionDistributor with the extension name.
URLoptional
LocalSettings earlylocalsettingsearly

Pass custom php code that the user should include in [[LocalSettings.php]] before the extension is loaded.

Example
$wgUseAjax = true; //must be included before the extension is loaded
Unknownoptional
LocalSettingslocalsettings

Pass custom php code that the user should include in [[LocalSettings.php]].

Example
$wgUseAjax = true;
Unknownoptional
Database updatedb-update

If the extension has one or more database tables that need to be created through [[update.php]], set this parameter to any value.

Default
false
Booleanoptional
Composercomposer

If the extension uses [[Composer]] to manage dependencies, set this parameter to any value.

Default
false
Booleanoptional
Custom steps 0custom-steps0

Additional steps before download, e.g. other required extensions (as an unordered "* list")

Contentoptional
Custom stepscustom-steps

Additional steps (as an unordered "* list")

Contentoptional
Supports registrationregistration

Changes the template to use <code>wfLoadExtension()</code> if it supports registration. Set to any value if the extension supports registration, or to <code>required</code> if it <em>only</em> supports registration and doesn't support the old-style of loading.

Stringoptional
No registration versionno-registration-version

The MediaWiki version for which extension registration should not be used

Default
1.24
Unknownoptional

Beispiele

Unten einige Beispiele, wie diese Vorlage zu verwenden ist:

Einfach

{{ExtensionInstall}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Name

{{ExtensionInstall|CategoryTree}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens CategoryTree im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/CategoryTree/CategoryTree.php";
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Herunterladen

{{ExtensionInstall
|download-link=[http://bits.wikimedia.org/example.zip Download]
}}
  • Die Download und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

LocalSettings

{{ExtensionInstall
|localsettings=
$wgUseAjax = true;
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    $wgUseAjax = true;
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

LocalSettings früher

{{ExtensionInstall
|localsettingsearly=
$wgUseAjax = true; // this must be included before the extension is loaded
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    $wgUseAjax = true; // this must be included before the extension is loaded
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Datenbank-Aktualisierung

{{ExtensionInstall
|db-update=Yes
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    
  • Führe das Aktualisierungsskript aus, welches automatisch die notwendigen Datenbanktabellen erstellt, die diese Erweiterung braucht.
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Composer

{{ExtensionInstall
|composer=Yes
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Wird von git aus installiert, ist Composer auszuführen, um PHP-Abhängigkeiten zu installieren, indem composer install --no-dev im Erweiterungsverzeichnis ausgeführt wird. (Siehe task T173141 für mögliche Komplikationen.)
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Anpassungsschritte

{{ExtensionInstall
|custom-steps=
* Lorem ipsum dolor sit amet
* Foo bar baz quux [[sandbox]]
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    require_once "$IP/extensions/MyExtension/MyExtension.php";
    
  • Lorem ipsum dolor sit amet
  • Foo bar baz quux sandbox
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Registrierung unterstützt

{{ExtensionInstall
|registration=1
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    wfLoadExtension( 'MyExtension' );
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Für Benutzer, die MediaWiki in der Version 1.24 und früher betreiben:

Die oben stehenden Anweisungen beschreiben die neue Installationsanweisung für diese Erweiterung unter der Verwendung von wfLoadExtension(). Wird diese Erweiterung in einer dieser früheren Versionen (MediaWiki 1.24 und früher)  – an Stelle von wfLoadExtension( 'MyExtension' ); – installiert, benutze:

require_once "$IP/extensions/MyExtension/MyExtension.php";

Setze empfohlene MediaWiki-Version für Registrierung

{{ExtensionInstall
|registration=1
|no-registration-version=1.25
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    wfLoadExtension( 'MyExtension' );
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Für Benutzer, die MediaWiki in der Version 1.25 und früher betreiben:

Die oben stehenden Anweisungen beschreiben die neue Installationsanweisung für diese Erweiterung unter der Verwendung von wfLoadExtension(). Wird diese Erweiterung in einer dieser früheren Versionen (MediaWiki 1.25 und früher)  – an Stelle von wfLoadExtension( 'MyExtension' ); – installiert, benutze:

require_once "$IP/extensions/MyExtension/MyExtension.php";

Registrierung erforderlich

{{ExtensionInstall
|registration=required
}}
  • Die Erweiterung herunterladen und die Datei(en) in ein Verzeichnis namens MyExtension im Ordner extensions/ ablegen.
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    wfLoadExtension( 'MyExtension' );
    
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Alles

{{ExtensionInstall|Example
|download-link=[http://bits.wikimedia.org/example.zip Download]
|vagrant=example
|localsettings=
$wgUseAjax = true;

|db-update=Yes
|composer=Yes
|custom-steps=
* Lorem ipsum dolor sit amet
* Foo bar baz quux [[sandbox]]
|registration=yes
}}
  • Die Download und die Datei(en) in ein Verzeichnis namens Example im Ordner extensions/ ablegen.
  • Wird von git aus installiert, ist Composer auszuführen, um PHP-Abhängigkeiten zu installieren, indem composer install --no-dev im Erweiterungsverzeichnis ausgeführt wird. (Siehe task T173141 für mögliche Komplikationen.)
  • Folgenden Code am Ende der LocalSettings.php einfügen:
    wfLoadExtension( 'Example' );
    $wgUseAjax = true;
    
  • Führe das Aktualisierungsskript aus, welches automatisch die notwendigen Datenbanktabellen erstellt, die diese Erweiterung braucht.
  • Lorem ipsum dolor sit amet
  • Foo bar baz quux sandbox
  • Yes Erledigt – Zu Special:Version in dem Wiki (bei Einstellung auf deutsch nach Spezial:Version) navigieren, um die erfolgreiche Installierung der Erweiterung zu überprüfen.

Für Benutzer, die MediaWiki in der Version 1.24 und früher betreiben:

Die oben stehenden Anweisungen beschreiben die neue Installationsanweisung für diese Erweiterung unter der Verwendung von wfLoadExtension(). Wird diese Erweiterung in einer dieser früheren Versionen (MediaWiki 1.24 und früher)  – an Stelle von wfLoadExtension( 'Example' ); – installiert, benutze:

require_once "$IP/extensions/Example/Example.php";


Vagrant-Installation:

  • Wird Vagrant benutzt, ist mit vagrant roles enable example --provision zu installieren