Police du support de PHP

This page is a translated version of the page Support policy for PHP and the translation is 100% complete.
Other languages:

Cette page décrit la politique de prise en charge de PHP telle qu'elle est appliquée pour le noyau MediaWiki et aux autres composants inclus avec sa distribution officielle.

Critères

Les nouvelles versions majeures de MediaWiki doivent prendre en charge au moins une version de PHP pour chacun des critères suivants :

  • Une version de PHP prise en charge par le groupe PHP upstream pour toute la durée de ce cycle de version majeure de MediaWiki (à partir de notre date prévue de diffusion de la version et jusqu'à la date de fin de vie prévue).
  • Une version de PHP fournie par un canal des versions LTS Debian Linux, qui sera supportée pendant la durée de cette version MediaWiki
  • Une version de PHP version fournie par un canal des versions LTS Ubuntu Linux, qui sera supportée durant la durée de cette version MediaWiki.

A cela s'ajoutent les restrictions applicables suivantes :

  • Pour chaque version LTS Debian Linux et Ubuntu Linux il doit exister au moins une version compatible de MediaWiki qui soit prise en charge à partir du début de la période où la distribution Linux est devenue LTS.
  • Sur l'échelle des temps, à aucun momment il ne doit y avoir au moins une combinaison de Debian Linux LTS et de MediaWiki où les deux se recouvrent sur une période de deux ans. Ceci permet donc à un administrateur de site, de garder une combinaison pendant deux ans (avec le support inclus), avant de passer à la combinaison suivante prise en charge. C'est la même chose pour Ubuntu Linux LTS.

Processus

En conservant le critère ci-dessus, les mainteneurs du noyau MediaWiki (tels qu'ils sont définis dans les règles des privilèges) sont libres d'ajouter ou d'abandonner le support de toute version supplémentaire de PHP sans avoir à faire intervenir TechCom ni son processu de RFC.

Le fait d'ajouter un support pour une version PHP peut se produire pour toute version (y compris pour les versions mineures et les versions de correction) et ceci sans préavis.

L'abandon du support d'une version PHP ne peut se produire que sur des versions majeures, et doit être annoncé sur Wikitech-l dans un fil de discussion dédié au moins deux semaines avant la modification de fusion sur la branche master de MediaWiki.

Si les mainteneurs ne peuvent arriver à un consensus à propos d'une modification proposée pour le support, ou si l'exemption du critère est souhaitée, la décision peut être remontée à TechCom en créant une tâche pour TechCom dans Phabricator, ou en contactant directement un membre de TechCom.

Meta

Cette règle a été établie par T228342, approuvée en septembre 2019 via le processus de RFC de TechCom, pour s'appliquer à MediaWiki 1.34 et aux suivants.

Voir aussi