Meza/Requirements

The requirements for installing Meza are as follows.

  1. System Requirements:
    1. 4GB RAM minimum suggested. For trying out Meza with 2GB RAM or even less, see Meza/Setup on a low-memory system
    2. 2.5GB minimum available free space in /opt (Linux)
  2. Operating system:
    1. Linux, either CentOS 7 or RedHat 7 (Debian 9 has beta support on the 32.x branch)
    2. Mac, Windows, or Linux using the Vagrant or Virtual Box install instructions
  3. Minimal install: Attempting to install it on a Linux server with many other packages already installed may not work properly due to conflicts
  4. Mail: meza does not configure any mail services. A mail service such as postfix needs to be configured separately from meza in order for the meza deployed wikis to send mail from the system. If a service like postfix can not be configured at the system level, basic outbound SMTP can be configured within Meza via the $wgSMTP mediawiki variable provided in a file such as /opt/config-meza/public/postLocalSettings.d/smtp.php however while using using $wgSMTP may be adequate for basic mediawiki email notification, it may not work with extensions that require a system level mail service.

See Meza/Known Enterprise Challenges for challenges, conflicts, and common errors.