Manual:$wgBadUserAgents

Language, regional and character encoding settings: $wgBadUserAgents
Array of user agents that should be automatically blocked.
Introduced in version:pre 1.1.0
Removed in version:1.2.0 (r2473)
Allowed values:Unspecified
Default value:false

DetailsEdit

User agent/range blocking. Blocks all users using a particular user agent, possibly restricted to a set of IP ranges.

You can't block all user agents by leaving $wgBadUserAgents blank. That would block nothing.

This setting holds an array of user agents that should be automatically blocked.

e.g. array( 'OfflineExplorer/1.0' )

See alsoEdit