Extension:WikiHiero/pl

This page is a translated version of the page Extension:WikiHiero and the translation is 3% complete.
Podręcznik rozszerzeń MediaWiki
OOjs UI icon advanced-invert.svg
WikiHiero
Status wydania: stabilne
Wikihiero.png
Realizacja Tag
Opis Enables the use of hieroglyphs with additional syntaxes
Autor(zy) Guillaume Blanchard, Max Semenik and others
Ostatnia wersja continuous updates
Polityka zgodności Snapshots releases along with MediaWiki. Master is not backward compatible.
MediaWiki >= 1.35.0
Zmiany w bazie danych Nie
Licencja GNU General Public License 2.0 or later
Pobieranie
README
Przykład
A2B4C6D8
‎<hiero>
Przetłumacz rozszerzenie WikiHiero jeżeli jest dostępne na translatewiki.net
Problemy Otwarte zadania · Zgłoś błąd

The WikiHiero extension allows the addition of Ancient Egyptian hieroglyphs from text written in accordance with the Hieroglyph coding manual syntax.

See the Hieroglyph coding manual for details. [need link]

In brief:

- - separator
: - subdivision
* - juxtaposition
! - end of line
\ - reverse an asymmetric character
V - rotate character [only a few are supported, e.g. Y1, Y1V]

Each hieroglyph is given a unique code:

  • A letter [A-Z + Aa] that represents the hieroglyph category (human, god, bird, etc.)
  • A number that represents the rank in this category [1-...]

This unique code is an extension of Gardiner's list of hieroglyphs.

The Hieroglyph coding manual allows the use of the more common phonemes as well as unique code.

For details, see WikiHiero's syntax .

Installation

  • Pobierz i umieść plik(i) w katalogu o nazwie wikihiero w folderze extensions/.
  • Dodaj poniższy kod na dole twojego pliku LocalSettings.php :
    wfLoadExtension( 'wikihiero' );
    
  • Yes Zrobione – Przejdź do Special:Version na twojej wiki, aby sprawdzić czy rozszerzenie zostało pomyślnie zainstalowane.

Do użytkowników używających wersji MediaWiki 1.26 lub wcześniejszej:

Powyższe instrukcje opisują nowy sposób instalowania tego rozszerzenia z wykorzystaniem wfLoadExtension(). Jeżeli chcesz zainstalować to rozszerzenie we wcześniejszych wersjach (MediaWiki 1.26 i wcześniejsze), zamiast wfLoadExtension( 'wikihiero' ); użyj:

require_once "$IP/extensions/wikihiero/wikihiero.php";

Testing

Test with some example wiki text.

The following code:

<hiero>A1</hiero>

should produce the following output:

A1

License

Zobacz też