Open main menu

Extension:UpdateMediaWiki/pl

This page is a translated version of the page Extension:UpdateMediaWiki and the translation is 15% complete.

Other languages:
Deutsch • ‎English • ‎Nederlands • ‎español • ‎polski • ‎中文 • ‎日本語
Podręcznik rozszerzeń MediaWiki
OOjs UI icon advanced.svg
updateMediaWiki
Status wydania: beta
Realizacja Special page , MyWiki
Opis Allows administrators and authorized users upgrade from a special page
Autor(zy) Miguel Peláez (Miguel2706talk)
Ostatnia wersja 0.3.0 (2014-04-03)
MediaWiki 1.25+
PHP 5.3+
Zmiany w bazie danych Nie
Licencja GPL v2 or later
Pobieranie
updatecore
Przetłumacz rozszerzenie UpdateMediaWiki jeżeli jest dostępne na translatewiki.net
Sprawdź wykorzystywanie i matrycę wersji.
Problemy Otwarte zadania · Zgłoś błąd

The UpdateMediaWiki extension allows administrators and authorized users upgrade from a special page MediaWiki.

Instalacja

  • Pobierz i umieść plik(i) w katalogu o nazwie UpdateMediaWiki w swoim katalogu extensions/.
  • Dodaj poniższy kod na dole swojego pliku LocalSettings.php:
    wfLoadExtension( 'UpdateMediaWiki' );
    
  •   Zrobione – Przejdź do Special:Version na swojej wiki, aby sprawdzić czy rozszerzenie zostało pomyślnie zainstalowane.

Do użytkowników mających wersję MediaWiki 1.24 lub wcześniejszą:

Powyższe instrukcje opisują nowy sposób instalowania tego rozszerzenia, poprzez wfLoadExtension(). Jeżeli chcesz zainstalować to rozszerzenie we wcześniejszych wersjach (MediaWiki 1.24 i wcześniejsze), zamiast wfLoadExtension( 'UpdateMediaWiki' ); użyj:

require_once "$IP/extensions/UpdateMediaWiki/UpdateMediaWiki.php";

User rights

Once you installed the extension, you'll have to set up the user rights in LocalSettings.php .

Right Opis
updatecore Update the MediaWiki Core

For example, the following sample configuration would allow sysops to do everything they want with UpdateMediaWiki:

$wgGroupPermissions['sysop']['updatecore'] = true;

Usage

To update from this extension, go to "Special:Updatemediawiki". Permission "updatecore" is required to do so.