Open main menu

Extension:SecureAuth

MediaWiki extensions manual
OOjs UI icon advanced.svg
SecureAuth
Release status: experimental
Implementation Special page
Author(s) Jayprakash12345talk
Latest version 1.0
MediaWiki 1.29+
PHP 5.3+
License GNU General Public License 2.0 or later
Download
Translate the SecureAuth extension if it is available at translatewiki.net
Check usage and version matrix.
Issues Open tasks · Report a bug

This is currently under development.

InstallationEdit

  • Download and place the file(s) in a directory called SecureAuth in your extensions/ folder.
  • Add the following code at the bottom of your LocalSettings.php:
    wfLoadExtension( 'SecureAuth' );
    
  •   Done – Navigate to Special:Version on your wiki to verify that the extension is successfully installed.

To users running MediaWiki 1.24 or earlier:

The instructions above describe the new way of installing this extension using wfLoadExtension(). If you need to install this extension on these earlier versions (MediaWiki 1.24 and earlier), instead of wfLoadExtension( 'SecureAuth' );, you need to use:

require_once "$IP/extensions/SecureAuth/SecureAuth.php";