Topic on Talk:Talk pages project/Replying

Bluetpp (WMF) (talkcontribs)

User NhacNy2412 in the Vietnamese community reported a bug: "When I press Shift button, the cursor will jump back to a random place in the paragraph. Press once and it jumps back once. The place it jumps back usually is the text/link that I pasted in. When I use the old Vector, this error happens only when I paste something, but now when I use the new Vector, it also happens when I bold or italicize texts".

Please check the video here and help her fix it. Thank you so much.

PPelberg (WMF) (talkcontribs)

hi @Bluetpp (WMF) – can you please ask @NhacNy2412 to repeat the steps shown in the video with Safemode enabled and share whether doing so resolved the issue? Below are instructions for enabling Safemode that you can share.

By the way, the screen recording is a big help – thank you for including it. ^ _ ^

Enabling safemode

  1. Revisit the page where you experienced the issue
  2. Add the safemode parameter (?safemode=1) to the URL. E.g. https://vi.wikipedia.org/wiki/Wikipedia:Th%E1%BA%A3o_lu%E1%BA%ADn?safemode=1
  3. Open the Reply Tool
  4. Try drafting a comment
Bluetpp (WMF) (talkcontribs)

@PPelberg (WMF) Hi, after following your instruction with the safemode, that user found out that maybe the problem is caused by GoogleTrans gadget: "Open a popup window allowing the translation from Vietnamese to other languages (use the cursor to highlight then press Shift)", because when using safemode or turn this gadget off, the error doesn't happen anymore.


So I guess it's fixed, thank you so much for your help! I just figured that fixing errors will be way easier if you guys can "see" the problem, so!