Topic on Project:Support desk

Can't login. No error messages.

Summary by Ciencia Al Poder

Check Manual:How to debug/Login problems and provide more information on a new post

Bouncingmolar (talkcontribs)

I try to login and it just refreshes the login page with no error and not logged in. I can view the contents of my wiki but unable to edit since login doesn't work.

Is there a folder/database permission which could have changed which would do this?

Also, when installing a test wiki i get a blank screen when clicking the initial setup button. The PHP log says:

PHP Warning: require(.../wiki/languages/Language.php): failed to open stream: Permission denied in on line 1146

mediawiki 1.19.2 php 5.4 MySql 5.5.3

Bouncingmolar (talkcontribs)
Ciencia Al Poder (talkcontribs)

Try to do perform a search through the search bar and let us know if the search works, and if it fails see if the search terms appear already in the search bar of the search results page.

Bouncingmolar (talkcontribs)

thanks for looking! search bar seems to work fine. However i notice that all the wikimarkup and html is included in the search results.

edit: oh.. Just realised that is normal after googling it.

btw my test wiki is 1.20.3 if that makes any difference.

Ciencia Al Poder (talkcontribs)

Well, that's really strange. Something that may cause this is the loss of session information.

Make sure PHP session configuration variables are set correctly to allow session storage. For example, upload a php file with this contents to the server:

if (!isset($_SESSION['count'])) {
  $_SESSION['count'] = 0;
} else {


Browse that page and it should print you a number increasing every time you reload the page. If not, something is wrongly configured in the php.ini.

Bouncingmolar (talkcontribs)

The test worked: +1 each refresh.

Not sure if this is relevant, but a web developer recently installed joomla in a different directory. Also they wiped my htaccess.txt file. I deactivated the htaccess.txt file in the joomla directory just in case with no improvement.

Ciencia Al Poder (talkcontribs)

Check the value of Manual:Configuration settings#Cookies. If any of those variables are defined, try to comment them, since in general their default value is already OK.

If your wiki is public a link to it may help.

Bawolff (talkcontribs)

Maybe something is really wrong with your web server and somehow POST requests are being broken. (Most session related issues should raise some sort of error on special:userlogin)

Do you have short urls enabled in any sort of way that's weird or different from the standard way of doing it? If you enabled editing for anonoymous users, does anon editing go through?

Bouncingmolar (talkcontribs)

I have not changed anything to do with the cookies.

I have tried installing a new wiki in a separate directory (1.20.3) and i can not get past the link "setup the wiki now" ---> http error 500

I think that whatever problem is preventing me from installing the new wiki is also affecting my old wiki. I'm getting my host support to look at it right now. He is looking at permalinks to see if that is the problem. (talkcontribs)

I had this problem and I have found a solution: In my LocalSettings.PHP file I had a line of code:

$wgSessionsInMemcached = true; # optional

THIS is causing the problem! I changed the true to false and it worked. Do you have this setting in your localsettings.php? and did this work for you also?

So in closing: I uploaded my old wiki to a new server and suddenly couldn't login and with no error message. The local settings had a line of code (which was added by me a long time ago) and on the new server they didn't allow the caching. Turned the "True" to False and I can now login.

Bouncingmolar (talkcontribs)

Wow thanks for replying (a year ago) anonymous person. I can't seem to find that setting in my localsettings.php

The closest thing I've got is:

##shared memory settings

$wgMainCacheType = CACHE_NONE;

$wgMemCachedServers = array(); (talkcontribs)

having this problem now, 8 years in the future!

Ciencia Al Poder (talkcontribs)