Topic on Extension talk:LDAP Authentication

193.47.161.196 (talkcontribs)

Hello,

we are currently running MediaWiki 1.16.0 with XAMPP, PHP 5.3.3, MySQL 5.1.49 on a XP machine for testing. Now we want to add the latest snapshot of LDAP Authentication. Every time we activate the LDAP Authentication plugin, we get the following error:

Strict Standards: Declaration of LdapAuthenticationPlugin::modifyUITemplate() should be compatible with 
that of AuthPlugin::modifyUITemplate() in E:\Team\xampp\htdocs\mediawiki\extensions\LdapAuthentication\LdapAuthentication.php on line 116

Strict Standards: Declaration of LdapAuthenticationPlugin::setPassword() should be compatible with 
that of AuthPlugin::setPassword() in E:\Team\xampp\htdocs\mediawiki\extensions\LdapAuthentication\LdapAuthentication.php on line 116

Strict Standards: Declaration of LdapAuthenticationPlugin::addUser() should be compatible with 
that of AuthPlugin::addUser() in E:\Team\xampp\htdocs\mediawiki\extensions\LdapAuthentication\LdapAuthentication.php on line 116

Strict Standards: Declaration of LdapAuthenticationPlugin::initUser() should be compatible with 
that of AuthPlugin::initUser() in E:\Team\xampp\htdocs\mediawiki\extensions\LdapAuthentication\LdapAuthentication.php on line 116

We tried all the other versions of the plugin with the same result. Google didn’t help and we have no idea what we are doing wrong. Any help would be welcome.

Thanks Jo

Ryan lane (talkcontribs)

I haven't gotten a chance to test with php 5.3 yet. I'll try to get to this soon.

95.62.170.97 (talkcontribs)
114.37.152.140 (talkcontribs)

I have encountered the same warning message after I setup the SMTP for sending emails. These messages appeared when new user registers and old user asking for new password. However, the email did go through my personal email account.

Mediawiki 1.16.0
XAMPP ver:Linux 1.7.4-beta6

Strict Standards: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /opt/lampp/lib/php/Mail/smtp.php on line 167

Strict Standards: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /opt/lampp/lib/php/Net/SMTP.php on line 290

Strict Standards: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /opt/lampp/lib/php/Net/SMTP.php on line 295

Strict Standards: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /opt/lampp/lib/php/Net/SMTP.php on line 298
216.99.53.251 (talkcontribs)

I encountered the same error after upgrading to PHP 5.3.4 and LDAP Authentication Plugin (Version 1.2b (alpha)). I haven't bothered to look at the code but assume that it's something along the lines of the LdapAuthenticationPlugin class overloading not matching exactly the AuthPlugin class (built in to MW). Because I was having difficulties using my original php.ini configuration, I had created a new one using the php.ini-development. The defaults error level for php.ini-development is: E_ALL | E_STRICT, which is causing the errors. If you set it to something else (like the default of E_ALL & ~E_NOTICE) that does not show E_STRICT errors, the problem goes completely away and this plugin works.

Look for the error_reporting = line in your php.ini (I've changed mine to error_reporting = E_ALL & ~E_NOTICE and this resolved the problem for me).


-Kevin

Reply to ""Strict Standards" error"