Templat:Compatibility browser

This page is a translated version of the page Template:Compatibility browser and the translation is 36% complete.
Outdated translations are marked like this.
Matriks dukungan peramban as of Mei 2024 l · b · s
Peramban Chrome Edge Firefox Safari iOS Android
Modern (kelas A) Last three years' versions (2021) 11.1+ (2018) 11.3+ (2018) 5+ (2014)
Dasar (kelas C) 49+ (2016) 79+ (2020) 49+ (2016) 10+ (2016) 10+ (2016) 5+ (2014)[note 1]
Tidak Diketahui (kelas X) Semua peramban lainnya
Practical implications as of Mei 2024
Platform Minimum OS or device Supported modern browser
Android Moto G (1st generation) (2013)
Google Nexus 4 (2012)
Android 5.1, Chrome 91-95
Samsung Galaxy S5 (2014) Android 6.0, Chrome 91-106
iOS iPhone 5s (2013) iOS Mobile Safari 11.3 - 12 (2018-2023)[note 2]
Linux Debian 10 Buster (2019) firefox-esr 102
Ubuntu 18.04 LTS (2018) firefox (current), chromium-browser (current)
macOS OS X 10.11 El Capitan (2015-2018) Safari 11.1, Chrome 91-103
macOS 10.13 High Sierra (2017-2020) Safari 11.1-13, Firefox 115 ESR, Chrome 91-116
macOS 10.15 Catalina (2019-2022) Safari 13-15, current Firefox, Chrome 91 to current
Windows Windows 7 (2009-2020) Edge 91-109, Firefox 115 ESR, Chrome 91-109

List of changes, most recent first:

  • As of MediaWiki 1.43, Basic support is removed for Internet Explorer 11 (IE 11), Edge 12–18, Chrome 31–48, Firefox 39–48, Safari 9 on macOS and iOS, and Opera. Chromium versions of Opera will probably see exactly the same experience as before. T288287
  • As of 2023, the support targets have been re-stated; for Chrome and Chrome-based browsers, this is now the last three years' versions (covering three years rather than three months); for Firefox, this is now the current and previous LTS versions (reaching approximately the same time range). T178356
  • As of MediaWiki 1.41, Modern support is removed for Internet Explorer 11, macOS and iOS Safari 9–10, and Firefox 39–53. T178356
  • As of MediaWiki 1.39, Basic support is removed for Internet Explorer 9-10, Firefox 27-38, and Android 4.3-4.4 T293298, T297313, T290815
  • Per MediaWiki 1.36, dukungan Dasar dihapus untuk Firefox 3-26, Internet Explorer 8, Safari 3-8, iOS (Safari) 5-8, Android 3.0-4.2, Chrome 1-30, dan Opera 15-18. T248061, T262946, T266866
  • Per MediaWiki 1.36, dukungan Modern dihapus untuk Android 4.1-4.2, iOS 6.1-8, dan Safari 5.1-8. T266866
  • Sejak MediaWiki 1.35, dukungan Dasar dihapus untuk Internet Explorer 6-7 dan Android 2. T232563, T249788
  • Sejak MediaWiki 1.31, JavaScript untuk Internet Explorer 10 telah dimatikan. T187869
  • Sejak MediaWiki 1.29, JavaScript untuk Internet Explorer 9 telah dimatikan beserta peramban-peramaban non-ES5 lainnya. T128115
  • Sejak MediaWiki 1.27, JavaScript untuk Internet Explorer 8 telah dimatikan. T118303, Wikitech-ambassadors message
  • Sejak MediaWiki 1.24, JavaScript untuk Internet Explorer 6 dan 7 telah dimatikan. gerrit:152072, gerrit:152128, Wikitech-ambassadors message

Notes

  1. Note this refers to the stock Android browser. For Chrome for Android, provided that you're running Chrome 49+, it requires Android 4.1+(2012). For Firefox for Android, provided that you're running Firefox 49+, it requires Android 4.0+(2011).
  2. iOS 11 dropped support for iPhone 5 and older devices
Dokumentasi templat

Penggunaan

{{Compatibility browser}}

Prints the compatibility of browsers.

Template parameters[Edit template data]

This template prefers block formatting of parameters.

ParameterDescriptionTypeStatus
No parameters specified

Lihat pula