About this board

Post your feedback about using the visual editor. Learn how to report problems clearly.

Need more attention? Report directly in Phabricator. The Wikimedia Foundation does not provide support for installing VisualEditor on third-party wikis.

You can read the guide to optimize the visual editor on your site. The guide explains how to set up citation templates.

View open developer tasks Report a new bug in Phabricator

Previous page history was archived for backup purposes at VisualEditor/Feedback/LQT Archive 1 on 2015-07-30.

Named reference bug.

Jak86 (talkcontribs)

I noticed that this edit broke multiple named references. For example "Lynch02" is turned into "Lynch022", but its definition isn't renamed. So it gives the error message "The named reference Lynch022 was invoked but never defined". Is this caused by VisualEditor? Is it a known bug? I didn't make that edit and wasn't able to recreate the bug.

TheDJ (talkcontribs)

It seems to me someone just edited the page and made a mistake when modifying a reference. Mistakes happen, it's a wiki.

Kerry Raymond (talkcontribs)

No, it's a VE "bug". It has been reported for years but the VE implementers like to think it is a "benefit" and don't do anything about it. It occurs when you copy content with named citations between articles. If the citation name already exists in the destination article, VE assumes the incoming citation is a different citaton which must therefore have a different citation name and silently adds "2" (or "3" or ...) to make the citation name unique rather than reuse the existing citation. This may or may not be what the user wants, particularly if they are copying a number of bits of text from one article to another (when you usually want them to continue to share a citation). You really need a pop-up at that point to ask if the user wants to re-use the citation in the article already or create a separate one. This should be done showing the user the existing citation and the incoming citatation. As it is currently (and silently) implemented, you can end up with name, name2, name3, name4, all with the same citation because of the assumption they must all be made different. For me personally, it is a "bug" that creates an annoying number of duplicated citations over time in an article.

Reply to "Named reference bug."
Lfstevens (talkcontribs)

Let me edit the source of an existing reference in the editor. That way I can fix broken syntax or change the template.

Reply to "Ref editor"

overlapping text's lines

1 (talkcontribs)

the visualization of some pages presents a superimposing kinda bug

Reply to "overlapping text's lines"

Warning: Array to string conversion in D:\phpstudy_pro\mediawiki-1.41.1\extensions\VisualEditor\includes\Hooks.php on line 889

2408:8418:F20:8C59:24CD:C3C5:7E7E:E8E9 (talkcontribs)


Steps to reproduce the behavior:

  1. Install the theme according to
  2. In LocalSettings.php, set wfLoadSkin( 'Citizen' ); $wgDefaultSkin = "Citizen";
  3. A warning appears at the top of the page.
  4. See error

Expected Behavior

When I installed the Citizen theme and enabled it, a warning appeared at the very top of the page:

Warning: Array to string conversion in D:\phpstudy_pro\mediawiki-1.41.1\extensions\VisualEditor\includes\Hooks.php on line 889


Please complete the following information:

  • MediaWiki version v1.41.1
  • Server OS: Win10
  • Installed extensions and versions SemanticMediaWiki4.1
  • PHP version PHP 8.0.2 (cli) (built: Feb 3 2021 18:36:37) ( NTS Visual C++ 2019 x64 )
2603:C022:800E:6C00:505:FBEE:55E6:3764 (talkcontribs)

I also encountered this problem, have you solved it?

Reply to "Warning: Array to string conversion in D:\phpstudy_pro\mediawiki-1.41.1\extensions\VisualEditor\includes\Hooks.php on line 889"

Failing to recover unsaved changes

Closed Limelike Curves (talkcontribs)

The "unsaved changes" feature doesn't seem to be working consistently for me. Sometimes, nothing pops up at all when I try to edit a page I was in the process of fixing before a crash. Sometimes the changes are just replaced with a blank page. Anyone know what's wrong?

Reply to "Failing to recover unsaved changes"

Improving adding categories in VE

Samuel Wiki (talkcontribs)

I'm hoping adding categories could be improved in VisualEditor. Sometimes I copy and paste categories from somewhere else. I can't edit the name categories in VE though. eg. I paste "Australian companies established in 1997" and want to just change the year.

Secondly, I hoping the category search could be better. Right now I have to be very precise with what I type (different behaviour from adding a link to a article). I can't just type "Australian established 1997", I would have to type "Australian companies established in 199" to get a matching suggestion.

TheDJ (talkcontribs)

> I paste "Australian companies established in 1997" and want to just change the year.

I don't understand.. why can't you edit that ? There is no cursor in the text input to do so ?

> I have to be very precise This is going to be a problem even with search. There are a LOT of categories, so even with search it is very likely you are going to get a lot of noise in your search results. It should be possible however to allow for at least typos, if VE would use prefix search instead of title prefix matching. I have filed a ticket for that in phab:T359302.

I've also been thinking that one of the problems with adding categories, is that you can not choose a higher or lower level categories from a match. It might be a good idea if you could navigate the tree from the Category input field.

Samuel Wiki (talkcontribs)

Thanks for creating that ticket.

Regarding the first point... actually the scenario where I encountered that issue was I copied the source of one article to use as a starting point for another article. But when I switch to VE, I can't edit the categories.

The point I was trying to make was once a category is entered, it cannot be edited in VE. It would be great if they were editable.

TheDJ (talkcontribs)

You can edit the categories in VE by going to the drop down menu at the top right (three horizontal lines) and choosing: Categories. Or simply by clicking the previewed categories. You can then remove incorrect categories and add new ones.

TheDJ (talkcontribs)

Thinking about it again, I suspect that your problem is that when you are in the categories dialog, you don't want to have to type out from scratch the category name that you want ? This is why you speak of modifying (technically, there is no such thing, each category spelling exists and each of them is a valid category). I guess this would be helped if you could at least copy the text of the 'wrong' category name, but this is currently not possible in the dialog.

Samuel Wiki (talkcontribs)

Yeah, I was talking about the categories dialog and editing each individual category. It isn't very flexible at the moment. :/

Kerry Raymond (talkcontribs)

I agree. I find it easier to switch into source mode to edit categories than to do it in VE. Or use HotCat and don't bother with any editor. When you are in the category-edit pop-up in VE, you see a category name with a down arrow to the right which currently takes you a popup with a textbox for the sort key. What if it took you to a popup with two textboxes, one with the category name as editable text and the other as the sortkey? That might be a solution for the VE users.

Reply to "Improving adding categories in VE"

Cell alignment in Tables

Summary by Whatamidoing (WMF)
The-Pope (talkcontribs)

When you use the VisualEditor to copy a cell or a row in a table that has an |style="text-align: left;" | attached to it, to overrule the entire table's alignment, the style alignment isn't copied with the cell's content. Then, there is no way in the formatting tools to assign an alignment setting to the cell. Can this please be added? Be ideal if you could format an entire column, but even cell by cell would be useful.

Whatamidoing (WMF) (talkcontribs)

At this time, that type of formatting can only be done in a wikitext editor.

Kc3302 (talkcontribs)

If anyone in the future finds this like I did in October 2023: the only way to add cell formatting such as centering the text is still by editing the source code (wikitext editor). It can not be done in the Visual Editor. (talkcontribs)

It would be great to have centering available in visual editing

Reply to "Cell alignment in Tables"

Problemes à sourcer

Aleqc (talkcontribs)
Reply to "Problemes à sourcer"

Correcting links in tables in VE

Redfiona99 (talkcontribs)
Jdforrester (WMF) (talkcontribs)

Do you mean that, because they're wrapped using a template, you can only edit them as wikitext? If so, sadly that's a very long-known missing feature, T52355.

Redfiona99 (talkcontribs)

Hi, yes, I think that's what I mean. Thanks for answering :)

Reply to "Correcting links in tables in VE"

VisualEditor in 1.40.0 breaks categories tag

Olarp (talkcontribs)

Upgraded a 1.39.4 to 1.40.0

When editing with the VisualEditor, category tags like [[Category:System]] are converted and saved as [[index.php?title=Kategori:System]]. This of course breaks the page categorising. It's possible to re-edit the page, re-categorise it and it works but it will break again on the next edit.

The WikiText editor does not exhibit this behaviour. It correctly handles the category tags.

Restored the 1.39.4 from backup and tried re-installing a few times, but the upgrade to 1.40.0 produces this unwanted behaviour all times.

Here's rest of the software versions.

Produkt Version
MediaWiki 1.39.4
PHP 8.2.9 (cgi-fcgi)
MariaDB 10.10.2-MariaDB
ICU 71.1
Lua 5.1.5
Pygments 2.16.1

Browser used is Chrome Version 116.0.5845.110 (Officiell version) (arm64) on MacOS.

Whatamidoing (WMF) (talkcontribs) (talkcontribs)

i got the same problem (talkcontribs)

Freshly installed yesterday and can confirm this very annoying behaviour (talkcontribs)

Experiencing the same issue. Any solution? (talkcontribs)

MediaWiki 1.40.1, VisualEditor 0.1.2, issue witnessed. We plan to update MW to latest soon to find out if that fixes it. I can't tell the VE version that appears in ME vs the VE version that is posted on these pages. (talkcontribs)

+1 on this issue. Very annoying. (talkcontribs)

Yup. can confirm and is very frustrating

ESanders (WMF) (talkcontribs)

Is the issue present in 1.41?

2003:FD:2707:BC4F:88CD:7BE2:FD8:D93A (talkcontribs)

Yes, Issue still present in version 1.41.0. This is indeed very annoying.

Heinrich krebs (talkcontribs)

MediaWiki 1.41.0, VisualEditor 0.1.2

Fresh installation, issue witnessed.

Reply to "VisualEditor in 1.40.0 breaks categories tag"