MediaWiki 1.37

This page is a translated version of the page MediaWiki 1.37 and the translation is 100% complete.
Avertissement Avertissement : MediaWiki n'est pas encore compatible avec PHP 8. Voir tâche T248925 pour plus d'informations.
Avertissement Avertissement : MediaWiki 1.37.0 contient un problème de sécurité très grave. Veuillez effectuer une mise à niveau vers 1.37.1 ou une version ultérieure. Voir Version de sécurité 2021-12/FAQ pour plus d'informations.

MediaWiki 1.37 est une ancienne version de MediaWiki. Consultez le fichier Notes de version pour la liste complète des changements. Elle a été déployée sur les wikis de la Fondation Wikimedia dans les branches incrémentales « wmf » à partir d'avril 2021. La version stable 1.37.0 est sortie le 18 novembre 2021. Téléchargez mediawiki-1.38.2.tar.gz ou recopiez la branche REL1_37 de Git pour suivre cette version.

Nouvelles fonctionnalités

Changements dans l’API Action

  • (T280806) The API methods for fetching tokens which were deprecated in MediaWiki 1.24 have been removed. action=query&meta=tokens&type= should be used instead. Please note, some token types no longer exist, and you should just use type=csrf for those instead.
    • action=query&prop=info&intoken -> action=query&meta=tokens&type=csrf
    • action=tokens&type= -> action=query&meta=tokens&type=
    • action=query&list=recentchanges&rctoken -> action=query&meta=tokens&type=csrf
    • action=query&prop=revisions&rvtoken=rollback -> action=query&meta=tokens&type=rollback
    • action=query&meta=userinfo&uiprop=preferencestoken -> action=query&meta=tokens&type=csrf
    • action=query&list=users&ustoken=userrights -> action=query&meta=tokens&type=userrights

Changements de configuration

  • (T242768) The PasswordCannotMatchUsername password policy has been removed, please use PasswordCannotBeSubstringInUsername instead. If you have not customised your password policies, there will be nothing to do here.

Noouvelle configuration

  • $wgBrowserFormatDetection - This setting allows the enabling or disabling of automatic detection of possible phone numbers in a webpage in iOS Safari.
  • $wgParserEnableLegacyMediaDOM - This setting defaults to true, and enables the legacy media HTML structure in the output from the Parser. The alternative modern HTML structure for media is described at https://www.mediawiki.org/wiki/Parsing/Media_structure. In a future release of MediaWiki, this option will default to false, so it's a good idea to test this setting on your wiki early and report any issues.

Configuration modifiée

  • $wgContentHandlerTextFallback - This migration setting, which defines how to react if a plain text version of a non-text Content object is requested using ContentHandler::getContentText(), is deprecated.
  • $wgActions – This setting lets sysadmins override which actions can be used. It has been re-worked to support injecting dependencies into Action sub-classes as part of wider work on dependency injection. Previously, $wgActions was an array where the keys were the names of actions, and the values had the following impacts (for a given key 'Foo'):
    • `true`: use the class 'FooAction' unless for a specific page WikiPage::getActionOverrides() wants to override that action
    • a string: use the class with that name, and do not allow over-riding on a per-page basis
    • `false`: the action is disabled
    • a callable: use the Action instance returned by invoking that callback, and do not allow overriding on a per-page basis
    • an object: use that specific Action instance, and do not allow overriding on a per-page basis.

As part of T253078, values can now be arrays that are not callables, which are treated as ObjectFactory specs, allowing for services to be injected. Additionally, the distinction between values that allow per-page overrides and those that do not be removed - all actions can now be overridden on a per-page basis using WikiPage::getActionOverrides().

Configuration supprimée

Sous-pages