Handbuch:$wgUseAjax

This page is a translated version of the page Manual:$wgUseAjax and the translation is 40% complete.
Ajax: $wgUseAjax
AJAX-Unterstützung aktivieren.
Eingeführt in Version:1.6.0 (r13335)
Deprecated in version:1.31.0 (Gerrit change 427743; git #add25fea)
Entfernt in Version:1.38.0 (Gerrit change 741941; git #9bcd3fdf)
Erlaubte Werte:(boolean)
Standardwert:true (1.11+)
false (1.6-1.10)

Enables AJAX support. Required by some extensions and optional features.

Before 1.8.0, enabling Ajax support implicitly activated auto-suggestion for the search bar. Between 1.8 and 1.19 it had to be enabled explicitly: see $wgAjaxSearch (for 1.8 to 1.13) and $wgEnableMWSuggest (for 1.13 to 1.19). It returned to being implicitly activated when $wgEnableMWSuggest was removed in 1.20.

Siehe auch