Open main menu

Manual:$wgTidyInternal

This page is a translated version of the page Manual:$wgTidyInternal and the translation is 38% complete.
Other languages:
English • ‎español • ‎magyar • ‎polski • ‎中文 • ‎日本語
Tidy: $wgTidyInternal
Controls the use of the tidy extension to use an in-process tidy library instead of spawning a separate program.
Introducido en la versión:1.4.2
Deprecated in version:1.26.0 (Gerrit change 235401; git #2c6c954e)
Eliminado en la versión:1.33.0
Valores permitidos:(booleano)
Valor predeterminado:extension_loaded( 'tidy' )

Detalles

Normally you shouldn't need to override the setting except for debugging.

Tidy 2.0 is bundled with PHP5 by default (MediaWiki requires PHP5), but is not included in the ubuntu build of PHP5. To install it on Ubuntu 10.04 / PHP 5.2.x:

sudo apt-get install -y php5-dev libtidy-dev
svn co http://svn.php.net/repository/php/php- src/branches/PHP_5_2/ext/tidy/
cd tidy/
phpize
./configure
make
sudo make install
cd ../
rm -rf tidy/

Add extension=tidy.so to php.ini ; set $wgUseTidy = true; in LocalSettings.php ; finally, restart apache.