Extensión:UploadBlacklist

This page is a translated version of the page Extension:UploadBlacklist and the translation is 75% complete.
Other languages:
English • ‎Türkçe • ‎español • ‎polski • ‎中文 • ‎日本語
Extensión matemática MediaWiki
OOjs UI icon advanced.svg
UploadBlacklist
Estado de lanzamiento estable
Implementación Actividad de usuario
Descripción Allows configuration of an array with sha1 hashes which can then no longer be uploaded
Autor(es) Brion Vibber (Brion VIBBERtalk)
MediaWiki 1.25+
Licencia GNU Licencia Pública general 2.0 o más tarde
Descarga
  • $ubUploadBlacklist
Traduce el UploadBlacklist extensión si es disponible en translatewiki.net
Verificar uso y versión de la matriz.
Asuntos Tareas abiertas · Reportar un bug

Descarga

The extension can be retrieved directly from Git [?]:

  • Browse code
  • Some extensions have tags for stable releases.
  • Each branch is associated with a past MediaWiki release. There is also a "master" branch containing the latest alpha version (might require an alpha version of MediaWiki).

Extract the snapshot and place it in the extensions/UploadBlacklist/ directory of your MediaWiki installation.

If you are familiar with git and have shell access to your server, you can also obtain the extension as follows:

cd extensions/
git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/UploadBlacklist.git

Instalación

  • Descarga y extrae los archivos en el directorio «UploadBlacklist» dentro del directorio extensions/ existente.
  • Añade el siguiente código a tu LocalSettings.php (preferiblemente al final):
    wfLoadExtension( 'UploadBlacklist' );
    $ubUploadBlacklist = array ('hash1', 'hash2', ...)
    
  •   Hecho – Navega a Special:Version en tu wiki para verificar que la apariencia se haya instalado correctamente.

Para quienes usan MediaWiki 1.24 o versiones anteriores:

Estas instrucciones describen la nueva forma de instalar extensiones usando wfLoadExtension(). Si necesitas instalar esta extensión en versiones anteriores (MediaWiki 1.24 y anteriores), debes usar lo siguiente en lugar de wfLoadExtension( 'UploadBlacklist' );:

require_once "$IP/extensions/UploadBlacklist/UploadBlacklist.php";