Open main menu

Extension:SPARQLEditor


MediaWiki extensions manual
OOjs UI icon advanced.svg
SPARQLEditor
Release status: experimental
Implementation ContentHandler , Hook
Description Enabling SPARQL content model and improved editing for SPARQL
Author(s) Smalyshev (WMF)talk
License Unlicense
Download
README
wgSPARQLEditorNamespaces
Translate the SPARQLEditor extension if it is available at translatewiki.net
Check usage and version matrix.

The SPARQLEditor extension enables SPARQL content model and improved editing for SPARQL queries by enabling SPARQL mode in Extension:CodeEditor.

InstallationEdit

  • Download and place the file(s) in a directory called SPARQLEditor in your extensions/ folder.
  • Add the following code at the bottom of your LocalSettings.php:
    wfLoadExtension( 'SPARQLEditor' );
    
  •   Done – Navigate to Special:Version on your wiki to verify that the extension is successfully installed.

To users running MediaWiki 1.24 or earlier:

The instructions above describe the new way of installing this extension using wfLoadExtension(). If you need to install this extension on these earlier versions (MediaWiki 1.24 and earlier), instead of wfLoadExtension( 'SPARQLEditor' );, you need to use:

require_once "$IP/extensions/SPARQLEditor/SPARQLEditor.php";

Configuration parametersEdit

See alsoEdit