Extension:Buggy

MediaWiki extensions manual
OOjs UI icon advanced-invert.svg
Buggy
Release status: stable
Implementation Example
Description Generates errors.
Author(s) Gergő Tisza (Tgrtalk)
Latest version 0.1.0 (2015-02-01)
Compatibility policy Snapshots releases along with MediaWiki. Master is not backward compatible.
MediaWiki 1.25+
PHP 5.3+
Database changes No
License GNU General Public License 2.0 or later
Download
Translate the Buggy extension if it is available at translatewiki.net

Check usage and version matrix.

Issues Open tasks · Report a bug

The Buggy extension is intentionally buggy. This is useful when you want to test functionality related to bug handling or error reporting. It has originally been created to help with the testing of Sentry.

DownloadEdit

The extension can be retrieved directly from Git [?]:

  • Browse code
  • Some extensions have tags for stable releases.
  • Each branch is associated with a past MediaWiki release. There is also a "master" branch containing the latest alpha version (might require an alpha version of MediaWiki).

Extract the snapshot and place it in the extensions/Buggy/ directory of your MediaWiki installation.

If you are familiar with git and have shell access to your server, you can also obtain the extension as follows:

cd extensions/ git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/Buggy.git


InstallationEdit

  • Download and place the file(s) in a directory called Buggy in your extensions/ folder.
  • Add the following code at the bottom of your LocalSettings.php:
    wfLoadExtension( 'Buggy' );
    
  •   Done – Navigate to Special:Version on your wiki to verify that the extension is successfully installed.

UsageEdit

Errors are triggered with the buggy URL parameter. The vagrant role includes a test page.